aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: 20050801  (Read 3995 times)

microft

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 9
20050801
« on: August 02, 2005, 02:31:33 AM »

I get this everytime I start amuled

Code: [Select]
aMule terminated after throwing an instance of 'CInvalidParamsEx'
        Version: aMuled CVS using wxGTK2 v2.6.0 (Snapshot: Sat Jul 30 07:02:02 CEST 2005)
        what(): CRunTimeException::CInvalidArgsException: Not a valid range.

The configure options I use are:
--enable-kad-compile --enable-amulecmd --enable-webserver --disable-monolithic --enable-amule-daemon

Can anyone tell me what's the problem?
« Last Edit: August 02, 2005, 02:33:18 AM by microft »
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: 20050801
« Reply #1 on: August 02, 2005, 08:10:31 AM »

try if it helps not to compile kad-support, its not working anyway on daemon at the moment...

Kry: we should disable that if people do --disable-monolithic
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5823
Re: 20050801
« Reply #2 on: August 02, 2005, 03:50:37 PM »

It's Xaignar's fault!
Logged

Xaignar

  • Admin and Code Junky
  • Hero Member
  • *****
  • Karma: 19
  • Offline Offline
  • Posts: 1103
Re: 20050801
« Reply #3 on: August 02, 2005, 04:12:59 PM »

Try moving your ipfilter*.dat files out of ~/.aMule and let me know if that helps.
Logged

Xaignar

  • Admin and Code Junky
  • Hero Member
  • *****
  • Karma: 19
  • Offline Offline
  • Posts: 1103
Re: 20050801
« Reply #4 on: August 02, 2005, 04:55:47 PM »

It it is the problem I thought it was, then tomorrows snapshot should work properly. In either case, snapshots after the 30th also display backtraces for unhandled exceptions, so we should be able to diagnose it more easily if you upgrade.
Logged

microft

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 9
Re: 20050801
« Reply #5 on: August 02, 2005, 08:52:43 PM »

For a sec there I thought it might me a lib problem.
I'll way for tomorrow's snapshot and try it then.

Thanks!
« Last Edit: August 02, 2005, 08:53:04 PM by microft »
Logged

Xaignar

  • Admin and Code Junky
  • Hero Member
  • *****
  • Karma: 19
  • Offline Offline
  • Posts: 1103
Re: 20050801
« Reply #6 on: August 02, 2005, 11:21:28 PM »

As I said, if I am right, you don't have to wait for tomorrows snapshot. Simply move the ipfilter*.dat files out of your ~/.aMule/ dir and try to run aMule.
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1485
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: 20050801
« Reply #7 on: August 02, 2005, 11:47:14 PM »

Quote
Originally posted by Xaignar
In either case, snapshots after the 30th also display backtraces for unhandled exceptions, so we should be able to diagnose it more easily if you upgrade.

That's something I don't understand. I tinhk it's about 20050801 which is behind the 30th. Or which month do you mean?
Logged
Homefucking is killing prostitution

Xaignar

  • Admin and Code Junky
  • Hero Member
  • *****
  • Karma: 19
  • Offline Offline
  • Posts: 1103
Re: 20050801
« Reply #8 on: August 02, 2005, 11:53:34 PM »

Behold my amazing power of Reading The Text In Posts:
Quote
       Version: aMuled CVS using wxGTK2 v2.6.0 (Snapshot: Sat Jul 30 07:02:02 CEST 2005)
:P
Logged

microft

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 9
Re: 20050801
« Reply #9 on: August 03, 2005, 12:18:26 AM »

After this happened with 20050801, I tried using 20050730.
The same thing happened with both.

It seems to work without ipfilter, however, because I live in Portugal (DAMN!), I can't have aMule running without it   :( :( :( :( :( :( :( :(
Logged

Xaignar

  • Admin and Code Junky
  • Hero Member
  • *****
  • Karma: 19
  • Offline Offline
  • Posts: 1103
Re: 20050801
« Reply #10 on: August 03, 2005, 12:21:56 AM »

Ok, good (well, not for you :P), then it's fixed for tomorrow.
Logged