aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: 1 [2]

Author Topic: --> hat das schon jemand für Suse 8.1 compiliert?  (Read 5747 times)

Wurstbrot

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: --> hat das schon jemand für Suse 8.1 compiliert?
« Reply #15 on: November 09, 2005, 11:09:51 PM »

klappt leider noch nicht mit downloaden. folgende fehlermeldung kommt, wenn ich amuled starte:

/usr/local/bin # amuled
amuled: OnInit - starting timer
Initialising aMule
Checking if there is an instance already running...

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/board.php?boardid=67
If possible, please try to generate a real backtrace of this crash:
    http://www.amule.org/wiki/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMuled 2.0.3 using  v2.6.2 (Unicoded)
Running on: Linux 2.4.25 i686

[2] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.6.so.0[0x4014ed66]
[3] ?? in /lib/i686/libpthread.so.0 [0x40021a7a]
[4] ?? in /lib/i686/libc.so.6 [0x40394d88]
[5] wxString::wxString(char const*, wxMBConv&, unsigned) in /usr/lib/libwx_baseu-2.6.so.0[0x401089b1]
[6] wxMsgCatalogFile::FillHash(wxMessagesHash&, wxString const&, bool) const in /usr/lib/libwx_baseu-2.6.so.0[0x400e5634]
[7] wxMsgCatalog::Load(wchar_t const*, wchar_t const*, wchar_t const*, bool) in /usr/lib/libwx_baseu-2.6.so.0[0x400e5ce8]
[8] wxLocale::AddCatalog(wchar_t const*, wxLanguage, wchar_t const*) in /usr/lib/libwx_baseu-2.6.so.0[0x400e8d12]
[9] wxLocale::AddCatalog(wchar_t const*) in /usr/lib/libwx_baseu-2.6.so.0[0x400e8c92]
[10] otherfunctions::InitLocale(wxLocale&, int) in OtherFunctions.cpp:1628
[11] CamuleApp::Localize_mule() in amule.cpp:1362
[12] CamuleApp::OnInit() in amule.cpp:645
[13] CamuleDaemonApp::OnInit() in amuled.cpp:407
[14] wxAppConsole::CallOnInit() in app.h:87
[15] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.6.so.0[0x400e1de1]
[16] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.6.so.0[0x400e1eb2]
[17] main in amuled.cpp:124
[18] __libc_start_main in /lib/i686/libc.so.6[0x403834c2]
[19] std::basic_ostream >& std::operator<< >(std::basic_ostream >&, char) in :0

--------------------------------------------------------------------------------
Aborted
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4249
Re: --> hat das schon jemand für Suse 8.1 compiliert?
« Reply #16 on: November 10, 2005, 07:51:26 AM »

sieht nach einem tollen neuen feature in wxGTK aus...
wenn man die "falsche" locale hat auf der console crasht es

als "workaround" bis wxGTk sein problem wieder gelösst hast solltest du vor dem start von amuled eingeben

export LC_ALL=C

und dannach dann amuled starten, dann sollt es eigentlich net mehr crashen
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

Wurstbrot

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: --> hat das schon jemand für Suse 8.1 compiliert?
« Reply #17 on: November 11, 2005, 10:18:22 AM »

ich habe keinen Plan, was das Kommando bewirkt, aber funktionieren tut es. Danke nochmal (o:=

Jetzt muss ich es nur noch schaffen, dass auch amuleweb läuft. Alles Andere klappt.
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4249
Re: --> hat das schon jemand für Suse 8.1 compiliert?
« Reply #18 on: November 11, 2005, 02:57:54 PM »

http://wiki.amule.org :))

da hats eine komplette anleitung ;)
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

Wurstbrot

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: --> hat das schon jemand für Suse 8.1 compiliert?
« Reply #19 on: November 11, 2005, 07:22:46 PM »

ja, die kenne ich schon. hat mir aber bis jetzt nicht weitergeholfen, denn auf diese Weise vorgegangen bin ich bereits. danke übrigens für Deine Geduld (o:=
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4249
Re: --> hat das schon jemand für Suse 8.1 compiliert?
« Reply #20 on: November 11, 2005, 08:39:31 PM »

musst halt mal sagen wo das problem liegt ;)
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

Wurstbrot

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: --> hat das schon jemand für Suse 8.1 compiliert?
« Reply #21 on: November 12, 2005, 11:17:33 PM »

wenn ich das wüsste, würde ich es sagen. Ich habe aber ehrlich gesagt keine Ahnung und dieses Mal noch viel weniger Anhaltspunkte als die letzten Male, da ich keine Fehlermeldung bekomme. Ich versuche, auf den Rechner über x.x.x.x:4712 zuzugreifen (der Port, den ich für die Kommunikation gewählt habe), und dann fängt der Browser an zu laden, bleibt aber bei 0 KB stehen. Die Verbindung wird allerdings nicht getrennt, er lädt weiter, aber es kommen keine Daten an. Der Port ist in der Firewall freigegeben.
Logged

thedude0001

  • evil bugfinder ;)
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 830
Re: --> hat das schon jemand für Suse 8.1 compiliert?
« Reply #22 on: November 13, 2005, 02:30:20 AM »

OK, der Reihe nach (ich gehe mal von Standard-Ports aus):

amule / amuled haben keinen Webserver eingebaut wie emule, es ist ein separates Programm (amuleweb).
4712 ist der Port auf dem die Kommunikation zwischen amule und amuleweb / amulecmd abläuft, NICHT der Port auf den du mit deinem Webbrowser zugreifen mußt.
Wenn amuled und amuleweb laufen greif mit deinem Browser auf IP-Adresse:4711 zu...
Logged
Das Schlimme auf dieser Welt ist
daß die Dummen so selbstsicher sind
und die Gescheiten so voller Zweifel.

Wurstbrot

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: --> hat das schon jemand für Suse 8.1 compiliert?
« Reply #23 on: November 18, 2005, 12:59:16 PM »

wenn ich auf 4711 zugreife, dann sagt er nur, die seite könne nicht geladen werden. amuleweb läuft aber (zeigt er mir zumindest in den prozessen an) und der port ist auch freigegeben.
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4249
Re: --> hat das schon jemand für Suse 8.1 compiliert?
« Reply #24 on: November 18, 2005, 04:23:48 PM »

wie startest du amuleweb?

schau mal mit

netstat -ntpl

ob auf 4711 was hört...
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."
Pages: 1 [2]