aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: 1 [2]

Author Topic: Problemas cargando archivos temporales  (Read 6298 times)

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Problemas cargando archivos temporales
« Reply #15 on: December 08, 2005, 05:14:09 AM »

por cierto, dije:

> Así que "chmod o+w /media/sda1/eMule/Temp" (o donde sea que tengas el directorio Temp).

queria decir

chmod u+w ... (o chmod a+w ...)
Logged

d34th

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 18
Re: Problemas cargando archivos temporales
« Reply #16 on: December 08, 2005, 01:44:01 PM »

Aqui tienes el ls -l del directorio '/media'

Code: [Select]
lrwxrwxrwx   1 root root     6 2005-12-04 20:44 cdrom -> cdrom0
drwxr-xr-x   2 root root  4096 2005-12-04 20:44 cdrom0
drwxr-xr-x   2 root root  4096 2005-12-04 20:44 cdrom1
dr-xr-xr-x   1 root root  2048 1970-01-01 01:00 cdrom2
lrwxrwxrwx   1 root root     7 2005-12-04 20:44 floppy -> floppy0
drwxr-xr-x   2 root root  4096 2005-12-04 20:44 floppy0
drwxr-xr-x   2 root root  4096 2005-12-04 20:44 hda1
drwxrwx---  22 toni root 32768 1970-01-01 01:00 sda1
dr-x------   1 toni root  8192 2005-12-04 16:11 windows

el fstab
Code: [Select]
# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
/dev/hda5       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda7       /home           ext3    defaults        0       2
#/dev/hda1       /media/hda1     ntfs    defaults        0       0
#/dev/sda1       /media/sda1     vfat    uid=1000,utf8        0       0
/dev/hda6       none            swap    sw              0       0
/dev/hdb        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/hdc        /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/hdd        /media/cdrom2   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

/dev/hda1 /media/windows  ntfs uid=1000,nls=utf8 0 0
/dev/sda1       /media/sda1     vfat uid=1000,utf8,rw,umask=007,gid=root,quiet 0 0

Los permisos de temp


Code: [Select]
drwxr-x---   3 toni root   32768 2005-12-07 20:19 Temp
Los permisos de tentro de temp

Code: [Select]
-rwxrwx---  1 toni root 1001469960 2005-12-08 13:22 001.part
-rwxrwx---  1 toni root      56320 2005-12-08 13:56 001.part.met
-rwxrwx---  1 toni root      56258 2005-12-08 12:55 001.part.met.bak
-rwxrwx---  1 toni root  733919232 2005-12-06 11:39 002.part
-rwxrwx---  1 toni root       1499 2005-12-07 15:23 002.part.met
-rwxrwx---  1 toni root       1499 2005-12-07 15:23 002.part.met.bak
Logged

darksidex

  • Mule Farmer
  • Full Member
  • ***
  • Karma: 4
  • Offline Offline
  • Posts: 194
Re: Problemas cargando archivos temporales
« Reply #17 on: December 08, 2005, 04:11:04 PM »

Ahora te deja, ¿no? ya me he perdido

@Jacobo221, cuando montas una partición Fat32 (supongo que NTFS también), yo tengo entendido, y al menos en mi Ubuntu Breezy es así, que los ficheros y directorios de la partición heredan los permisos de el directorio donde lo has montado. Es decir que si el monta su partición Fat32 en /media/sda1 todos sus ficheros heredan los permisos (rwx------), perteneciendo a su usuario, por lo que no es necesario modificar los permisos con umask en el fstab.
Logged
First of all, I apologize for my bad english. :D

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Problemas cargando archivos temporales
« Reply #18 on: December 08, 2005, 07:09:04 PM »

darksidex, ah, pues quizas tengas razon. Yo he pasado por supoermount, submount, autofs y ahora con autofs4 y en todos ellos los permisos se sobreescriben. quizas por defecto el mount de-toda-la-vida no lo hace deberia mirarlo. no, lo mirare :) ahora me ha picado la curiosidad ;)
Logged

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Problemas cargando archivos temporales
« Reply #19 on: December 08, 2005, 07:11:27 PM »

d34th: y aMule sigue sin poder escribir los part files???
Logged

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Problemas cargando archivos temporales
« Reply #20 on: December 08, 2005, 07:14:30 PM »

y... no entiendo nada:

Permisos son
/dev/sda1       /media/sda1     vfat uid=1000,utf8,rw,umask=007,gid=root,quiet 0 0
es decir, rwxrwx---

o, al modo darksidex
drwxrwx---  22 toni root 32768 1970-01-01 01:00 sda1
es decir, rwxrwx---

por tanto, son por coj*nes rwxrwx---

sin embargo los directorios se revelan:
drwxr-x---   3 toni root   32768 2005-12-07 20:19 Temp

:S

pon dmask=007 junto a umask=007 (separado por coma)
Logged

d34th

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 18
Re: Problemas cargando archivos temporales
« Reply #21 on: December 09, 2005, 12:47:18 PM »

Parece que esta arreglado, al menos ya no me da errores

Al final la línea del fstab ha quedado asi

Code: [Select]
/dev/sda1       /media/sda1     vfat uid=1000,utf8,rw,umask=007,dmask=007,gid=root,quiet 0 0
Muchas gracias a todos por la ayuda

Si hay tengo algun problema mas ya volvere a dar la lata
Si no, es que todo funciona perfectamente  :)

Desde luedo problema raro de narices

Un saludo
Logged

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: Problemas cargando archivos temporales
« Reply #22 on: December 09, 2005, 03:20:11 PM »

;) guay. ya me empezaba a agobiar :D
Logged
Pages: 1 [2]