aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: 1.2.5 Uploads mit "nan kb/s"  (Read 5729 times)

Ano

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
1.2.5 Uploads mit "nan kb/s"
« on: February 13, 2004, 06:44:59 PM »

Hallo!

Seit der Version 1.2.5 koennen andere Nutzer nur etwa eine Minute nach Programmstart Dateien downloaden. Danach wird jeder Upload mit "nan kb/s" angezeigt und nach etwa 30 - 60s entfernt, ohne dass Daten uebertragen wurden?!
Leider habe ich trotz mehrfacher Suche im Internet nicht einen einzigen Hinweis auf dieses Verhalten gefunden.

- amule wxwindows2.4 von thermoman fuer woody
- debian gnu/linux 3.0r2 "woody" + backports von backports.org und anderen
- LowID, da firewalled

Ano
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: 1.2.5 Uploads mit "nan kb/s"
« Reply #1 on: February 13, 2004, 07:13:08 PM »

huh ??

bist irgendwie der einzige .. wie hoch ist dein upload limit ?

kannst du mal einen screenshot machen bitte ..

Ano

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: 1.2.5 Uploads mit "nan kb/s"
« Reply #2 on: February 14, 2004, 01:52:57 AM »

Hallo!

Upload ist 12 kB/s von 16 kB/s maximal (ADSL - 768/128 kb)



Gute Nacht!

Ano
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: 1.2.5 Uploads mit "nan kb/s"
« Reply #3 on: February 14, 2004, 02:14:29 AM »

komisch, da:

1. wir das wort nan nicht in den sources haben

2. ich sowas noch nie erlebt habe ..

versuche erstma autopriorität wegzumachen (download & sharedfiles)

gruss

Ano

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: 1.2.5 Uploads mit "nan kb/s"
« Reply #4 on: February 14, 2004, 02:55:42 AM »

Hallo nochmal,

scheint etwas geholfen zu haben, so richtig laeuft es aber immer noch nicht:



Gruesse,

Ano
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: 1.2.5 Uploads mit "nan kb/s"
« Reply #5 on: February 14, 2004, 03:11:40 AM »

kontrolliere bitte dass kein einziges file (sowohl im dl als auch im share) auf  autoprio steht und wenn du es dir sicher bist restarte amule

gruss

ps. ich will aber wissen was das wort nan da macht ..  X(

deltaHF@deltahf:~/file/amule-cvs/src> grep -Hn nan *
Übereinstimmungen in Binärdatei amule.
amule.cpp:502:          str.Format(_("Port %d is not available !!\n\nThis will mean that you will be LOWID.\n\nUse netstat to determine when port becomes available\nand try starting amule again."), glob_prefs->GetPort());
Übereinstimmungen in Binärdatei amule-otherfunctions.o.
Übereinstimmungen in Binärdatei amule-ServerSocket.o.
Übereinstimmungen in Binärdatei amuleweb.
Übereinstimmungen in Binärdatei amulewebDLG.
Übereinstimmungen in Binärdatei amulewebDLG-WebServer.o.
Übereinstimmungen in Binärdatei amuleweb-WebServer.o.
ServerSocket.cpp:248:                                   throw wxString(wxT("Corrupt or invalid loginanswer from server received"));
strings.en:91:{IDS_ERR_BADSERVERREPLY,  "Corrupt or invalid loginanswer from server received"},
deltaHF@deltahf:~/file/amule-cvs/src>

deltaHF@deltahf:~/RELEASE/aMule-1.2.5/src> grep -Hn nan *
amule.cpp:496:          str.Format(_("Port %d is not available !!\n\nThis will mean that you will be LOWID.\n\nUse netstat to determine when port becomes available\nand try starting amule again."), glob_prefs->GetPort());
amule.cpp~:496:         str.Format(_("Port %d is not available !!\n\nThis will mean that you will be LOWID.\n\nUse netstat to determine when port becomes available\nand try starting amule again."), glob_prefs->GetPort());
ServerSocket.cpp:248:                                   throw wxString(wxT("Corrupt or invalid loginanswer from server received"));
strings.en:91:{IDS_ERR_BADSERVERREPLY,  "Corrupt or invalid loginanswer from server received"},
deltaHF@deltahf:~/RELEASE/aMule-1.2.5/src>

Ano

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: 1.2.5 Uploads mit "nan kb/s"
« Reply #6 on: February 14, 2004, 10:14:04 AM »

Hallo nochmal,

hatte alle Dateien bereits vor dem letzten Posting auf normal gestellt und neu gestartet und jetzt nochmal ueberprueft, dass das wirklich so ist.

Nebenbei habe ich ein neues "Foto" einer noch nicht da gewesenen SItuation geschossen:



BIs bald!

Ano
Logged

thermoman

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 40
Re: 1.2.5 Uploads mit "nan kb/s"
« Reply #7 on: February 14, 2004, 03:41:56 PM »

Hallihallo,

ich selber benutze meine woody Pakete von aMule (wer hätte das gedacht), habe das allerdings noch nicht festgestellt bei mir. Habe allerdings auch keine LowID und habe die Downloads alle auf normal oder high, aber eigentlich nie auto.

Bei mir sind Leute in der Uploadliste, die seit 55 Minuten von mir ziehen.

Sorry, kann da nicht helfen.

mfg,
thermoman
« Last Edit: February 14, 2004, 03:42:17 PM by thermoman »
Logged
Gentoo & Bittorrent User

fz

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 27
Re: 1.2.5 Uploads mit "nan kb/s"
« Reply #8 on: February 14, 2004, 03:46:32 PM »

edit: das stimmt so nicht, was ich da geschrieben hatte. wenn eine fliesskommazahl durch null geteilt wird, ist das ergebnis "inf", also unendlich.

edit2: auf der nächsten seite hab ichs nochmal genau gepostet. man, ich muss mal wieder ausschlafen, schreibe ja nur stuss hier  :O
« Last Edit: February 15, 2004, 01:29:23 AM by fz »
Logged

Citroklar

  • Full Member
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 148
Re: 1.2.5 Uploads mit "nan kb/s"
« Reply #9 on: February 14, 2004, 04:58:53 PM »

sollte nicht division by zero eigentlich einen Programmabsturz hervorrufen? "segementation fault?" ich glaube ich muss mal ein paar tests zu low id machen....mal sehen, morgen hab ich Zeit...

Cu,
Citroklar
Logged
#!/bin/ssh
#The Unix Guru's View of Sex
unzip ; strip ; touch ; grep ; finger ; mount ; fsck ; more ; yes ; umount ; sleep

Ano

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: 1.2.5 Uploads mit "nan kb/s"
« Reply #10 on: February 14, 2004, 05:33:54 PM »

Hallo!

Ich habe jetzt mal alle Downloads abgebrochen. Mit dem zweifelhaften Erfolg, dass zwar jetzt niemand mehr ein "nan" dazustehen hat, was aber wohl daran liegt, dass jetzt niemand mehr uploaded?!

Auch dieses Verhalten war bei 1.2.4 noch nicht!

Ano

PS: War bei den Beantwortern jemand von den Entwicklern dabei oder sollte ich mich noch einmal direkt an sie wenden?
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: 1.2.5 Uploads mit "nan kb/s"
« Reply #11 on: February 14, 2004, 05:45:18 PM »

mitbekommen

fz

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 27
Re: 1.2.5 Uploads mit "nan kb/s"
« Reply #12 on: February 15, 2004, 01:02:30 AM »

@Citroklar

ja, wenn du ein "int x=1/0;" machst, dann gibt das einen segfault.

fliesskommawerte haben aber noch als weitere zustände "nan" und + bzw. -infinity. teilen durch null wird als infinity, also unendlich definiert (da der grenzwert von 1/x für x->0 ja schliesslich auch unendlich ist). nan tritt auf, wenn der rückgabewert für einen mathematischen operator nicht definiert ist. ein beispiel: sqrt(-1). wurzelziehen geht nur für zahlen >0. ebenso ist es mit logarithmen.

viel spass beim bughunting!

p.s.: für interessierte: http://babbage.cs.qc.edu/courses/cs341/IEEE-754references.html

edit: jetzt ist es richtig, hehe.
« Last Edit: February 15, 2004, 01:24:05 AM by fz »
Logged

Citroklar

  • Full Member
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 148
Re: 1.2.5 Uploads mit "nan kb/s"
« Reply #13 on: February 15, 2004, 06:03:20 PM »

Okay, gebongt, danke für die Info, fz.
Ich werd's jetzt mal testen, mal sehen was passiert...:)

Citroklar
Logged
#!/bin/ssh
#The Unix Guru's View of Sex
unzip ; strip ; touch ; grep ; finger ; mount ; fsck ; more ; yes ; umount ; sleep

Ano

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
1.2.6 & 1.2.5 Uploads mit "nan kb/s"
« Reply #14 on: February 17, 2004, 08:49:22 AM »

Hallo!

Habe heute auf thermomans Version von 1.2.6 ein Update durchgefuehrt. Hier scheint es wieder normal zu funktionieren.  :D

...

- dachte ich, ist leider doch nicht ganz behoben  ?(

Die Leute koennen jetzt wie es scheint ordentlich uploaden, bei einigen erscheint trotzdem die "nan kB/s" Anzeige!

Ano
« Last Edit: February 17, 2004, 09:04:43 AM by Ano »
Logged