aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Ubuntu Breezy and Dapper  (Read 20221 times)

dreamerwolf

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 16
Ubuntu Breezy and Dapper
« on: June 14, 2006, 03:46:05 AM »

#aMule 2.1.2 for Ubuntu Breezy i386
deb http://twemu.no-ip.org/apt/amule/breezy/ ./
deb-src http://twemu.no-ip.org/apt/amule/breezy/ ./

#aMule 2.1.2 for Ubuntu Dapper i386
deb http://twemu.no-ip.org/apt/amule/dapper/ ./
deb-src http://twemu.no-ip.org/apt/amule/dapper/ ./

#aMule 2.1.3 for Ubuntu Breezy i386 (testing)
deb http://twemu.no-ip.org/apt/amule-testing/breezy/ ./
deb-src http://twemu.no-ip.org/apt/amule-testing/breezy/ ./

#aMule 2.1.3 for Ubuntu Dapper i386/amd64 (testing)
deb http://twemu.no-ip.org/apt/amule-testing/dapper/ ./
deb-src http://twemu.no-ip.org/apt/amule-testing/dapper/ ./
---

#Mirror at apt.ubuntu.org.tw
#aMule 2.1.3 for Ubuntu Dapper i386 (testing)
deb http://apt.ubuntu.org.tw/ubtw-dapper/ ./
deb-src http://apt.ubuntu.org.tw/ubtw-dapper/ ./

#aMule 2.1.3 for Ubuntu Breezy i386 (testing)
deb http://apt.ubuntu.org.tw/ubtw-breezy/ ./
deb-src http://apt.ubuntu.org.tw/ubtw-breezy/ ./

---

#Breezy CVS (upstream every week)
#aMule 2.1.3+CVS for Ubuntu Breezy i386
#deb http://twemu.no-ip.org/apt/amule-CVS/$(date +%Y%m%d)/ ./
#deb-src http://twemu.no-ip.org/apt/amule-CVS/$(date +%Y%m%d)/ ./

---
To get my key, you have to do this. (optional)

$wget http://twemu.no-ip.org/apt/Pub.key
$sudo apt-key add Pub.key
---
If you have problems here, visit
http://twemu.no-ip.org/wiki/index.php/Maintaining_Packages

The mirror will be back later.
« Last Edit: November 28, 2006, 05:09:23 PM by dreamerwolf »
Logged

Vollstrecker

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1477
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Ubuntu Breezy and Dapper
« Reply #1 on: June 14, 2006, 05:55:51 AM »

According to: http://twemu.no-ip.org/wiki/index.php/Maintaining_Packages

Solve: sudo ln -s /usr/bin/ed2k.wrapper /usr/bin/ed2k

Hint: pre_inst and dpkg-divert
Logged
Homefucking is killing prostitution

dreamerwolf

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 16
Re: Ubuntu Breezy and Dapper
« Reply #2 on: June 14, 2006, 05:13:14 PM »

Quote
Originally posted by Vollstrecker
According to: http://twemu.no-ip.org/wiki/index.php/Maintaining_Packages

Solve: sudo ln -s /usr/bin/ed2k.wrapper /usr/bin/ed2k

Hint: pre_inst and dpkg-divert
Fixed
« Last Edit: June 14, 2006, 05:13:34 PM by dreamerwolf »
Logged

cromo

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
Re: Ubuntu Breezy and Dapper
« Reply #3 on: June 15, 2006, 03:30:35 PM »

Przygotowanie do zastpienia amule-common 2.1.2-1ubuntu0-1 (wykorzystujc .../amule-common_2.1.3-1ubuntu0-1_i386.deb) ...
/var/lib/dpkg/tmp.ci/preinst: line 17: syntax error near unexpected token `fi'

This is what I get when upgrading to 2.1.3.
Logged

tOz666

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: Ubuntu Breezy and Dapper
« Reply #4 on: June 15, 2006, 04:36:55 PM »

Quote
Originally posted by cromo
Przygotowanie do zastpienia amule-common 2.1.2-1ubuntu0-1 (wykorzystujc .../amule-common_2.1.3-1ubuntu0-1_i386.deb) ...
/var/lib/dpkg/tmp.ci/preinst: line 17: syntax error near unexpected token `fi'

This is what I get when upgrading to 2.1.3.

Same problem here too, please fix it. :))

I want to use these packages for upgrading the official dapper versions, as they have the same naming.
Logged

Vollstrecker

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1477
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Ubuntu Breezy and Dapper
« Reply #5 on: June 15, 2006, 05:56:24 PM »

If it helps you, you can download the source for my cvs-pkg's and look into them how it works.
Logged
Homefucking is killing prostitution

dreamerwolf

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 16
Re: Ubuntu Breezy and Dapper
« Reply #6 on: June 16, 2006, 05:36:02 AM »

Quote
Originally posted by tOz666
Quote
Originally posted by cromo
Przygotowanie do zastpienia amule-common 2.1.2-1ubuntu0-1 (wykorzystujc .../amule-common_2.1.3-1ubuntu0-1_i386.deb) ...
/var/lib/dpkg/tmp.ci/preinst: line 17: syntax error near unexpected token `fi'

This is what I get when upgrading to 2.1.3.

Same problem here too, please fix it. :))

I want to use these packages for upgrading the official dapper versions, as they have the same naming.
The problem is fixed today.
I will try in 2.2.x and CVS, but it won't be in 2.1.x .
Logged

sebastienserre

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
    • http://www.webynux.net
Problem with amule-common
« Reply #7 on: July 12, 2006, 08:32:03 PM »

hello,

i've installed amule 2.1.3 but i've an error message when synaptics is installing amule-common_2.1.3-1ubuntu0-1_i386.deb.

Synaptics is saying :
Code: [Select]
E: /var/cache/apt/archives/amule-common_2.1.3-1ubuntu0-1_i386.deb: le sous-processus pre-installation script a retourné une erreur de sortie d'état 2
What should i do ???

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4379
Re: Ubuntu Breezy and Dapper
« Reply #8 on: July 14, 2006, 02:56:56 PM »

Could you please try to download the file manually and install it in a terminal via sudo dpkg -i amule-common_2.1.3-1ubuntu0-1_i386.deb to get more informations?
You can try to force-install it as well, add the switch --force-all to the above command.
Logged

sebastienserre

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
    • http://www.webynux.net
Re: Ubuntu Breezy and Dapper
« Reply #9 on: July 14, 2006, 03:09:07 PM »

many thx, by downloading file without synaptics, it's working well ... but i think that i have a problem with KAD, it's disconnecting my adsl line !

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4379
Re: Ubuntu Breezy and Dapper
« Reply #10 on: July 14, 2006, 03:12:23 PM »

Some Routers do have problems with KAD, in this case you have no other choice than to disable Kad and use only the servers.
Logged

sebastienserre

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
    • http://www.webynux.net
Re: Ubuntu Breezy and Dapper
« Reply #11 on: July 14, 2006, 03:58:35 PM »

ok thanks

dreamerwolf

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 16
Re: Ubuntu Breezy and Dapper
« Reply #12 on: November 28, 2006, 05:10:56 PM »

2006/11/29
add amd64 for 2.1.3 dapper
Logged