aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Under OpenBSD  (Read 3129 times)

fa²

  • Guest
Under OpenBSD
« on: February 15, 2004, 09:31:57 PM »

I try to build binaries from sources under OpenBSD 3.4.
I've GTK 1.2.10 & wx 2.4.2.

./configure --disable-amulecmd --disable-systray
gmake

>>> PPgConnection.cpp
position.h : 8 : 'NULL' was not declared in this scope
position.h : 8 : confused by earlier errores, bailing out

How can i do ?? ?(

Thanks in advance. :)
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: Under OpenBSD
« Reply #1 on: February 17, 2004, 06:19:00 PM »

like i remember we didn't test amule compilation on openbsd ..
maybe u could join #amule on efnet so we can talk about?

btw, atm we don't have much time cos of some big changes

greets

fa²

  • Guest
Re: Under OpenBSD
« Reply #2 on: February 17, 2004, 10:14:39 PM »

Many thanks to Kry and all the aMule team !!

A solution with aMule 1.2.6 :
- position.h -> add this after line 6 (after #include )
Code: [Select]
#ifndef NULL
#define NULL 0
#endif
- OScopeCtrl.h -> add this after line 21 (after #define OSCOPECTRL_H)
Code: [Select]
#ifndef NULL
#define NULL 0
#endif
- TabCtrl.cpp -> move line 23 (#include ) to the first include (before #include "sys.h")

That's all !!
Enjoy :P
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5823
Re: Under OpenBSD
« Reply #3 on: February 17, 2004, 10:16:43 PM »

And now to do it for 1.2.7 ;)
Logged

fa²

  • Guest
Re: Under OpenBSD
« Reply #4 on: February 27, 2004, 10:52:13 PM »

Hum... you've said 1.2.7 :P

Ok- for the 2.0.0 of course !
Logged