aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: SuSE 10.2  (Read 24659 times)

Abe81

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
SuSE 10.2
« on: December 09, 2006, 02:39:38 PM »

Hello,

is it possible to use the 10.1 rpm for SuSE 10.2?

So long,

Abe
Logged

Gerd78

  • Hero Member
  • *****
  • Karma: 9
  • Offline Offline
  • Posts: 681
Re: SuSE 10.2
« Reply #1 on: December 09, 2006, 09:12:36 PM »

No, this is impossible because of libbfd.

Besides that, the 2.1.3 release wouldn't work well because it doesn't compile with wx 2.8 and has problems with wx 2.6. Use a CVS snapshot.
Logged

daemon73

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
RE: SuSE 10.2
« Reply #2 on: December 14, 2006, 07:41:48 AM »

have a look in here, might be useful, I do have the cvs running quite fine on suse 10.2

http://forum.amule.org/thread.php?postid=63176

have phun
« Last Edit: December 14, 2006, 07:42:17 AM by daemon73 »
Logged

kuritin

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
Re: SuSE 10.2
« Reply #3 on: December 23, 2006, 03:46:10 PM »

Hi, i have built a rpm to Suse 10.2, it can be downloaded from http://rapidshare.com/files/8658667/aMule-2.1.3-1.i586.rpm.html

Remember that it requires wxGTK >= 2.6.3, so you should install it before aMule

bye

http://www.jortega.org
« Last Edit: December 23, 2006, 05:47:15 PM by kuritin »
Logged

jaSalta

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
Re: SuSE 10.2
« Reply #4 on: January 27, 2007, 05:37:40 PM »

I tried all ways but doesn't work:

* Form CVS snapshot, I got the message
Quote
checking for xlC_r... no
checking for xlC... no
checking for C++ compiler default output file name... configure: error: C++ compiler cannot create executables
See `config.log' for more details.

* Compiling all from scratch following the tutorial at http://www.amule.org/wiki/index.php/Compilation_Installation, I got:
Quote
./configure --prefix=/usr --with-gtk --enable-unicode --disable-compat24 --enable-optimise

(...)
checking for strcasecmp() in string.h... no
checking for strcasecmp() in strings.h... no
configure: error: No case-insensitive string comparison function found.

Suggestions?

Thanks a lot!
Logged

Gerd78

  • Hero Member
  • *****
  • Karma: 9
  • Offline Offline
  • Posts: 681
Re: SuSE 10.2
« Reply #5 on: January 27, 2007, 05:49:40 PM »

You don't have a working build environment installed. Please install gcc-c++ and glibc-devel try again.

Also please read and follow the instructions that configure prints:
Quote
configure: error: C++ compiler cannot create executables
See `config.log' for more details.
That is, see config.log for more details. You can also attach it here.
Logged

Defender

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
Re: SuSE 10.2
« Reply #6 on: June 13, 2007, 03:28:13 PM »

Hi, i have built a rpm to Suse 10.2, it can be downloaded from http://rapidshare.com/files/8658667/aMule-2.1.3-1.i586.rpm.html

Remember that it requires wxGTK >= 2.6.3, so you should install it before aMule

bye

http://www.jortega.org

I got the following error when installing your package :

:~/Downloads> rpm -i aMule-2.1.3-1.i586.rpm -vh
warning: aMule-2.1.3-1.i586.rpm: Header V3 DSA signature: NOKEY, key ID 106ed786
error: can't create transaction lock on /var/lib/rpm/__db.000

someone knows a solution (i am a noob on suse 10.2)   :(


Nevermind..... Figured out yoy need to be root.........
« Last Edit: June 13, 2007, 03:34:10 PM by Defender »
Logged