aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Amule e wxGTK  (Read 2451 times)

enigmista

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 21
Amule e wxGTK
« on: April 25, 2007, 08:57:47 PM »

Salve,
volevo compilare la versione CVS di amule, ma ho incontrato moltissimi problemi di dipendenze (distro Slackware senza X). Mi sono ora fermato a questo errore e non riesco più ad andare avanti:
Code: [Select]
root@linux:/usr/src/wxGTK-2.6.3# ./configure --prefix=/usr --with-gtk --enable-unicode --disable-compat24 --enable-optimise
mi da:
Code: [Select]
checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

Sembra non trovare GTK, ma pkgtool mi dice che è installato:
Code: [Select]
gtk+2-2.10.11-i486-1 GTK+ version 2
Provando ad installare GTK dai sorgenti ho un errore:
Code: [Select]
checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.12.0    atk >= 1.9.0    pango >= 1.13.0    cairo >= 1.2.0) were not met:

Package xrender was not found in the pkg-config search path.
Perhaps you should add the directory containing `xrender.pc'
to the PKG_CONFIG_PATH environment variable
Package 'xrender', required by 'cairo', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Sembra non avere xrender. Se provo ad installare xrender dai sorgenti mda da un errore:
Code: [Select]
checking for X... no
configure: error: X is required, but it was either disabled or not found.

Ho provato anche ad installare xfree86-devel-4.2.0-i386-3.tgz, ma non si compila.

Sto seguento il tutorial http://www.amule.org/wiki/index.php/Compilation_Installation

Aiutatemi sto impazzendo :)
Logged