aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMule crashes (zombie) and gdb gets no backtrace  (Read 1985 times)

Arichy

  • Full Member
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 224
aMule crashes (zombie) and gdb gets no backtrace
« on: May 16, 2007, 05:41:19 PM »

I got aMule (svn-2007-05-15) running within gdb but from time to time it crashes and there is only little info about new thread, zombie process and memory access failure, bad file descriptor  and that's it. No backtrace from gdb. What's up there? Looks like gdb itself crashed... What to do?
« Last Edit: May 16, 2007, 06:00:53 PM by Arichy »
Logged
Gentoo i686

skolnick

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 24
  • Offline Offline
  • Posts: 1189
  • CentOS 6 User
Re: aMule crashes (zombie) and gdb gets no backtrace
« Reply #1 on: May 17, 2007, 06:40:26 AM »

bad file descriptor sounds like a file not found. Are you sure aMule crashes? maybe just gets stuck or something...

Regards.
Logged

Arichy

  • Full Member
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 224
Re: aMule crashes (zombie) and gdb gets no backtrace
« Reply #2 on: May 17, 2007, 02:52:21 PM »

It happened again. Now here is the output:
Code: [Select]
[New Thread -1289753680 (LWP 4082)]
close failed: [Errno 9] Bad file descriptor
[Thread -1289753680 (zombie) exited]
[New Thread -1298146384 (LWP 4240)]
close failed: [Errno 9] Bad file descriptor
[Thread -1298146384 (zombie) exited]
[New Thread -1306539088 (LWP 5723)]
close failed: [Errno 9] Bad file descriptor
[Thread -1306539088 (zombie) exited]
[New Thread -1314931792 (LWP 7404)]
close failed: [Errno 9] Bad file descriptor
[Thread -1314931792 (zombie) exited]
[New Thread -1323324496 (LWP 28395)]
close failed: [Errno 9] Bad file descriptor
[Thread -1323324496 (zombie) exited]
[New Thread -1331717200 (LWP 29709)]
close failed: [Errno 9] Bad file descriptor
[Thread -1331717200 (zombie) exited]
/home/user/bin/gdb.amule.sh: line 15: 25049 Speicherzugriffsfehler  gdb -command=/home/user/.aMule/gdb_befehle /usr/local/bin/amule
Speicherzugriffsfehler=memory access failure

content of /home/user/.aMule/gdb_befehle :
Code: [Select]
run --even-if-lfroen-complains-this-will-stay
bt
bt full
thread apply all bt

content of /home/user/bin/gdb.amule.sh (creation if mine):
Code: [Select]
#!/bin/sh

# Starte gdb, f├╝hre dann amule aus
# und generiere schlie├člich backtraces

AMULE_BEFEHL="/usr/local/bin/amule"

# in der Befehlsdatei steht "run":
GDB_BEFEHL_DATEI="$HOME/.aMule/gdb_befehle"

GDB_BEFEHL="gdb -command=$GDB_BEFEHL_DATEI $AMULE_BEFEHL"

eval $GDB_BEFEHL

In relation to files I can say: If a download is completed on my system, amule executes a shell script that renames the download file (inclusion of the first six characters of the MD4 hash at the end of the filename).
« Last Edit: May 17, 2007, 02:55:31 PM by Arichy »
Logged
Gentoo i686

Arichy

  • Full Member
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 224
Re: aMule crashes (zombie) and gdb gets no backtrace
« Reply #3 on: May 17, 2007, 09:03:29 PM »

I clicked on the refresh button in the "shared files" tab, and amule crashed.
Only output was the following, allthough running within gdb:
Code: [Select]
Adding file /daten/p2p/amule/temp/005.part.met to shares
Adding file /daten/p2p/amule/temp/010.part.met to shares
Adding file /daten/p2p/amule/temp/007.part.met to shares
Adding file /daten/p2p/amule/temp/009.part.met to shares
Adding file /daten/p2p/amule/temp/004.part.met to shares
Adding file /daten/p2p/amule/temp/008.part.met to shares
Adding file /daten/p2p/amule/temp/064.part.met to shares
Adding file /daten/p2p/amule/temp/021.part.met to shares
Adding file /daten/p2p/amule/temp/001.part.met to shares
Adding file /daten/p2p/amule/temp/023.part.met to shares
Empty dir /daten/p2p/amule/eingang/ shared
Logged
Gentoo i686

Arichy

  • Full Member
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 224
Re: aMule crashes (zombie) and gdb gets no backtrace
« Reply #4 on: May 17, 2007, 11:51:49 PM »

Hm, a new variant:
Code: [Select]
[New Thread -1274991696 (LWP 27984)]
[Thread -1274991696 (zombie) exited]
[New Thread -1274991696 (LWP 29012)]
close failed: [Errno 9] Bad file descriptor
[Thread -1274991696 (zombie) exited]
/home/user/bin/gdb.amule.sh: line 15: 10261 Speicherzugriffsfehler  gdb -command=/home/user/.aMule/gdb_befehle /usr/local/bin/amule
user@host:~$
But: aMule is still running! Maybe because after invoking /home/user/bin/gdb.amule.sh, before the aMule window appeared, I switched on a different xfce desktop page (work space), so aMule window was on one work space window, the xterm with the gdb was on the other?
Logged
Gentoo i686

skolnick

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 24
  • Offline Offline
  • Posts: 1189
  • CentOS 6 User
Re: aMule crashes (zombie) and gdb gets no backtrace
« Reply #5 on: May 20, 2007, 07:07:59 AM »

No, the workspace you are running on should have nothing to do with gdb and aMule. It might have been a coincidence, but I am not the most proficient gdb user ;)

Regards.
Logged