aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Amuled Crashes on CVS version! libwx related it seems...help  (Read 1258 times)

ShiftyPowers

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 8
Amuled Crashes on CVS version! libwx related it seems...help
« on: September 20, 2007, 01:48:15 AM »

hey all, i'm running a 9/19/07 version of amule CVS and the monolithic app runs fine, but whenever i try to rule amuled it starts up, starts loading the .part files and then this happens:

Code: [Select]
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/index.php?board=67.0
If possible, please try to generate a real backtrace of this crash:
    http://www.amule.org/wiki/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMuled CVS using wxGTK2 v2.8.4 (Snapshot: Wed Sep 19 07:01:56 CEST 2007)
Running on: Linux 2.6.17-11-generic i686

[2] CamuleApp::OnFatalException() in amuled [0x8056cb1]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0xb7e947ec]
[4] ?? in [0xffffe420]
[5] __dynamic_cast in /usr/lib/libstdc++.so.6[0xb7d6856e]
[6] CamuleApp::OnFinishedHashing(CHashingEvent&) in amuled [0x80572ac]
[7] wxAppConsole::HandleEvent(wxEvtHandler*, void (wxEvtHandler::*)(wxEvent&), wxEvent&) const in /usr/lib/libwx_baseu-2.8.so.0[0xb7ded6bf]
[8] wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0xb7e9009c]
[9] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) in /usr/lib/libwx_baseu-2.8.so.0[0xb7e9026e]
[10] wxEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0xb7e90416]
[11] wxEvtHandler::ProcessPendingEvents() in /usr/lib/libwx_baseu-2.8.so.0[0xb7e908ff]
[12] wxAppConsole::ProcessPendingEvents() in /usr/lib/libwx_baseu-2.8.so.0[0xb7ded97a]
[13] CamuleDaemonApp::OnRun() in amuled [0x8054eae]
[14] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0xb7e27bbe]
[15] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.8.so.0[0xb7e27c77]
[16] main in amuled [0x8053e80]
[17] __libc_start_main in /lib/tls/i686/cmov/libc.so.6[0xb7b658cc]
[18] __gxx_personality_v0 in amuled[0x80538d1]

Anyone have any idea how to fix this?
Logged