aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Librerie wxWidgets (Conflitto di repository) ed aMule CVS  (Read 2878 times)

balubeto

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 17
Librerie wxWidgets (Conflitto di repository) ed aMule CVS
« on: November 07, 2007, 07:42:04 PM »

CIAO

Avevo installato aMule CVS seguendo le instruzioni indicate qui ed in particolare avevo messo nel file /etc/apt/sources.list la riga deb http://www.vollstreckernet.de/debian/ testing amule wx .

Ora, ho necessita` di inserire nel repository di sistema il repository deb http://apt.wxwidgets.org/ lenny-wx main (vedere qui) che contiene anch'esso librerie wxWidgets .

A questo punto, come devo configurare il mio /etc/apt/sources.list per evitare la doppia libreria wxWidgets ma, facendo in modo che aMule CVS funzioni con le nuove librerie wxWidgets cancellando completamente le versioni delle librerie wxWidgets prelevate dal repository di aMule CVS?

GRAZIE

CIAO

Uso GNU/Debian Lenny Testing.
Logged
balubeto

1Carlos

  • Full Member
  • ***
  • Karma: 2
  • Offline Offline
  • Posts: 187
Re: Librerie wxWidgets (Conflitto di repository) ed aMule CVS
« Reply #1 on: November 09, 2007, 03:04:01 PM »

Ciao,
la soluzione al tuo problema sta qui:
http://www.debian.org/doc/manuals/apt-howto/ch-apt-get.en.html
http://wiki.debian.org/AptPinning

Devi inserire in /etc/apt/preferences

qualcosa tipo:

Package: *
Pin: origin apt.wxwidgets.org
Pin-Priority: 990

Per dargli una priorità maggiore rispetto ai repo di vollstreckernet.

Ciao.
Logged
Please excuse my bad English  :(.