aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Absturz bei klick auf prefs tab  (Read 7230 times)

MasterKGB

  • Jr. Member
  • **
  • Karma: 1
  • Offline Offline
  • Posts: 51
Absturz bei klick auf prefs tab
« on: November 25, 2007, 02:56:09 PM »

Sorry wenns ein Doppelpost ist, hab aber den anderen nicht gefunden wo es auch schon vorkommt.

Zum Fehler beim klick auf einstellungen stürtzt amule ab (ist aber ein glaube ich bkannter fehler)

Habe jetzt beobachtet, das wenn ich amule als root ausführe der absturz nicht passiert, amule also problemlos funktioniert.

Vielleicht hilft das ja, weil es muss ja wohl ein berechtigungsproblem sein.

Zum system Gentoo Linux 2.6.23-r2 wxgtk 2.8.4.0

Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4319
Re: Absturz bei klick auf prefs tab
« Reply #1 on: November 25, 2007, 06:48:58 PM »

Hallo,

unter Linux sollte es eigentlich nicht zum Absturz kommen, wenn du die Einstellungen öffnest - gibt es dazu einen Backtrace?
Logged

MasterKGB

  • Jr. Member
  • **
  • Karma: 1
  • Offline Offline
  • Posts: 51
Re: Absturz bei klick auf prefs tab
« Reply #2 on: November 30, 2007, 09:09:06 PM »

Werde ich mal erstellen ;)
muss es nochmal mit der debug kompilen ;)
Logged

chango

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 28
Re: Absturz bei klick auf prefs tab
« Reply #3 on: December 07, 2007, 08:21:15 PM »

Hallo Zusammen,

ich habe das selbe Problem. Wenn ich amule als user oder als root starte stürtz es ab sobald man neu server downloaden will oder auf die Einstellungen klickt.

Habe Linux 10.3 und nicht sehr viel Erfahrung damit!

Haben schon CVS und andere Versionen getestet - immer das selbe Ergebniss.

Hab ich was falsch gemacht?

Gruß

Chango
Logged

MasterKGB

  • Jr. Member
  • **
  • Karma: 1
  • Offline Offline
  • Posts: 51
Re: Absturz bei klick auf prefs tab
« Reply #4 on: December 08, 2007, 02:06:16 PM »

Es scheint wohl eher am wxGTK zu Liegen.
Nachdem ich den amule mit debug flag compiliert habe hab ich vorher den wxGTK upgegraded seitdem geht er wieder als User ohne absturz.

Habe momentan die wxGTK 2.8.7.1 damit scheint das Problem weg zu sein.
Logged