aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: fallo al compilar 2.0.0rc1 en debian sid  (Read 2436 times)

angeld

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 29
fallo al compilar 2.0.0rc1 en debian sid
« on: March 28, 2004, 11:01:15 AM »

Al intentar compilar en sid me da un fallo porque no encuentra la librería "libcrypto++".
Esto se debe a que esta librería no aparece con este nombre, no se si el fallo es de debian o de amule.
## La solución
Lo he solucionado creando un enlace a "libcrypto++5.1.a" que se llame "libcrypto++":
ln -s /usr/lib/libcrypto++5.1.a /usr/lib/libcrypto++.a

Saludos --- angeld
Logged

Jacobo221

  • Hero Member
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 2711
Re: fallo al compilar 2.0.0rc1 en debian sid
« Reply #1 on: March 31, 2004, 01:18:59 AM »

El fallo es de Debian. De todas formas, deberias compilar las librerias Crypto++ 5.1 que vienen en la pagina de amule.org, ya que las de Debian y Gentoo parecen no ir precisamente de maravilla (creo que ahora hay un parche para Gentoo, segun he leido en los foros). Bajate el source de Crypto++ 5.1 de http://download.berlios.de/amule/crypto-5.1.tar.bz2

Un saludo y gracias por la "buena fe" de postear el truco :-)
Logged