aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: 1 [2] 3 4

Author Topic: Amulegui is failing to connect properly to amuled after a few hours  (Read 19825 times)

wild_oscar

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 45
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #15 on: May 05, 2008, 04:36:23 PM »

Looks like the protocol needs some rework...
Yes, it does.

No, it does not. Yet another EC re-write?!

Regarding "remote GUI over slow connection": this is plain tcp. It works bad over crappy connection, no news here.  For GUI to work properly, you need timely updates. This doesn't compute.

Bare in mind that I'm using amuleGUI on a local network, 100kbps, and that it used to work before.
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3762
  • Engines screaming
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #16 on: May 05, 2008, 10:22:40 PM »

Quote from: RRT4
how can there be more UL bandwidth available if you just need to rehash 2/3 files (few seconds) for starting to upload again at maximum speed?
After hashing (which will take more than few seconds with many large files) the files need to be published, and the be found by the sinks. That should take enough time to make a few successful remote connects.

No, it does not. Yet another EC re-write?!
Easy.  8) If amuleweb is not affected it might be just a problem of the remotegui-app.

Regarding "remote GUI over slow connection": this is plain tcp.
No, it's not. Plain TCP has no bandwidth throttler to consider.
I've also tested it with a straight 100Mbit connection. If it fails even there it's not very useful as it is.

Another thing that deserves a look is the go-to-the-background-and-wait-until-someone-kills-the-process-behaviour, if the connection can't be established.  ;)
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

RRT4

  • Jr. Member
  • **
  • Karma: 3
  • Offline Offline
  • Posts: 67
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #17 on: May 05, 2008, 10:45:59 PM »

Quote from: RRT4
how can there be more UL bandwidth available if you just need to rehash 2/3 files (few seconds) for starting to upload again at maximum speed?
After hashing (which will take more than few seconds with many large files) the files need to be published, and the be found by the sinks. That should take enough time to make a few successful remote connects.
that is true only if you change also ip or tcp port when you delete the known.met
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3762
  • Engines screaming
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #18 on: May 05, 2008, 11:57:36 PM »

Even if not it will not upload until the first sink reasks, and they do that only every 30min or so.  :P
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

lfroen

  • Guest
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #19 on: May 06, 2008, 01:08:21 PM »

Another thing that deserves a look is the go-to-the-background-and-wait-until-someone-kills-the-process-behaviour, if the connection can't be established.  ;)
That's bloody annoying bug, I agree.
Logged

chemical

  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 62
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #20 on: May 06, 2008, 09:45:57 PM »

I've reported this bug a long time ago ( #1146 ), and i'm really glad theres progress! Thanks for all of your investigation.

I closed the issue prematurely, the problem is still there.
Logged

maciste

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #21 on: May 08, 2008, 03:47:17 PM »

I think to have the same problem: my remote gui doens't update the download progress. It stops to work after few minutes and this happens only with the svn version. The older version of Amule Gui worked too but it's incompatible with the new Amule demon. I'm using Amule Svn 5may version on linux ubuntu 8.04 64 bit and the remote gui on a Windows XP laptop on a 54mbit wifi lan.
Logged

wild_oscar

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 45
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #22 on: May 08, 2008, 04:21:38 PM »

I think to have the same problem: my remote gui doens't update the download progress. It stops to work after few minutes and this happens only with the svn version. The older version of Amule Gui worked too but it's incompatible with the new Amule demon. I'm using Amule Svn 5may version on linux ubuntu 8.04 64 bit and the remote gui on a Windows XP laptop on a 54mbit wifi lan.

Any chance of prioritizing this issue, as it is making amulegui useless right now?

Please check these bug issues:
http://bugs.amule.org/view.php?id=1311
http://bugs.amule.org/view.php?id=1146
Logged

Crakem

  • Full Member
  • ***
  • Karma: 2
  • Offline Offline
  • Posts: 103
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #23 on: May 08, 2008, 07:54:14 PM »

Easy.  8) If amuleweb is not affected it might be just a problem of the remotegui-app.
My amuled server is a K6-II, 64mb computer and all network clients are Pentium4. amuleGUI works only on half each. And amuleweb always works perfectly for all. Sure! amuleGUI have some problem connecting but I prefer using it for distributing loads (I'm waiting lfroen adding xinet support for amuleweb  :P)
Logged

wild_oscar

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 45
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #24 on: May 09, 2008, 11:39:15 AM »

I've installed an amule SVN on a new, unused machine (with ubuntu).

After the night of running amuled, I seem to:

1) Be able to connect with amulegui in the same machine

2) Not able to connect with amulegui using another computer


UPDATE:
I've tried this running amulegui in two different computers and both cannot connect to the amuled I set up.
« Last Edit: May 09, 2008, 12:39:47 PM by wild_oscar »
Logged

Festor

  • Hero Member
  • *****
  • Karma: 79
  • Offline Offline
  • Posts: 940
  • Offline -> Studying...
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #25 on: May 09, 2008, 02:37:34 PM »

Please... what SVN versión (say date of SVN)

wild_oscar

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 45
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #26 on: May 09, 2008, 04:46:36 PM »

Please... what SVN versión (say date of SVN)

server1 (amuled+ working amulegui) - May 8 (yesterday's)
desktop1 (amulegui) - April 28th

laptop1 (amulegui) - May 8th (yesterday's)
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3762
  • Engines screaming
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #27 on: May 10, 2008, 11:31:51 PM »

Mind that only the same SVN version of amulegui and amuled/amule can connect.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

wild_oscar

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 45
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #28 on: May 11, 2008, 03:46:54 AM »

Mind that only the same SVN version of amulegui and amuled/amule can connect.

Don't believe that's true, I've find that different versions of SVN can connect.

Either way, I have the same SVN version on my laptop whose amulegui does not connect to amuled in server1.

Moreover, my "desktop1 (amulegui) - April 28th" was connecting to a server2 with amuled of April 28th (the origin of the problem).
Logged

wild_oscar

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 45
Re: Amulegui is failing to connect properly to amuled after a few hours
« Reply #29 on: June 05, 2008, 12:43:34 PM »

So, one month later...any news on this issue?
Logged
Pages: 1 [2] 3 4