aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Problem mit aMule-Installation  (Read 6588 times)

Guest

  • Guest
Problem mit aMule-Installation
« on: November 09, 2003, 12:27:10 AM »

Hallo!
Vorweg: Ich bin Linux-Neuling und nutze SuSE 8.1.
Bei dem Versuch aMule über das rpm-File zu installieren, sagt mir YaST, mir würde Folgendes fehlen:
- libc.so.6(GLIBC_2.3)
- libc.so.3
- libstdc++.so.5(GLIBCPP_3.2.2)
- libwx_gtk-2.4.so.0
- libwx_gtk-2.4.so.0(WXGTK_2.4)
Ich habe auf den Install-CD's gesucht und dort nix gefunden (nur ein Paket in älterer Version - denke ich...). Ein Online-Update hat nichts erbracht. Auf den SuSE-Seiten haben ich keine Möglichkeit gefunden, bestimmte Pakete herunterzuladen.
Wie komme ich nun an die erforderlichen Pakete?
Danke für Hilfe!
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3928
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: Problem mit aMule-Installation
« Reply #1 on: November 09, 2003, 02:58:04 PM »

hi,

suse 8.1 ist zu alt um aMule rpms installieren zu können.. brauchst mind. 8.2 ..

sauge dir den src-code (*.tar.gz) und compiliere es ..

gruss
delta

Kunstguerilla

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: Problem mit aMule-Installation
« Reply #2 on: November 09, 2003, 10:59:13 PM »

Hi deltaHF!

Wichtiger Hinweis, dass die RPM nur mit einem 8.2er SuSE verwendbar ist und nicht mit einem älteren (ich habe 8.1). Wäre das nicht einen Hinweis auf der Download-Page wert?

So, ok, also mit 8.1 von Hand compilieren. Nur wie? :-)  Es fängt schon damit an, dass die sonst gewohnte Datei configure im Tarball die Endung .in hat. Grund dafür? Die liess sich erst nicht ausführen wegen der falschen Berechtigung. Als ich sie endlich aufrufen konnte, habe ich folgende Fehlermeldungen erhalten:

./configure.in: line 2: syntax error near unexpected token `[aMule],[1.1.2],[scolin@planetepc.fr]'
./configure.in: line 2: `AC_INIT([aMule],[1.1.2],[scolin@planetepc.fr])'

Das sagt mir jetzt was? Das Helpfile INSTALL hilft mir auch nicht sonderlich weiter, wenn ich ehrlich bin. Auch der dortige Hinweis, man solle sich im Falle einer CVS-Version (wat weiss ich :D) mit ./autogen.sh ein Configure-Script basteln lassen, brachte keinen Erfolge, da bekomme ich folgende Meldungen:

to create the configure script I used:
- GNU Autoconf V2.57
- GNU Automake V1.7.2
- GNU gettext V0.11.5
You may be able to generate it with older versions but I didn't test it.
Setting up internationalization files
./autogen.sh: line 11: autopoint: command not found
Running aclocal -I m4
./autogen.sh: line 19: aclocal: command not found
Running automake m4/Makefile
./autogen.sh: line 22: automake: command not found
Running automake --foreign -a
./autogen.sh: line 25: automake: command not found
Running autoheader
./autogen.sh: line 28: autoheader: command not found
Running autoconf
./autogen.sh: line 31: autoconf: command not found

So, und wie nun weiter?
Ich wäre Dir oder einem anderen Fachmann dankbar für ein wenig Unterstützung :-)

Grüße.
Logged

Guest

  • Guest
Ebenso
« Reply #3 on: November 10, 2003, 12:31:05 AM »

Mit genau den gleichen Problemen schlug ich mich gerade auch herum. (An das CVS habe ich mich allerdings erst gar nicht herangewagt...)
Wie gesagt, ich bin Linux-Neuling und finde allein die Tatsache, dass es notwendig ist ein Programm selbst zu compilieren recht wunderlich.:-) Nun ja.
Kann man solche Dinge nicht etwas ... äh ... benutzerfreundlicher aufziehen? Kein Wunder, dass MS die Oberhand behält...
Logged

jfk2k

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 9
Re: Problem mit aMule-Installation
« Reply #4 on: November 10, 2003, 01:29:46 AM »

Hi,

hmm bin zwar kein Fachmann aber hier mal ein paar Hinweise:

Prüfe erstmal ob Du alles installiert hast was Du brauchst:
Wichtig ist auf jedenfall wxGTK siehe auch http://amule.sourceforge.net/phpBB2/viewtopic.php?t=103

Damit das ./autogen.sh Script richtig läuft brauchts Du folgende Versionen
siehe http://amule.sourceforge.net/phpBB2/viewtopic.php?t=121

automake (GNU automake) 1.7.2 > 1.7.6 (check it with automake --version)

autoconf (GNU Autoconf) 2.57 (check it with automake --version)

gettext (GNU gettext-runtime) 0.11.5 > 0.12.1 (check it with gettext --version)

autopoint (GNU gettext-tools) 0.11.5 > 0.12.1 (check it with autopoint --version)

In den Klammern stehen die entsprechen Befehle um das zu prüfen - evt. mußt Du diese als root in einer Shell eingeben.

Habe zwar selber keine Suse hier am laufen - aber ich mußte mir z.B. auch gettext erstmal updaten damit das Script lief.

Das compilieren solltest Du so starten (zumindest klappst bei mir so):

./autogen.sh && CXX="g++ -Os" CC="gcc -Os" ./configure --disable-debug --enable-optimise && make

danach kannst Du noch ein "make install" machen damit aMule nach /usr..blablasonstwo installiert wird

Du kannst aber auch nach dem compilieren nur die amule-Datei aus dem src-Verzeichnis in ein beliebiges Verzeichnis kopieren und starten. So habe ich mir in meinem Homeverzeichnis einfach zusätzlich noch ein muli-Verzeichnis angelegt, in dem ich alle Versionen "vorrätig" habe - man weis ja nie :wink:

Starten solltest Du das ganze so:

export LANG=C && export LC_ALL=en_EN && export LANG=en_EN && export LC_MESSAGES=C && amule

siehe auch http://amule.sourceforge.net/phpBB2/viewtopic.php?t=110

Du siehst es steht eigentlich alles hier im Forum - sollte man vielleicht mal auf der HomePage zusammenfassen - oder ?

bye JFK2k
Logged

Kunstguerilla

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: Problem mit aMule-Installation
« Reply #5 on: November 10, 2003, 07:31:53 AM »

Morgen jfk2k!

Ich danke Dir erst einmal für Dein ausführliches Posting, komme aber leider erst heute Abend dazu, es zu testen und melde mich dann erneut.
Und ja, sollte man mal zusammenfassen und auf die Download-Site vom aMule setzen ;-)

Ciao.
Logged

zrox

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
    • http://lin4b.6x.to/
Re: Problem mit aMule-Installation
« Reply #6 on: November 10, 2003, 07:49:00 AM »

@Fraggle

schau würde es unter ms nicht laufen hättest du einfach pech gehabt  :shock:
und unter linux kannst du wenigstenns  was machen  :D das es läuft!!

ps: und wenn dir was nicht an dem prog passen sollte kannst du (wenn du es "man" )kannst "kann" sich nach seinen wünschen anpassen  :) kannst du das unter ms???


mfg zrox
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3928
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: Problem mit aMule-Installation
« Reply #7 on: November 10, 2003, 10:47:25 AM »

danke jfk2k :)

dass die rpms nur unter suse 8.2 & 9.0 laufen hab ich glaub ich im englischen forum gepostet ..

configure script wird durch ./autogen.sh erstellt ..
dafür braucht ihr aber automake, autopoint etc ..

configure.in ist nicht gleich configure ;) also finger wech davon ..
./autogen.sh heisst das zauberwort

gruss
delta

Kunstguerilla

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: Problem mit aMule-Installation
« Reply #8 on: November 11, 2003, 07:38:22 AM »

Morgen jfk2k!

Immerhin habe ich es jetzt bis zur Installation von wxGTK gebracht :-) Aber bereits bei automake hakt es aus. Leuts, das funzt anscheinend ebenfalls erst ab SuSE 8.2. Wollte automake installieren, da sagt er, info würde fehlen. Will ich info installieren (wann war ich jemals so oft auf rpmfind?! :D) , braucht er die libc.so.6. Will ich die installieren, braucht er in der selben Version gtk-locale und gtk-devel. BTW: alle drei Pakete sind eigentlich für SuSE 8.2. Jetzt kommt aber der Clou: Ich kann die libc.so.6 nicht installieren, weil die vorher installierten devel- und locale-Pakete die Version 2.2.5 benötigen. Der Brüller, oder? :-D

Gut, da ignorieren wir doch einfach mal die Abhängigkeiten und riskieren ein inkonsistentes System. Was tut man nicht alles für das Maultier?!

Melde mich später wieder, jetzt muss ich los.

Ciao.
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3928
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: Problem mit aMule-Installation
« Reply #9 on: November 11, 2003, 11:45:40 AM »

Quote
Original von Kunstguerilla


Gut, da ignorieren wir doch einfach mal die Abhängigkeiten und riskieren ein inkonsistentes System. Was tut man nicht alles für das Maultier?!


das würd ich nicht machen .....

Kunstguerilla

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: Problem mit aMule-Installation
« Reply #10 on: November 11, 2003, 08:47:54 PM »

Da hast Du recht, sollte man nicht machen. Und da ich inzwischen sowieso völlig fest stecke, muss ich wohl oder übel zurück zum alten und sehr gerne abschmierenden lMule oder aber mein SuSE updaten, wozu mir im Moment ehrlich gesagt Zeit und Lust fehlen.

Auf jeden Fall funzt die Installation einfach nicht. All das Zeugs, das für autogen.sh nötig ist, benötige ich laut Euren Aussagen in Versionen, die für SuSE 8.1 nicht passend sind, da bekomme ich einen Konflikt nach dem anderen.

Ich gebe an dieser Stelle also erst einmal auf, bevor ich mein System ganz inkonsisten mache.
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3928
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: Problem mit aMule-Installation
« Reply #11 on: November 11, 2003, 10:40:32 PM »

das kriegen wir schon hin ;)
ich meld mich per pm bei dir wenn ich zeit habe..

gruss
delta

Guest

  • Guest
noch'n Problem
« Reply #12 on: November 13, 2003, 01:05:17 AM »

So. Ich hab nun Suse 9 aufgespielt. Der Esel rennt. Nur ein Problem habe ich jetzt:
Beim Start eines neuen Download bekomme ich folgende Meldung:
"Impossible to set permission for the file '.../xxx.part.met.BAK' (error 1: Die Operation ist nicht erlaubt)"
"..." ist mein Temp-Verzeichnis und liegt auf meiner Slave-Platte (FAT 32). Habe dort Schreibrecht. Nur das Schreibrecht für "other" bekomme ich mit chmod dort nicht hinein (?).
Weiß jemand Rat?
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3928
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: noch'n Problem
« Reply #13 on: November 13, 2003, 11:42:50 AM »

Quote
Original von Fraggle

So. Ich hab nun Suse 9 aufgespielt. Der Esel rennt. Nur ein Problem habe ich jetzt:
Beim Start eines neuen Download bekomme ich folgende Meldung:
"Impossible to set permission for the file '.../xxx.part.met.BAK' (error 1: Die Operation ist nicht erlaubt)"
"..." ist mein Temp-Verzeichnis und liegt auf meiner Slave-Platte (FAT 32). Habe dort Schreibrecht. Nur das Schreibrecht für "other" bekomme ich mit chmod dort nicht hinein (?).
Weiß jemand Rat?


ja .. [schild=8 fontcolor=000000 shadowcolor=C0C0C0 shieldshadow=1]nach FAT32 im forum suchen[/schild]

es gibt hier zig beiträge zu diesem thema ..  :wink:
sowohl auf englisch als auch auf deutsch ..

gruss
delta

ZwiebelZ

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 46
Re: noch'n Problem
« Reply #14 on: November 15, 2003, 01:51:03 PM »

Quote
Original von Fraggle

So. Ich hab nun Suse 9 aufgespielt. Der Esel rennt. Nur ein Problem habe ich jetzt:
Beim Start eines neuen Download bekomme ich folgende Meldung:
"Impossible to set permission for the file '.../xxx.part.met.BAK' (error 1: Die Operation ist nicht erlaubt)"
"..." ist mein Temp-Verzeichnis und liegt auf meiner Slave-Platte (FAT 32). Habe dort Schreibrecht. Nur das Schreibrecht für "other" bekomme ich mit chmod dort nicht hinein (?).
Weiß jemand Rat?

linux:/etc # vi fstab


/dev/hda1            /windows/C           vfat    users,gid=users,umask=0002,iocharset=iso8859-1,quiet,code=437 0 0

Editier mal die fstab um den roten Parameter bei dir. Dann das /dev/hda1 unmounten und wieder mounten (mit umount bzw. mount).

Gruß
Logged
Long live rock 'n' roll and the aMule-Dev-Team :)