aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMule 2.2.1 in Ubuntu 8.10 64bit  (Read 2302 times)

arosar

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
aMule 2.2.1 in Ubuntu 8.10 64bit
« on: October 18, 2008, 12:07:03 AM »

It crashes often.

Intel(R) Core(TM)2 CPU T7200  @ 2.00GHz
2 GB RAM

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.2.1 using wxGTK2 v2.8.7
Running on: Linux 2.6.27-7-generic x86_64

[2] wxThreadHelperThread::~wxThreadHelperThread() in amule [0x44a14f]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0x7f769f2ae22c]
[4] ?? in /lib/libpthread.so.0 [0x7f76a093a0f0]
[5] wxMenuItemList::~wxMenuItemList() in amule [0x56fdc0]
[6] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x51b0c8]
[7] wxDataObjectSimple::~wxDataObjectSimple() in amule [0x51b79e]
[8] wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x7f769f2a9ca9]
[9] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) in /usr/lib/libwx_baseu-2.8.so.0[0x7f769f2aae84]
[10] wxEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_baseu-2.8.so.0[0x7f769f2aaf77]
[11] wxTimerBase::Notify() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7f769fa2d1d6]
[12] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0 [0x7f769f9343cb]
[13] ?? in /usr/lib/libglib-2.0.so.0 [0x7f769bf2a50b]
[14] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0x7f769bf29d4b]
[15] ?? in /usr/lib/libglib-2.0.so.0 [0x7f769bf2d51d]
[16] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0x7f769bf2da4d]
[17] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x7f769ddba7d7]
[18] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7f769f92bd18]
[19] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7f769f9b4f4b]
[20] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x7f769f24f73d]
[21] std::basic_string<char, std::char_traits<char>, std::allocator<char> > std::operator+<char, std::char_traits<char>, std::allocator<char> >(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) in amule [0x5161b2]
[22] __libc_start_main in /lib/libc.so.6[0x7f769e497466]
[23] CryptoPP::BufferedTransformation::ChannelPut2(std::string const&, unsigned char const*, unsigned long, int, bool) in amule[0x449159]


--------------------------------------------------------------------------------
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2675
Re: aMule 2.2.1 in Ubuntu 8.10 64bit
« Reply #1 on: October 18, 2008, 01:11:57 PM »

Use a (self-compiled) validated crypto++ lib.
Logged
concordia cum veritate

tom1111

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: aMule 2.2.1 in Ubuntu 8.10 64bit
« Reply #2 on: January 11, 2009, 11:43:36 AM »

Quote
Use a (self-compiled) validated crypto++ lib.

how to do it ?

i have same problem in ubuntu 8.10 , 64
Logged