aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Debian Testing  (Read 10736 times)

Vollstrecker

  • Hero Member
  • *****
  • Karma: 62
  • Offline Offline
  • Posts: 1460
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Debian Testing
« on: December 30, 2008, 01:10:42 PM »

The testing version is updated to 2.2.3

 deb http://www.vollstreckernet.de/debian/ testing amule-stable wx

wx is not needed for wx-2.8 which is included in testing already. You can omit it.

For optional parameter is said:  you'll get the updated versions in there when they are needed by amule, so it makes no harm to include it right now

For sure, you can get the sources for selfcompile the usual way via:

 deb-src http://www.vollstreckernet.de/debian/ testing amule-stable wx

You can combine those two possibilities to get just what you want.

GPG Key:

  gpg --keyserver wwwkeys.eu.pgp.net --recv-key D63913EF50D0AE60
  gpg --export D63913EF50D0AE60 > amule-key
  apt-key add amule-key
« Last Edit: January 16, 2009, 12:22:16 AM by Festor »
Logged
Homefucking is killing prostitution

jimbo

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 24
Re: Debian Testing
« Reply #1 on: January 01, 2009, 06:21:00 PM »

Hello,

I have added this link in my source.list and if I type apt-cache policy in a terminal I cannot see anthing about your server ?! So I cannot created my preference file and install amule with aptitude.  May be there are not amule 64 bit packages ?

Logged

Vollstrecker

  • Hero Member
  • *****
  • Karma: 62
  • Offline Offline
  • Posts: 1460
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Debian Testing
« Reply #2 on: January 01, 2009, 10:05:51 PM »

You're right. I have only i386 right now.
Logged
Homefucking is killing prostitution

dreamerwolf

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 16
Re: Debian Testing
« Reply #3 on: January 02, 2009, 06:19:29 AM »

Logged

jimbo

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 24
Re: Debian Testing
« Reply #4 on: January 02, 2009, 01:10:06 PM »

ok no problem I have compiled by sources  ;D but I enjoy when somebody creat a *.deb file !!!!  ;D
Logged

Festor

  • Hero Member
  • *****
  • Karma: 78
  • Offline Offline
  • Posts: 954
  • Offline -> Studying...
Re: Debian Testing
« Reply #5 on: January 16, 2009, 12:23:03 AM »

I added GPG key to main post.

dreamerwolf

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 16
Re: Debian Testing
« Reply #6 on: February 04, 2009, 07:47:51 PM »

I take out the binary files for security reasons.

Please check the md5sum before starting to compile.

Quote
Architecture: any
Standards-Version: 3.8.0.1
Build-Depends: debhelper (>= 5.0.0), libglib2.0-dev, libgtk2.0-dev, zlib1g-dev, libwxgtk2.8-dev, libgd2-xpm-dev, bison, flex, libcrypto++-dev, libreadline5-dev, libgeoip-dev, libupnp3-dev (>> 1.6.6), binutils-dev
Files:
 a14ebfee4ba68c7608481425ad89cbfc 6043631 amule_2.2.3.orig.tar.gz
 725e6632b9e05877534a78c1f170be25 36411 amule_2.2.3-1.diff.gz

The best way is download from Debian Experimental.
« Last Edit: February 04, 2009, 08:18:12 PM by dreamerwolf »
Logged

vbf

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
Re: Debian Testing
« Reply #7 on: February 26, 2009, 11:36:17 PM »

Have same problem with installation from deb package (Debian Lenny, now it is a stable). amule-remote-gui need ONLY libcrypto++5.2a2c, but now i had libcrypto++7 (5.5.2-2)
Problem with upgrade, if a  previous version of  amule-gui already installed (previous version of amule-alc was included in amule-gui)
« Last Edit: February 26, 2009, 11:38:15 PM by vbf »
Logged