aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: emule crasht, nachdem Win-Fat32 - Laufwerk eingebunden wurde  (Read 2280 times)

Kiezkicker

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
emule crasht, nachdem Win-Fat32 - Laufwerk eingebunden wurde
« on: April 14, 2004, 11:46:44 AM »

Moin,

aus Platzgründen würde ich mein Incomming sowie meinen Tempfolder gerne auf eine mit Fat32 formatierte Platte legen. Dieses wird von amule jedoch beim naechsten Start fortan mit einer nicht sehr aussagekraeftigen Fehlermeldung quittiert:
Quote
Stefan@kiezkicker:~$ amule
Initialising aMule
Loading preferences from /home/Stefan/.aMule/preferences.ini

OOPS! - Seems like aMule crashed
--== BACKTRACE FOLLOWS: ==--

  • amule(_ZN9CamuleApp16OnFatalExceptionEv+0x3f) [0x81b2ecb]
  • [1] /usr/lib/libwx_gtk-2.4.so.0(wxFatalSignalHandler+0x2d)
[0x403d296d]
[2] /lib/libpthread.so.0 [0x40fa4815]
[3] /lib/libc.so.6 [0x410134a8]
[4] amule(_ZN9CamuleApp6OnInitEv+0x1570) [0x81b07e6]
[5] /usr/lib/libwx_gtk-2.4.so.0(_Z7wxEntryiPPc+0x228) [0x402481a8]
[6] /lib/libc.so.6(__libc_start_main+0xc6) [0x40fffdc6]
[7] amule(_ZN18wxBaseArrayPtrVoidD2Ev+0x39) [0x80a6a41]
Abgebrochen

Ja, ich habe gelesen, was im anderen Forum ueber den Backtrace steht - dieser Fehler ist bei mir jedoch sowas von reproduzierbar, reproduzierbarer geht es gar nicht mehr. ;)

Zugewiesene Incomming und Tempfolder sind leer und neu eingerichtet, der Schreib- und Lesezugriff funktioniert ansonsten immer problemlos auf diesen Windowsplatten.
Sobald ich diese Pfade wieder aus der .emule loesche und sie wieder zurueck auf meine Linux - Rootplatte in mein Userdir verlege, startet amule jedoch problemlos hoch. Wechsel ich dann wieder auf eine mit Fat32 formatierte Platte (voellig egal, welche), haengt er sich beim naechsten Start mit obiger Meldung auf.
Irgendeine Idee, woher diese ploetzlich auftretende Amule - Antiphatie gegen meine Windowsplatten kommt? ;)
Vorhergehende Versionen (hier lief zuvor die Version 1.2.4-1) hatten diese Probleme noch nicht.

Ergaenzung:
Das ist so krank - mit einer im Amigafilesystem(!) formatierten Platte funktioniert es ebenfalls problemlos, es scheint echt am Fat32 zu liegen. Die amigaplatte ist nun allerdings auch ein wenig zu klein (und zu langsam...), sonst wuerde ich doch glatt die nehmen... Mein Linuxroot bietet mir halt leider nur noch ein knappes GB Platz. ;-\
« Last Edit: April 14, 2004, 11:55:44 AM by Kiezkicker »
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org

Kiezkicker

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5
Re: emule crasht, nachdem Win-Fat32 - Laufwerk eingebunden wurde
« Reply #2 on: April 14, 2004, 04:25:43 PM »

Dankeschön, funktioniert wie beschrieben. :)
Öhm, der Thread kann dann wohl als erledigt erklärt und geschlossen werden. :)
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: emule crasht, nachdem Win-Fat32 - Laufwerk eingebunden wurde
« Reply #3 on: April 14, 2004, 04:48:47 PM »

ist übrigens gefixt worden .. also mal auf rc3 warten ;)

gruss