aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: [1] 2

Author Topic: Ubuntu Hardy  (Read 14603 times)

Vollstrecker

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1471
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Ubuntu Hardy
« on: September 29, 2009, 01:31:04 PM »

Thanks to ^marcell! I can announce the upload of  2.2.6 to my repo. I hope everything works like expected.

deb http://www.vollstreckernet.de/ubuntu/ hardy amule-stable upnp

upnp contains libupnp 1.6.6, I hope that the upgrade path is the same like on debian.

For sure, you can get the sources for selfcompile the usual way via:

deb-src http://www.vollstreckernet.de/ubuntu/ hardy amule-stable upnp

You can combine those two possibilities to get just what you want.

If you want an package for your flavour, too. Send me all needed pkg's like in "Debian Stable" thread described.
Logged
Homefucking is killing prostitution

NetRunner

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Re: Ubuntu Hardy
« Reply #1 on: October 02, 2009, 11:50:15 PM »

 Hello,  :)

Thanks for your work  ;)

but Wouston, we have  a problem.  ;D

After a simple : Sudo apt-get update

My terminal say me:

Impossible to find  http://www.vollstreckernet.de/ubuntu/dists/hardy/Release  Unable to find expected entry  amule-stable/source/Sources in Meta-index file (malformed Release file?)

I'm running under Hardy Heron 8.04. For me release.gpg and  amule depot  is ok in Synaptic configuration. Synaptic say " dependency  Matter"

Sorry for my english. I have never learning this language.  :P :P

See you latter on this topic.




« Last Edit: October 02, 2009, 11:56:18 PM by NetRunner »
Logged

Vollstrecker

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1471
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Ubuntu Hardy
« Reply #2 on: October 03, 2009, 01:40:43 AM »

Jep, it's just a problem of the name. I'll change it when I'm back home.
Logged
Homefucking is killing prostitution

gonzo13

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: Ubuntu Hardy
« Reply #3 on: October 03, 2009, 02:03:56 PM »

Hello:

I wrote a message in the wrong place (http://forum.amule.org/index.php?topic=17271.msg93415#msg93415) and marcell correct me (I'm sorry marcell but thank you for your help).

I've done what marcell told me but I can't download from your repository, Vollstrecker. I always get a 302 error:
Quote
Error de GPG: http://www.vollstreckernet.de hardy Release
Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY D63913EF50D0AE60
Imposible obtener http://www.vollstreckernet.de/ubuntu/dists/hardy/amule-stable/source/Sources.gz  302 Found

Another error is that on Synaptic I can see the amule-common 2.2.6-1 but not the others packages. See the attachment picture.

Any solutions? If possible, I would like to compile aMule, but the parge file support in wxWidgets doesn't let me.

Thank you very very much.
Logged

Vollstrecker

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1471
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Ubuntu Hardy
« Reply #4 on: October 03, 2009, 07:02:44 PM »

OK, names are fixed now
@NetRunner: I don't know why your apt tries to read the sources and bins, but now it should work.
@gonzo: Maybe this fixes your problem, too.
Logged
Homefucking is killing prostitution

NetRunner

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Re: Ubuntu Hardy
« Reply #5 on: October 04, 2009, 01:11:02 AM »

Hello

Thanks, Vollstrecker. I try it.

@I don't know why your apt tries to read the sources and bins, but now it should work.

I can't explain it too but today my Hardy have been a big crash. A problem with /var part.  :-\

Gonzo13
@Another error is that on Synaptic I can see the amule-common 2.2.6-1 but not the others packages. See the attachment picture.

I have the same error

Have you a good Howto links to learning compilation of amule "amule-svn".

for all packagers, you make a good job for us, thanks to ALL.

Have a good time  ;)
« Last Edit: October 04, 2009, 11:44:45 AM by NetRunner »
Logged

NetRunner

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Re: Ubuntu Hardy
« Reply #6 on: October 04, 2009, 03:09:20 AM »

I'm back.
It does not work, but amule 2.2.6 is in synaptic.
If i make this code in terminale.

sudo apt-get upgrade
apt want remove amule 2.2.5 and amule-deamon 2.2.5, not update or remove amule-dbg and amule-utils and update amule-common.
This is a problem with dependency: amule-alc / amule-alcc / libwxbase 2.8-0 / libxgtk 2.8-0 and i don't no how to correct/fix it.
apt or synaptic have don't see amule-gnome-support
 :-[ sorry for this back-repport
I come back later
« Last Edit: October 04, 2009, 11:52:35 AM by NetRunner »
Logged

bonico

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 1
Re: Ubuntu Hardy
« Reply #7 on: October 04, 2009, 11:06:30 AM »

I have a problem with dependencies too, with libwxbase 2.8
I'm trying to install amuled and amuleweb on a server edition
any suggest?
Logged

Vollstrecker

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1471
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Ubuntu Hardy
« Reply #8 on: October 04, 2009, 12:43:48 PM »

@NetRunner: Jep, gnome-suport was a creation of festor. I've often told him, that creating packages with different content to the ones in our source-tree, or the ones in official distros can cause problems. Now I am proved right. If you want to be sure, try apt-get dist-upgrade. If this refuses to work, post it's output here.

@bonico: This is not really a good desciption of your problem. If you can't describe better, post the ouput of apt (or whatever packagemanager you use), and your sources.list.
Logged
Homefucking is killing prostitution

NetRunner

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Re: Ubuntu Hardy
« Reply #9 on: October 04, 2009, 06:23:28 PM »

Sorry in my first post, i didn't write to i work  with amule 2.2.5 with amule -gnome-support by Festor.

At this time, i wont to update this version to version  amule 2.2.6. I think is better to restart at this time for all reader of this topic.
Now, your source-tree of  your amule- release and  official french source-tree of official-amule-release are in my sources.list. The official release contain amule-gnome support. The official release come to french Ubuntu Howto (Ubuntu.fr). The two gpg keys are Ok.
I'm thinking now it's better to speak for good working.

What should i for a good update now to do.

@try apt-get dist-upgrade. If this refuses to work, post it's output here.

I make  sudo apt-get dist-upgrade in terminal . And the output is (2 packages removed, 0 package new installed , 2 package conserved , 1 package upgraded)
This package are removed amule amule-deamon.
This package are conserved amule-dbg and amules-utils.
This package is updated amule common.
and the dependency error are the same.
 :P :P :P :P
Tchuss.
Logged

^marcell^

  • Developer
  • Hero Member
  • *****
  • Karma: 28
  • Offline Offline
  • Posts: 529
Re: Ubuntu Hardy
« Reply #10 on: October 05, 2009, 12:26:14 PM »

Sorry in my first post, i didn't write to i work  with amule 2.2.5 with amule -gnome-support by Festor.

At this time, i wont to update this version to version  amule 2.2.6. I think is better to restart at this time for all reader of this topic.
Now, your source-tree of  your amule- release and  official french source-tree of official-amule-release are in my sources.list. The official release contain amule-gnome support. The official release come to french Ubuntu Howto (Ubuntu.fr).
The french ubuntu site offers 2.2.0 as newest aMule for hardy.
Please don't mix official ubuntu releases with this one. I would suggest to remove aMule first, then add the Vollstrecker repository and key, enable "Unstable updates" in synaptic and install version 2.2.6-1 using synaptic.

The two gpg keys are Ok.
Which two keys are ok?
Logged

NetRunner

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Re: Ubuntu Hardy
« Reply #11 on: October 05, 2009, 03:59:07 PM »

Marcell,

thanks for your answer
Quote
Which two keys are ok?

The one: Is your release.gpg in http://www.vollstreckernet.de/ubuntu/dists/hardy/
I download it and add with Synaptic(not the file text  ;) ) or after to have added
Quote
deb http://www.vollstreckernet.de/ubuntu/ hardy amule-stable upnp
deb-src http://www.vollstreckernet.de/ubuntu/ hardy amule-stable upnp
and make
Code: [Select]
sudo apt-get updateat this time, i keeped the last 8 numbers from the error output and maked
Code: [Select]
gpg --recv-key last 8 numbers  
and the second: Come from http://doc.ubuntu-fr.org/amule I had with this code
Code: [Select]
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com B948431914FFEBADC98CD8AFA3CD88794B2C459E and this the release for:
Quote
deb http://ppa.launchpad.net/amule-releases/ppa/ubuntu hardy main
deb-src http://ppa.launchpad.net/amule-releases/ppa/ubuntu hardy main

Quote
enable "Unstable updates" in synaptic
Is this "Hardy backport" in synaptic ?

Now I am going to come back in 2.2.0 after reset of my configuration and trying like you write.

I'm learning aMule , Linux and English

Download make you inteligent. it's dangerous  ;D
see you later
« Last Edit: October 05, 2009, 04:04:01 PM by NetRunner »
Logged

^marcell^

  • Developer
  • Hero Member
  • *****
  • Karma: 28
  • Offline Offline
  • Posts: 529
Re: Ubuntu Hardy
« Reply #12 on: October 05, 2009, 11:31:12 PM »

Code: [Select]
sudo apt-get updateat this time, i keeped the last 8 numbers from the error output and maked
This sound very familiar. It should be ok.

Quote
enable "Unstable updates" in synaptic
Is this "Hardy backport" in synaptic ?
Yes, that is the fourth checkbox option from above.

I'm learning aMule , Linux and English
Sounds like a major project, good luck with it. :)
Logged

pepewilder

  • Newbie
  • *
  • Karma: 2
  • Offline Offline
  • Posts: 4
Re: Ubuntu Hardy
« Reply #13 on: October 06, 2009, 12:09:21 AM »

ok, only to  add this repo
Code: [Select]
deb http://www.vollstreckernet.de/ubuntu/ hardy amule-stable upnp
is not sufficient. After, we should  execute:

Code: [Select]
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com D63913EF50D0AE60
and

Code: [Select]
sudo apt-get update
finally

Code: [Select]
sudo apt-get dist-upgrade
So, all it's fine.

Thanks guys for the repo... and for this release, of course.

Best regards

Updated: Sorry, the url repo was wrong... now it's right.
« Last Edit: October 09, 2009, 01:37:05 PM by pepewilder »
Logged

Vollstrecker

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1471
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: Ubuntu Hardy
« Reply #14 on: October 06, 2009, 02:10:22 PM »

Maybe I shouldn't take it given that everyone has my key already. NOte to myself: Mention wiki-page with needed infos in next repo announce.
Logged
Homefucking is killing prostitution
Pages: [1] 2