aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMuleWeb: can't connect  (Read 11635 times)

borobudur

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
aMuleWeb: can't connect
« on: October 15, 2009, 10:09:34 PM »

Hi, I'm trying to get aMuleWeb running on my linux server but I have some problems.
I described my steps here:

http://ubuntuforums.org/showthread.php?t=1282602

Help would be appreciated. Thanks!
Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4319
Re: aMuleWeb: can't connect
« Reply #1 on: October 15, 2009, 11:08:07 PM »

Hi borobudur,

a) Please update aMule, your version is not supported anymore and we can't help you if you don't upgrade.
b) How do you try to connect when you say you can't connect?
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 166
  • Offline Offline
  • Posts: 2680
Re: aMuleWeb: can't connect
« Reply #2 on: October 16, 2009, 10:15:37 AM »

a) Please update aMule, your version is not supported anymore and we can't help you if you don't upgrade.

Frankly saying, it wasn't supported ever.
Logged
concordia cum veritate

Festor

  • Hero Member
  • *****
  • Karma: 79
  • Offline Offline
  • Posts: 940
  • Offline -> Studying...
Re: aMuleWeb: can't connect
« Reply #3 on: October 16, 2009, 11:11:22 AM »

borobudur

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: aMuleWeb: can't connect
« Reply #4 on: October 18, 2009, 12:02:10 PM »

Thanks to all of you! I have a problem now to install amule.

Added this to the repository list:
Code: [Select]
deb http://www.vollstreckernet.de/ubuntu/ hardy amule-stable upnpAdded the missing key and updated:
Code: [Select]
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com D63913EF50D0AE60Then I removed the old version:
Code: [Select]
$ sudo apt-get remove amule-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libupnp3 libwxbase2.8-0 libcrypto++7 libgeoip1 binutils
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  binutils libupnp3
Suggested packages:
  binutils-doc
The following packages will be REMOVED:
  amule-common amule-daemon
The following NEW packages will be installed:
  binutils libupnp3
0 upgraded, 2 newly installed, 2 to remove and 113 not upgraded.
Need to get 1557kB of archives.
After this operation, 786kB disk space will be freed.
Do you want to continue [Y/n]?
Get:1 http://ch.archive.ubuntu.com hardy/main binutils 2.18.1~cvs20080103-0ubuntu1 [1463kB]
Get:2 http://www.vollstreckernet.de hardy/upnp libupnp3 1:1.6.6-3 [94.5kB]
Fetched 1557kB in 3s (428kB/s)                                   
(Reading database ... 30600 files and directories currently installed.)
Removing amule-daemon ...
Removing amule-common ...
Selecting previously deselected package binutils.
(Reading database ... 30360 files and directories currently installed.)
Unpacking binutils (from .../binutils_2.18.1~cvs20080103-0ubuntu1_i386.deb) ...
Selecting previously deselected package libupnp3.
Unpacking libupnp3 (from .../libupnp3_1%3a1.6.6-3_i386.deb) ...
Setting up binutils (2.18.1~cvs20080103-0ubuntu1) ...

Setting up libupnp3 (1:1.6.6-3) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Now I'm trying to install the new version:
Code: [Select]
$ sudo apt-get install amule
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  amule: Depends: libwxbase2.8-0 (>= 2.8.10.1) but 2.8.7.1-0ubuntu3 is to be installed
         Depends: libwxgtk2.8-0 (>= 2.8.10.1) but it is not going to be installed
E: Broken packages
Any idea?

Perhaps this helps you too:
Code: [Select]
$ sudo apt-cache policy libcrypto++7
libcrypto++7:
  Installed: 5.5.2-1
  Candidate: 5.5.2-1
  Version table:
 *** 5.5.2-1 0
        500 http://ch.archive.ubuntu.com hardy/universe Packages
        100 /var/lib/dpkg/status
$ sudo apt-cache policy libupnp3
libupnp3:
  Installed: 1:1.6.6-3
  Candidate: 1:1.6.6-3
  Version table:
 *** 1:1.6.6-3 0
        500 http://www.vollstreckernet.de hardy/upnp Packages
        100 /var/lib/dpkg/status
$ sudo apt-cache policy libgd2-xpm
libgd2-xpm:
  Installed: 2.0.35.dfsg-3ubuntu2
  Candidate: 2.0.35.dfsg-3ubuntu2
  Version table:
 *** 2.0.35.dfsg-3ubuntu2 0
        500 http://ch.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status
Logged

Festor

  • Hero Member
  • *****
  • Karma: 79
  • Offline Offline
  • Posts: 940
  • Offline -> Studying...
Re: aMuleWeb: can't connect
« Reply #5 on: October 18, 2009, 02:47:29 PM »

Code: [Select]
The following packages have unmet dependencies:
  amule: Depends: libwxbase2.8-0 (>= 2.8.10.1) but 2.8.7.1-0ubuntu3 is to be installed
         Depends: libwxgtk2.8-0 (>= 2.8.10.1) but it is not going to be installed
E: Broken packages
Any idea?

By I can see Vollstrecker builds depends of 2.8.10 release of WxWidgets.

Then you should use this repo:

Quote
deb http://www.vollstreckernet.de/ubuntu/ hardy amule-stable upnp wx

But Vollstrecker packages dont use the official rules of Ubuntu aMule package. Then maybe you should remove all amule packages of your system and not only amule-common.
« Last Edit: October 18, 2009, 02:55:16 PM by Festor »
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1521
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: aMuleWeb: can't connect
« Reply #6 on: October 18, 2009, 02:53:48 PM »

Nope, I have no wx in my hardy repo. As marcell built them, he can maybe tell you which repo he used to get wx.
Logged
Homefucking is killing prostitution

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4319
Re: aMuleWeb: can't connect
« Reply #7 on: October 18, 2009, 03:30:53 PM »

Logged

borobudur

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: aMuleWeb: can't connect
« Reply #8 on: October 18, 2009, 09:06:36 PM »

The link to the wx helped. I was able to install amule:
Code: [Select]
$ amuled -v
amuled: OnInit - starting timer
aMuled 2.2.6 using wxGTK2 v2.8.10 (OS: Linux)
But there are still problems:
Code: [Select]
$ amuled -o
amuled: OnInit - starting timer
Logging to stdout enabled
Initialising aMuled 2.2.6 using wxGTK2 v2.8.10
Checking if there is an instance already running...
No other instances are running.
2009-10-18 21:00:13: amule.cpp(605): Starting aMuled 2.2.6 using wxGTK2 v2.8.10
2009-10-18 21:00:13: ClientCreditsList.cpp(168): Creditfile loaded, 0 clients are known
2009-10-18 21:00:13: IPFilter.cpp(109): Loading IP-filters 'ipfilter.dat' and 'ipfilter_static.dat'.
2009-10-18 21:00:13: IPFilter.cpp(334): Loaded 0 IP-ranges from '/home/borobudur/.aMule/ipfilter.dat'. 0 malformed lines were discarded.
2009-10-18 21:00:13: IPFilter.cpp(334): Loaded 0 IP-ranges from '/home/borobudur/.aMule/ipfilter_static.dat'. 0 malformed lines were discarded.
2009-10-18 21:00:13: ExternalConn.cpp(159): *** TCP socket (ECServer) listening on 0.0.0.0:4712
2009-10-18 21:00:13: MuleUDPSocket.cpp(81): Created Server UDP-Socket at port 4668
ListenSocket: Ok.
2009-10-18 21:00:13: ServerList.cpp(84): Loading server.met file: /home/borobudur/.aMule/server.met
2009-10-18 21:00:13: ServerList.cpp(169): 0 servers in server.met found
Loading temp files from /home/borobudur/.aMule/Temp.

All PartFiles Loaded.
2009-10-18 21:00:13: DownloadQueue.cpp(169): No part files found
No shareable files found in directory: /home/borobudur/.aMule/Incoming
2009-10-18 21:00:13: SharedFileList.cpp(352): Found 0 known shared files
2009-10-18 21:00:13: amule.cpp(803): Connecting
2009-10-18 21:00:13: ServerConnect.cpp(124): No valid servers to which to connect found in server list
2009-10-18 21:00:13: amule.cpp(2191): Kad network cannot be used if UDP port is disabled on preferences, not starting.
FATAL ERROR: Cannot find template:
2009-10-18 21:00:14: amule.cpp(846): web server running on pid 20542
2009-10-18 21:00:14: ThreadScheduler.cpp(308): ThreadScheduler: Completed task 'AICH Syncronizing', 0 tasks remaining.
2009-10-18 21:00:14: ExternalConn.cpp(217): New external connection accepted
2009-10-18 21:00:14: ExternalConn.cpp(251): Connecting client: aMuleweb 2.2.6
2009-10-18 21:00:14: ExternalConn.cpp(306): Access granted.
2009-10-18 21:01:55: TerminationProcess.cpp(49): Command `'amuleweb' '--amule-config-file=/home/borobudur/.aMule/amule.conf'' with pid `20542' has finished with status code `-1'.
2009-10-18 21:01:55: ExternalConn.cpp(116): External connection closed.
2009-10-18 21:02:01: ExternalConn.cpp(217): New external connection accepted
2009-10-18 21:02:01: ExternalConn.cpp(251): Connecting client: aMuleweb 2.2.6
2009-10-18 21:02:01: ExternalConn.cpp(306): Access granted.
And:
Code: [Select]
$ amuleweb -v
looking for template: php-default
checking for directory '/home/borobudur/.aMule/webserver'... no
checking for directory '/usr/share/amule/webserver'... yes
checking for directory '/usr/share/amule/webserver/php-default'... no
checking for directory '/usr/share/amule/webserver'... yes
checking for directory '/usr/share/amule/webserver/php-default'... no
FATAL ERROR: Cannot find template: php-default
This is amuleweb 2.2.6

Creating client...
Succeeded! Connection established to aMule 2.2.6
Index file not found: index.{html,php}
Logged

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4319
Re: aMuleWeb: can't connect
« Reply #9 on: October 18, 2009, 09:11:31 PM »

Please replace php-default by default. We only ship one template (litoral) in recent versions of aMule.
Logged

^marcell^

  • Developer
  • Hero Member
  • *****
  • Karma: 28
  • Offline Offline
  • Posts: 524
Re: aMuleWeb: can't connect
« Reply #10 on: October 26, 2009, 10:04:00 PM »

Nope, I have no wx in my hardy repo. As marcell built them, he can maybe tell you which repo he used to get wx.
Sorry for the late reply. If I recall it correctly I built wxWidgets from the latest stable 2.8.10 wxAll source package. Not sure though, as there is no reason to change this and I never touched wxWidgets ever since.
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 166
  • Offline Offline
  • Posts: 2680
Re: aMuleWeb: can't connect
« Reply #11 on: October 26, 2009, 10:25:11 PM »

Please replace php-default by default. We only ship one template (litoral) in recent versions of aMule.
Would be true for 2.3.x, but not for 2.2.x.
Logged
concordia cum veritate

borobudur

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: aMuleWeb: can't connect
« Reply #12 on: February 26, 2010, 10:51:08 AM »

I changed the php-default to default and the amuleweb has no error anymore:
Code: [Select]
myuser@mymachine:~$ amuleweb -v
looking for template: default
checking for directory '/home/myuser/.aMule/webserver'... no
checking for directory '/usr/share/amule/webserver'... yes
checking for directory '/usr/share/amule/webserver/default'... yes
checking for file '/usr/share/amule/webserver/default/login.php'... yes
This is amuleweb 2.2.6

Creating client...
Succeeded! Connection established to aMule 2.2.6
But I still have an error in amuled:
Code: [Select]
myuser@jakarta:~/.aMule$ amuled -o
amuled: OnInit - starting timer
Logging to stdout enabled
Initialising aMuled 2.2.6 using wxGTK2 v2.8.10
Checking if there is an instance already running...
No other instances are running.
2010-02-26 10:30:41: amule.cpp(605): Starting aMuled 2.2.6 using wxGTK2 v2.8.10
2010-02-26 10:30:41: ClientCreditsList.cpp(168): Creditfile loaded, 0 clients are known
2010-02-26 10:30:41: IPFilter.cpp(109): Loading IP-filters 'ipfilter.dat' and 'ipfilter_static.dat'.
2010-02-26 10:30:41: IPFilter.cpp(334): Loaded 0 IP-ranges from '/home/myuser/.aMule/ipfilter.dat'. 0 malformed lines were discarded.
2010-02-26 10:30:41: IPFilter.cpp(334): Loaded 0 IP-ranges from '/home/myuser/.aMule/ipfilter_static.dat'. 0 malformed lines were discarded.
2010-02-26 10:30:41: ExternalConn.cpp(159): *** TCP socket (ECServer) listening on 0.0.0.0:4712
2010-02-26 10:30:41: MuleUDPSocket.cpp(81): Created Server UDP-Socket at port 4668
ListenSocket: Ok.
2010-02-26 10:30:41: ServerList.cpp(84): Loading server.met file: /home/myuser/.aMule/server.met
2010-02-26 10:30:41: ServerList.cpp(169): 0 servers in server.met found
Loading temp files from /home/myuser/.aMule/Temp.

All PartFiles Loaded.
2010-02-26 10:30:41: DownloadQueue.cpp(169): No part files found
No shareable files found in directory: /home/myuser/.aMule/Incoming
2010-02-26 10:30:41: SharedFileList.cpp(352): Found 0 known shared files
2010-02-26 10:30:41: amule.cpp(803): Connecting
2010-02-26 10:30:41: ServerConnect.cpp(124): No valid servers to which to connect found in server list
2010-02-26 10:30:41: amule.cpp(2191): Kad network cannot be used if UDP port is disabled on preferences, not starting.
---->FATAL ERROR: Cannot find template:
2010-02-26 10:30:42: amule.cpp(846): web server running on pid 13597
2010-02-26 10:30:42: ThreadScheduler.cpp(308): ThreadScheduler: Completed task 'AICH Syncronizing', 0 tasks remaining.
2010-02-26 10:30:42: ExternalConn.cpp(217): New external connection accepted
2010-02-26 10:30:42: ExternalConn.cpp(251): Connecting client: aMuleweb 2.2.6
2010-02-26 10:30:42: ExternalConn.cpp(306): Access granted.
2010-02-26 10:30:53: ExternalConn.cpp(217): New external connection accepted
2010-02-26 10:30:53: ExternalConn.cpp(251): Connecting client: aMuleweb 2.2.6
2010-02-26 10:30:53: ExternalConn.cpp(306): Access granted.
Logged