aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: 1 [2] 3 4 ... 37

Author Topic: RRM's epic struggle for a better aMule on high-speed connections  (Read 74223 times)

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
RRM's epic struggle for a better aMule on high-speed connections
« Reply #15 on: February 23, 2009, 06:58:22 AM »

Thank you.
This is what i got:

Code: [Select]
(gdb) bt full
#0  0xb7f31410 in __kernel_vsyscall ()
No symbol table info available.
#1  0xb727e085 in raise () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#2  0xb727fa01 in abort () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#3  0x08248b64 in ?? ()
No symbol table info available.
#4  0xb748ad05 in ?? () from /usr/lib/libstdc++.so.6
No symbol table info available.
#5  0xb748ad42 in std::terminate () from /usr/lib/libstdc++.so.6
No symbol table info available.
#6  0xb748ae6a in __cxa_throw () from /usr/lib/libstdc++.so.6
No symbol table info available.
#7  0xb748b49e in operator new () from /usr/lib/libstdc++.so.6
No symbol table info available.
#8  0xb766b8d9 in wxSocketEvent::Clone ()
   from /usr/lib/libwx_baseu_net-2.8.so.0
No symbol table info available.
#9  0xb75db1e8 in wxEvtHandler::AddPendingEvent ()
   from /usr/lib/libwx_baseu-2.8.so.0
No symbol table info available.
#10 0xb766b77b in wxSocketBase::OnRequest ()
---Type <return> to continue, or q <return> to quit---

and bt:

Code: [Select]
(gdb) bt
#0  0xb7f31410 in __kernel_vsyscall ()
#1  0xb727e085 in raise () from /lib/tls/i686/cmov/libc.so.6
#2  0xb727fa01 in abort () from /lib/tls/i686/cmov/libc.so.6
#3  0x08248b64 in ?? ()
#4  0xb748ad05 in ?? () from /usr/lib/libstdc++.so.6
#5  0xb748ad42 in std::terminate () from /usr/lib/libstdc++.so.6
#6  0xb748ae6a in __cxa_throw () from /usr/lib/libstdc++.so.6
#7  0xb748b49e in operator new () from /usr/lib/libstdc++.so.6
#8  0xb766b8d9 in wxSocketEvent::Clone ()
   from /usr/lib/libwx_baseu_net-2.8.so.0
#9  0xb75db1e8 in wxEvtHandler::AddPendingEvent ()
   from /usr/lib/libwx_baseu-2.8.so.0
#10 0xb766b77b in wxSocketBase::OnRequest ()
   from /usr/lib/libwx_baseu_net-2.8.so.0
#11 0xb766b894 in wx_socket_callback () from /usr/lib/libwx_baseu_net-2.8.so.0
#12 0xb766fd47 in GSocket::Detected_Write ()
   from /usr/lib/libwx_baseu_net-2.8.so.0
#13 0xb77b41b7 in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#14 0xb6e6cbdf in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#15 0xb6d4ffed in ?? () from /usr/lib/libglib-2.0.so.0
#16 0xb6d1bcc6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#17 0xb6d1f083 in ?? () from /usr/lib/libglib-2.0.so.0
#18 0xb6d1f467 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit--
#19 0xb701e264 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#20 0xb77b271c in wxEventLoop::Run () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#21 0xb785532e in wxAppBase::MainLoop ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0
#22 0xb7854981 in wxAppBase::OnRun () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#23 0xb756f05a in wxEntry () from /usr/lib/libwx_baseu-2.8.so.0
#24 0xb756f107 in wxEntry () from /usr/lib/libwx_baseu-2.8.so.0
#25 0x0814f300 in ?? ()
#26 0xb7269450 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#27 0x08084c41 in ?? ()

Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
RRM's epic struggle for a better aMule on high-speed connections
« Reply #16 on: February 23, 2009, 07:02:33 AM »

Thank you for your support.

Quote
What is the output of
Code: [Select]
$ which amuleweb

nothing, just
Code: [Select]
$
Quote
Otherwise install the amule-daemon package.
What line do i need to insert to install amule-daemon?
(I apologize for over-asking)
« Last Edit: February 23, 2009, 07:19:33 AM by RRM »
Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
RRM's epic struggle for a better aMule on high-speed connections
« Reply #17 on: February 23, 2009, 06:38:28 PM »

And more crashes, which seem identical to the previous ones, to me

Code: [Select]
Terminated after throwing an instance of 'std::bad_alloc'
what(): std::bad_alloc
* Could not get symbol names for backtrace
backtrace:


Program received signal SIGABRT, Aborted.
[Switching to Thread 0xb69176c0 (LWP 8758)]
0xb7f01410 in __kernel_vsyscall ()
(gdb) bt full
#0  0xb7f01410 in __kernel_vsyscall ()
No symbol table info available.
#1  0xb724e085 in raise () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#2  0xb724fa01 in abort () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#3  0x08248b64 in ?? ()
No symbol table info available.
#4  0xb745ad05 in ?? () from /usr/lib/libstdc++.so.6
No symbol table info available.
#5  0xb745ad42 in std::terminate () from /usr/lib/libstdc++.so.6
No symbol table info available.
#6  0xb745ae6a in __cxa_throw () from /usr/lib/libstdc++.so.6
No symbol table info available.
#7  0xb745b49e in operator new () from /usr/lib/libstdc++.so.6
No symbol table info available.
#8  0xb7536ef6 in wxObjectList::CreateNode ()
   from /usr/lib/libwx_baseu-2.8.so.0
No symbol table info available.
#9  0xb754a5cb in wxListBase::Append () from /usr/lib/libwx_baseu-2.8.so.0
No symbol table info available.
#10 0xb75ab20f in wxEvtHandler::AddPendingEvent ()
   from /usr/lib/libwx_baseu-2.8.so.0
---Type <return> to continue, or q <return> to quit---
No symbol table info available.
#11 0xb763b77b in wxSocketBase::OnRequest ()
   from /usr/lib/libwx_baseu_net-2.8.so.0
No symbol table info available.
#12 0xb763b894 in wx_socket_callback () from /usr/lib/libwx_baseu_net-2.8.so.0
No symbol table info available.
#13 0xb763fd47 in GSocket::Detected_Write ()
   from /usr/lib/libwx_baseu_net-2.8.so.0
No symbol table info available.
#14 0xb77841b7 in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
No symbol table info available.
#15 0xb6e3cbdf in ?? () from /usr/lib/libgdk-x11-2.0.so.0
No symbol table info available.
#16 0xb6d1ffed in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#17 0xb6cebcc6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#18 0xb6cef083 in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#19 0xb6cef467 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#20 0xb6fee264 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
---Type <return> to continue, or q <return> to quit---
#21 0xb778271c in wxEventLoop::Run () from /usr/lib/libwx_gtk2u_core-2.8.so.0
No symbol table info available.
#22 0xb782532e in wxAppBase::MainLoop ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0
No symbol table info available.
#23 0xb7824981 in wxAppBase::OnRun () from /usr/lib/libwx_gtk2u_core-2.8.so.0
No symbol table info available.
#24 0xb753f05a in wxEntry () from /usr/lib/libwx_baseu-2.8.so.0
No symbol table info available.
#25 0xb753f107 in wxEntry () from /usr/lib/libwx_baseu-2.8.so.0
No symbol table info available.
#26 0x0814f300 in ?? ()
No symbol table info available.
#27 0xb7239450 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#28 0x08084c41 in ?? ()
No symbol table info available.

and bt:

Code: [Select]
(gdb) bt
#0  0xb7f01410 in __kernel_vsyscall ()
#1  0xb724e085 in raise () from /lib/tls/i686/cmov/libc.so.6
#2  0xb724fa01 in abort () from /lib/tls/i686/cmov/libc.so.6
#3  0x08248b64 in ?? ()
#4  0xb745ad05 in ?? () from /usr/lib/libstdc++.so.6
#5  0xb745ad42 in std::terminate () from /usr/lib/libstdc++.so.6
#6  0xb745ae6a in __cxa_throw () from /usr/lib/libstdc++.so.6
#7  0xb745b49e in operator new () from /usr/lib/libstdc++.so.6
#8  0xb7536ef6 in wxObjectList::CreateNode ()
   from /usr/lib/libwx_baseu-2.8.so.0
#9  0xb754a5cb in wxListBase::Append () from /usr/lib/libwx_baseu-2.8.so.0
#10 0xb75ab20f in wxEvtHandler::AddPendingEvent ()
   from /usr/lib/libwx_baseu-2.8.so.0
#11 0xb763b77b in wxSocketBase::OnRequest ()
   from /usr/lib/libwx_baseu_net-2.8.so.0
#12 0xb763b894 in wx_socket_callback () from /usr/lib/libwx_baseu_net-2.8.so.0
#13 0xb763fd47 in GSocket::Detected_Write ()
   from /usr/lib/libwx_baseu_net-2.8.so.0
#14 0xb77841b7 in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#15 0xb6e3cbdf in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#16 0xb6d1ffed in ?? () from /usr/lib/libglib-2.0.so.0
#17 0xb6cebcc6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#18 0xb6cef083 in ?? () from /usr/lib/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#19 0xb6cef467 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#20 0xb6fee264 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#21 0xb778271c in wxEventLoop::Run () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#22 0xb782532e in wxAppBase::MainLoop ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0
#23 0xb7824981 in wxAppBase::OnRun () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#24 0xb753f05a in wxEntry () from /usr/lib/libwx_baseu-2.8.so.0
#25 0xb753f107 in wxEntry () from /usr/lib/libwx_baseu-2.8.so.0
#26 0x0814f300 in ?? ()
#27 0xb7239450 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#28 0x08084c41 in ?? ()
« Last Edit: February 23, 2009, 06:53:44 PM by RRM »
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
RRM's epic struggle for a better aMule on high-speed connections
« Reply #18 on: February 23, 2009, 09:27:25 PM »

And more crashes, which seem identical to the previous ones, to me

Congratulations! You got almost good backtraces. You did everything right.

 Unfortunately some debug information is missing. It may be the case you will need to compile emule yourself, however lets try first with standard Ubuntu packages. Run

Code: [Select]
$ sudo aptitude install libc6-dbg libcairo2-dbg libgcc1-dbg libglib2.0-0-dbg libgtk2.0-0-dbg libstdc++6-4.3-dbg libwxbase2.8-dbg libwxgtk2.8-dbg libx11-6-dbg libx11-xcb1-dbg libxcb1-dbg

Once those packages are installed, your backtraces should look much more detailed. Please try to get a new one and post it in the backtraces forum.

If the backtraces are not good enough you will need to compile aMule.

btw, you can install amule daemon with synaptic or aptitude
Code: [Select]
$ sudo aptitude install amule-daemon
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
RRM's epic struggle for a better aMule on high-speed connections
« Reply #19 on: February 23, 2009, 09:37:13 PM »

By the way RRM, could you post the output of the following commands (needed for debugging your crash)

Code: [Select]
$ lsb_release -a
$ uname -a
$ dpkg-architecture
$ dpkg -l libwx*

Regards
Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
RRM's epic struggle for a better aMule on high-speed connections
« Reply #20 on: February 25, 2009, 06:17:02 PM »

Thank you for sticking with me, btkaos.

Quote
lets try first with standard Ubuntu packages. Run

Code: [Select]
$ sudo aptitude install libc6-dbg libcairo2-dbg libgcc1-dbg libglib2.0-0-dbg libgtk2.0-0-dbg libstdc++6-4.3-dbg libwxbase2.8-dbg libwxgtk2.8-dbg libx11-6-dbg libx11-xcb1-dbg libxcb1-dbg

I get this in response
Code: [Select]
Couldn't find any package whose name or description matched "libstdc++6-4.3-dbg"
Couldn't find any package whose name or description matched "libstdc++6-4.3-dbg"
The following packages are unused and will be REMOVED:
  libupnp2
The following NEW packages will be automatically installed:
  libc6-dev linux-libc-dev wx2.8-headers
The following NEW packages will be installed:
  libc6-dbg libc6-dev libcairo2-dbg libgcc1-dbg libglib2.0-0-dbg
  libgtk2.0-0-dbg libwxbase2.8-dbg libwxgtk2.8-dbg libx11-6-dbg
  libx11-xcb1-dbg libxcb1-dbg linux-libc-dev wx2.8-headers
0 packages upgraded, 13 newly installed, 1 to remove and 0 not upgraded.
Need to get 54,5MB of archives. After unpacking 161MB will be used.
Do you want to continue?


I continued, and everything seemed to go well
Do i need to post a translated report of that?; some of it is in dutch, here it is:

Code: [Select]
Writing extended state information... Klaar
Get:1 http://nl.archive.ubuntu.com hardy-updates/main linux-libc-dev 2.6.24-23.48 [703kB]
Get:2 http://nl.archive.ubuntu.com hardy-updates/main libc6-dev 2.7-10ubuntu4 [3344kB]
Get:3 http://nl.archive.ubuntu.com hardy/universe wx2.8-headers 2.8.7.1-0ubuntu3 [1086kB]
Get:4 http://nl.archive.ubuntu.com hardy-updates/main libc6-dbg 2.7-10ubuntu4 [5095kB]
Get:5 http://nl.archive.ubuntu.com hardy-updates/main libcairo2-dbg 1.6.0-0ubuntu2 [747kB]
Get:6 http://nl.archive.ubuntu.com hardy-updates/main libgcc1-dbg 1:4.2.4-1ubuntu3 [49,2kB]
Get:7 http://nl.archive.ubuntu.com hardy-updates/main libglib2.0-0-dbg 2.16.6-0ubuntu1 [1102kB]
Get:8 http://nl.archive.ubuntu.com hardy-updates/main libgtk2.0-0-dbg 2.12.9-3ubuntu5 [9451kB]
Get:9 http://nl.archive.ubuntu.com hardy/universe libwxbase2.8-dbg 2.8.7.1-0ubuntu3 [3963kB]
Get:10 http://nl.archive.ubuntu.com hardy/universe libwxgtk2.8-dbg 2.8.7.1-0ubuntu3 [26,2MB]
Get:11 http://nl.archive.ubuntu.com hardy/main libx11-6-dbg 2:1.1.3-1ubuntu2 [2586kB]
Get:12 http://nl.archive.ubuntu.com hardy/main libx11-xcb1-dbg 2:1.1.3-1ubuntu2 [72,6kB]
Get:13 http://nl.archive.ubuntu.com hardy/main libxcb1-dbg 1.1-1ubuntu1 [89,9kB]
Fetched 54,5MB in 4s (13,4MB/s)
(Database inlezen ... 96387 bestanden en mappen geïnstalleerd.)
libupnp2 wordt verwijderd ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Selecteren van voorheen niet geselecteerd pakket linux-libc-dev.
(Database inlezen ... 96379 bestanden en mappen geïnstalleerd.)
Uitpakken van linux-libc-dev (uit .../linux-libc-dev_2.6.24-23.48_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libc6-dev.
Uitpakken van libc6-dev (uit .../libc6-dev_2.7-10ubuntu4_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket wx2.8-headers.
Uitpakken van wx2.8-headers (uit .../wx2.8-headers_2.8.7.1-0ubuntu3_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libc6-dbg.
Uitpakken van libc6-dbg (uit .../libc6-dbg_2.7-10ubuntu4_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libcairo2-dbg.
Uitpakken van libcairo2-dbg (uit .../libcairo2-dbg_1.6.0-0ubuntu2_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libgcc1-dbg.
Uitpakken van libgcc1-dbg (uit .../libgcc1-dbg_1%3a4.2.4-1ubuntu3_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libglib2.0-0-dbg.
Uitpakken van libglib2.0-0-dbg (uit .../libglib2.0-0-dbg_2.16.6-0ubuntu1_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libgtk2.0-0-dbg.
Uitpakken van libgtk2.0-0-dbg (uit .../libgtk2.0-0-dbg_2.12.9-3ubuntu5_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libwxbase2.8-dbg.
Uitpakken van libwxbase2.8-dbg (uit .../libwxbase2.8-dbg_2.8.7.1-0ubuntu3_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libwxgtk2.8-dbg.
Uitpakken van libwxgtk2.8-dbg (uit .../libwxgtk2.8-dbg_2.8.7.1-0ubuntu3_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libx11-6-dbg.
Uitpakken van libx11-6-dbg (uit .../libx11-6-dbg_2%3a1.1.3-1ubuntu2_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libx11-xcb1-dbg.
Uitpakken van libx11-xcb1-dbg (uit .../libx11-xcb1-dbg_2%3a1.1.3-1ubuntu2_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libxcb1-dbg.
Uitpakken van libxcb1-dbg (uit .../libxcb1-dbg_1.1-1ubuntu1_i386.deb) ...
Instellen van linux-libc-dev (2.6.24-23.48) ...
Instellen van libc6-dev (2.7-10ubuntu4) ...
Instellen van wx2.8-headers (2.8.7.1-0ubuntu3) ...
Instellen van libc6-dbg (2.7-10ubuntu4) ...
Instellen van libcairo2-dbg (1.6.0-0ubuntu2) ...
Instellen van libgcc1-dbg (1:4.2.4-1ubuntu3) ...
Instellen van libglib2.0-0-dbg (2.16.6-0ubuntu1) ...
Instellen van libgtk2.0-0-dbg (2.12.9-3ubuntu5) ...
Instellen van libwxbase2.8-dbg (2.8.7.1-0ubuntu3) ...

Instellen van libwxgtk2.8-dbg (2.8.7.1-0ubuntu3) ...

Instellen van libx11-6-dbg (2:1.1.3-1ubuntu2) ...
Instellen van libx11-xcb1-dbg (2:1.1.3-1ubuntu2) ...
Instellen van libxcb1-dbg (1.1-1ubuntu1) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Pakketlijsten worden ingelezen... Klaar   
Boom van vereisten wordt opgebouwd       
Reading state information... Klaar
Reading extended state information       
Initializing package states... Klaar
Writing extended state information... Klaar
Building tag database... Klaar

Quote
btw, you can install amule daemon with synaptic or aptitude

Can i do both?
(install amule daemon and keep amule-common, alongside)
or will that cause a conflict?
« Last Edit: February 25, 2009, 06:19:14 PM by RRM »
Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
RRM's epic struggle for a better aMule on high-speed connections
« Reply #21 on: February 25, 2009, 06:31:07 PM »

By the way RRM, could you post the output of the following commands (needed for debugging your crash)

Code: [Select]
$ lsb_release -a

Code: [Select]
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 8.04.2
Release: 8.04
Codename: hardy

Quote
Code: [Select]
$ uname -a

Code: [Select]
Linux rrm-desktop 2.6.24-23-generic #1 SMP Mon Jan 26 00:13:11 UTC 2009 i686 GNU/Linux

Quote
Code: [Select]
$ dpkg-architecture

Code: [Select]
The program 'dpkg-architecture' is currently not installed.  You can install it by typing:
sudo apt-get install dpkg-dev
bash: dpkg-architecture: command not found

So, i did, and then i got:
Code: [Select]
DEB_BUILD_ARCH=i386
DEB_BUILD_ARCH_OS=linux
DEB_BUILD_ARCH_CPU=i386
DEB_BUILD_GNU_CPU=i486
DEB_BUILD_GNU_SYSTEM=linux-gnu
DEB_BUILD_GNU_TYPE=i486-linux-gnu
DEB_HOST_ARCH=i386
DEB_HOST_ARCH_OS=linux
DEB_HOST_ARCH_CPU=i386
DEB_HOST_GNU_CPU=i486
DEB_HOST_GNU_SYSTEM=linux-gnu
DEB_HOST_GNU_TYPE=i486-linux-gnu

Quote
Code: [Select]
$ dpkg -l libwx*

Code: [Select]
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name            Version          Description
+++-===============-===============-==============================================
ii  libwxbase2.8-0  2.8.7.1-0ubuntu wxBase library (runtime) - non-GUI support cla
ii  libwxbase2.8-db 2.8.7.1-0ubuntu wxBase library (debug) - non-GUI support class
un  libwxgtk2.6-0   <none>          (no description available)
ii  libwxgtk2.8-0   2.8.7.1-0ubuntu wxWidgets Cross-platform C++ GUI toolkit (GTK+
ii  libwxgtk2.8-dbg 2.8.7.1-0ubuntu wxWidgets Cross-platform C++ GUI toolkit (GTK+

Regards,
Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
RRM's epic struggle for a better aMule on high-speed connections
« Reply #22 on: February 25, 2009, 06:47:27 PM »

In the sticky thread "Do not post about crashes of aMule SVN Snapshot" i read:

Quote
Nobody here can and will help you with months old SVN versions, or official releases 2.1.3 or before.

So, im VERY happy ;D that you guided me into installing amule 2.2.3 btkaos,
because i could never have done that without your patient help.
Thank you.  8)

Btw: im sure there are more dummies like me who could badly use your help,
so, wouldnt it be useful to have a sticky thread (including your instruction posts) in this forum titled:
"How to install amule 2.2.3 for dummies with a pre-installed older version" ?

... and... how can i get to know what platform (32 or 64 bits) i use?
« Last Edit: February 25, 2009, 07:26:37 PM by RRM »
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
RRM's epic struggle for a better aMule on high-speed connections
« Reply #23 on: February 26, 2009, 01:13:50 AM »

Hi RRM, good job!

Read the output of the commands and try to make sense of them.

Your title did confuse me, as you said "Ubuntu 8.10 64bits" but note from the output of lsb-release and dpkg-architecture you are actually running Ubuntu 8.04 and in 32bits.

As you are running Ubuntu 8.04, the package you failed to install is named libstdc++6-4.2-dbg (use sudo aptitude install libstdc++6-4.2-dbg)

Now your backtraces should be much better, try to get one. Anyways you have a different problem, you are running a old wxwidgets release. You could upgrade Ubuntu to get 2.8.8 (not so bad IMHO) or we could try to install a new one. I strongly recommend upgrading your Ubuntu unless you need the LTS.

Anyways, try to get again a backtrace, now with all the debug packages it should be better.

I'm afraid I won't be able to help you a lot, as I'm currently running Ubuntu 8.10 64bits, which is a very different release from yours.
 (note Ubuntu 64bits is for advanced users, some things work better in 32bits)

Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
RRM's epic struggle for a better aMule on high-speed connections
« Reply #24 on: February 26, 2009, 06:50:24 AM »

Thank you btkaos.

Quote
Your title did confuse me, as you said "Ubuntu 8.10 64bits"

That wasnt me; i didnt start this thread...
I also didnt intentionally hijack this thread; i just pinched in as i thought that a script might solve the problem
, or some gui adjustments.
And then you responded, luckily for me.

Quote
note from the output of lsb-release and dpkg-architecture you are actually running Ubuntu 8.04 and in 32bits.

I did notice the Ubuntu 8.04 info, but where do you read "32 bits"?

Quote
use sudo aptitude install libstdc++6-4.2-dbg

Thank you. Done.

Quote
Now your backtraces should be much better, try to get one.

Is this one good enough to post in the backtrace forum?

Code: [Select]
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb69af6c0 (LWP 18747)]
0xb781c1b4 in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
(gdb) bt
#0  0xb781c1b4 in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#1  0xb6ed4bdf in gdk_io_invoke (source=0xb265c6c0,
    condition=<value optimized out>, data=0xb2502038)
    at /build/buildd/gtk+2.0-2.12.9/gdk/gdkevents.c:986
#2  0xb6db7fed in g_io_unix_dispatch (source=0xb1f782b8,
    callback=0xb6ed4b80 <gdk_io_invoke>, user_data=0xb2502038)
    at /build/buildd/glib2.0-2.16.6/glib/giounix.c:162
#3  0xb6d83cc6 in IA__g_main_context_dispatch (context=0x866ef80)
    at /build/buildd/glib2.0-2.16.6/glib/gmain.c:2012
#4  0xb6d87083 in g_main_context_iterate (context=0x866ef80, block=1,
    dispatch=1, self=0x8670480)
    at /build/buildd/glib2.0-2.16.6/glib/gmain.c:2645
#5  0xb6d87467 in IA__g_main_loop_run (loop=0x8d54c78)
    at /build/buildd/glib2.0-2.16.6/glib/gmain.c:2853
#6  0xb7086264 in IA__gtk_main ()
    at /build/buildd/gtk+2.0-2.12.9/gtk/gtkmain.c:1163
#7  0xb781a71c in wxEventLoop::Run () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#8  0xb78bd32e in wxAppBase::MainLoop ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0
#9  0xb78bc981 in wxAppBase::OnRun () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#10 0xb75d705a in wxEntry () from /usr/lib/libwx_baseu-2.8.so.0
#11 0xb75d7107 in wxEntry () from /usr/lib/libwx_baseu-2.8.so.0
#12 0x0814f300 in ?? ()
---Type <return> to continue, or q <return> to quit---
#13 0xb72d1450 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#14 0x08084c41 in ?? ()

bt full ("no symbol table avalailable"...):

Code: [Select]
#0  0xb781c1b4 in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
No symbol table info available.
#1  0xb6ed4bdf in gdk_io_invoke (source=0xb265c6c0,
    condition=<value optimized out>, data=0xb2502038)
    at /build/buildd/gtk+2.0-2.12.9/gdk/gdkevents.c:986
gdk_cond = GDK_INPUT_WRITE
#2  0xb6db7fed in g_io_unix_dispatch (source=0xb1f782b8,
    callback=0xb6ed4b80 <gdk_io_invoke>, user_data=0xb2502038)
    at /build/buildd/glib2.0-2.16.6/glib/giounix.c:162
buffer_condition = 0
#3  0xb6d83cc6 in IA__g_main_context_dispatch (context=0x866ef80)
    at /build/buildd/glib2.0-2.16.6/glib/gmain.c:2012
No locals.
#4  0xb6d87083 in g_main_context_iterate (context=0x866ef80, block=1,
    dispatch=1, self=0x8670480)
    at /build/buildd/glib2.0-2.16.6/glib/gmain.c:2645
max_priority = 2147483647
timeout = 5
some_ready = 1
nfds = <value optimized out>
allocated_nfds = <value optimized out>
fds = (GPollFD *) 0xb2553070
__PRETTY_FUNCTION__ = "g_main_context_iterate"
---Type <return> to continue, or q <return> to quit---
#5  0xb6d87467 in IA__g_main_loop_run (loop=0x8d54c78)
    at /build/buildd/glib2.0-2.16.6/glib/gmain.c:2853
self = (GThread *) 0x8670480
__PRETTY_FUNCTION__ = "IA__g_main_loop_run"
#6  0xb7086264 in IA__gtk_main ()
    at /build/buildd/gtk+2.0-2.12.9/gtk/gtkmain.c:1163
tmp_list = (GList *) 0x0
functions = (GList *) 0x0
init = (GtkInitFunction *) 0x8d54188
loop = (GMainLoop *) 0x8d54c78
#7  0xb781a71c in wxEventLoop::Run () from /usr/lib/libwx_gtk2u_core-2.8.so.0
No symbol table info available.
#8  0xb78bd32e in wxAppBase::MainLoop ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0
No symbol table info available.
#9  0xb78bc981 in wxAppBase::OnRun () from /usr/lib/libwx_gtk2u_core-2.8.so.0
No symbol table info available.
#10 0xb75d705a in wxEntry () from /usr/lib/libwx_baseu-2.8.so.0
No symbol table info available.
#11 0xb75d7107 in wxEntry () from /usr/lib/libwx_baseu-2.8.so.0
No symbol table info available.
#12 0x0814f300 in ?? ()
No symbol table info available.
---Type <return> to continue, or q <return> to quit---
#13 0xb72d1450 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#14 0x08084c41 in ?? ()
No symbol table info available.

Quote
I strongly recommend upgrading your Ubuntu unless you need the LTS.

Ok, then i will do that. (i guess i better get support at the ubuntu forum for that, right?)
So, I better focus on that instead of getting the backtraces analyzed, right?

Quote
(note Ubuntu 64bits is for advanced users, some things work better in 32bits)

I had no idea. Im certainly not an 'advanced user'  ;D ;D ;D
I apologize for the confusion.
Again, thank you for all the help you gave me.
« Last Edit: February 26, 2009, 07:59:26 AM by RRM »
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2678
RRM's epic struggle for a better aMule on high-speed connections
« Reply #25 on: February 26, 2009, 08:13:54 AM »

Im certainly not an 'advanced user'
You certainly will be, soon. Unless you stop reading posts from btkaos.
Logged
concordia cum veritate

wuischke

  • Developer
  • Hero Member
  • *****
  • Karma: 183
  • Offline Offline
  • Posts: 4319
RRM's epic struggle for a better aMule on high-speed connections
« Reply #26 on: February 26, 2009, 09:47:03 AM »

RRM: dpkg-architecture tells that you are running 32 bit. This crpytic "i486" (A pre-pentium processor architecture) is sure sign for 32 bit. Also i586, i386, i686 or ia32.
If you have amd64 or x86_64, it's 64 bit.

How to update Ubuntu: "sudo update-manager -d" will start a graphical manager for this.
Logged

rogerbenham

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
RRM's epic struggle for a better aMule on high-speed connections
« Reply #27 on: February 26, 2009, 04:44:48 PM »

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------

Current version is: aMule 2.2.2 using wxGTK2 v2.8.8

Running on: Linux 2.6.27-11-generic i686





** (amule:6684): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed



** (amule:6684): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed

[2] wxString::~wxString() in amule [0x8086451]

[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0xb77e6d96]

[4] ?? in [0xb80ea400]

[5] ?? in [0xde1f1f2]

[6] ?? in /usr/lib/libgdk-x11-2.0.so.0 [0xb70404af]

[7] ?? in /usr/lib/libglib-2.0.so.0 [0xb6dde6fd]

[8] g_main_context_dispatch in /usr/lib/libglib-2.0.so.0[0xb6da76f8]

[9] ?? in /usr/lib/libglib-2.0.so.0 [0xb6daada3]

[10] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0xb6dab2c2]

[11] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0xb71d83a9]

[12] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xb79aee95]

[13] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xb7a455ce]

[14] wxAppBase::OnRun() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0xb7a451a1]

[15] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0xb777da7a]

[16] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.8.so.0[0xb777dc77]

[17] CryptoPP::IteratedHash<unsigned int, CryptoPP::EnumToType<CryptoPP::ByteOrder, 0>, 64u, CryptoPP::HashTransformation>::~IteratedHash() in amule [0x8145a70]

[18] __libc_start_main in /lib/tls/i686/cmov/libc.so.6[0xb746a685]

[19] ?? in amule [0x8085261]





--------------------------------------------------------------------------------




Logged

RRM

  • Sr. Member
  • ****
  • Karma: 40
  • Offline Offline
  • Posts: 444
RRM's epic struggle for a better aMule on high-speed connections
« Reply #28 on: February 26, 2009, 07:05:55 PM »

Hi rogerbenham,

I guess you will be adviced to upgrade to amule 2.2.3
because in this sticky thread a developer wrote:
Quote from: Stu Redman
We are always glad about error reports, which help us improve aMule. If (and only if) they are about:
1) the current official release (which is 2.2.3 at the moment)

Regards,
_______________________________________________________________________________

RRM: dpkg-architecture tells that you are running 32 bit. This crpytic "i486" (A pre-pentium processor architecture) is sure sign for 32 bit. Also i586, i386, i686 or ia32.
If you have amd64 or x86_64, it's 64 bit.

Thank you for that valuable info. This is a great forum...
Maybe its a good idea to compile 'info-for-dummies' like this in the wiki?

Quote
How to update Ubuntu: "sudo update-manager -d" will start a graphical manager for this.

Thank you. Initially i thought that a 'more specific (and complicated) upgrade' was required;
i didnt think of this simple solution.
My Ubuntu has been upgraded to 8.10 now.
« Last Edit: February 26, 2009, 09:18:04 PM by RRM »
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
RRM's epic struggle for a better aMule on high-speed connections
« Reply #29 on: February 27, 2009, 01:27:59 PM »

Hi RRM,

Is this one good enough to post in the backtrace forum?

Code: [Select]
#0  0xb781c1b4 in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
No symbol table info available.
#1  0xb6ed4bdf in gdk_io_invoke (source=0xb265c6c0,
    condition=<value optimized out>, data=0xb2502038)
    at /build/buildd/gtk+2.0-2.12.9/gdk/gdkevents.c:986
gdk_cond = GDK_INPUT_WRITE
#2  0xb6db7fed in g_io_unix_dispatch (source=0xb1f782b8,
    callback=0xb6ed4b80 <gdk_io_invoke>, user_data=0xb2502038)
    at /build/buildd/glib2.0-2.16.6/glib/giounix.c:162
buffer_condition = 0

It is almost good. But unfortunately your crash is happening inside libwxgtk in a weird manner. I don't know why, but Ubuntu -dbg packages for libwx are broken :( I'm already looking into that as I'd like to be able just to install standard debug packages and get good backtraces.

By the way, is your system stable apart from aMule?

Quote

Quote
I strongly recommend upgrading your Ubuntu unless you need the LTS.

Ok, then i will do that. (i guess i better get support at the ubuntu forum for that, right?)
So, I better focus on that instead of getting the backtraces analyzed, right?
You need to upgrade your wx library, that's for sure. An easy way is to upgrade your Ubuntu installation, unless you have a specific reason to stick to 8.04
It's likely once you upgrade is finished your crash will be gone.

Quote
Quote
(note Ubuntu 64bits is for advanced users, some things work better in 32bits)

I had no idea. Im certainly not an 'advanced user'  ;D ;D ;D
I apologize for the confusion.
Again, thank you for all the help you gave me.
You are welcome. I just mean some things in 64bit land are a little bit more cumbersome, like installing flash or skype. You should also expect more bugs. So, if you don't need 64bits (4Gb or more of ram) 32bits are clearly the best choice.
« Last Edit: February 27, 2009, 01:32:07 PM by btkaos »
Logged
Pages: 1 [2] 3 4 ... 37