aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: compile amule-dev tarballs  (Read 1819 times)

sulliwane

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
compile amule-dev tarballs
« on: June 23, 2010, 11:15:48 PM »

Bonjour à tous,

je découvre le côté français du forum, et au risque de doubler la question (postée dans la section anglaise)

voici mon problème :

j'ai téléchargé le dernier tar.gz de amule que je compte compiler.

Cependant, une fois compilé, comme j'installe amule sur un server, seul amule-daemon et amule-cmd me serviront.

avec apt-get, ils étaient installé avec amule-utils.

Amuled et amuleweb seront-ils sompris dans le tar.gz que je m'apprête à compiler ?

Merci de vos réponses,
chaleureusement
victor
Logged

sulliwane

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
Re: compile amule-dev tarballs
« Reply #1 on: June 25, 2010, 12:38:58 AM »

mon problème est due à ma grande méconnaissance des méthode et des étapes de compilation.

Voici la réponse (postée sur le forum anglais)

il faut ajouter des options à la commande #./configure   pour spécifier quels sous programmes on souhaite compiler (ou ne pas compiler)

Dans mon cas, l'installation sur mon serveur permet de se passer de l'interface graphique. Voici la commande pour ne compiler que amuled, amuleweb et amulecmd :

Code: [Select]
./configure --disable-monolithic --enable-amule-daemon --enable-webserver  --enable-amulecmd
Avec cette solution viens un nouveau problème : dans mon cas (ubuntu 9.10 server) lorsque je lance cette commande dans le dossier de sources, j'obtiens le message d'erreur suivant :

Code: [Select]
checking for libupnp version >= 1.6.6... no (try to use --with-libupnp-prefix=PREFIX)
configure: WARNING:
        UPnP code has been disabled because libupnp >= 1.6.6 not found (try to use --with-libupnp-prefix=PREFIX).
checking for crypto++ version >= 5.1... no
configure: error:
        Could not find crypto++ header file "cryptlib.h".
        Please try again with --with-crypto-prefix=/my_crypto_prefix
        (replace /my_crypto_prefix with a valid path to your crypto++
        installation directory).

quelqu'un sait-il ou trouver ce fameux fichier cryptlib.h  ?

a +
Logged