aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMule crashes after a while - I don't know why  (Read 2595 times)

kmarien

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
aMule crashes after a while - I don't know why
« on: August 05, 2010, 09:33:37 PM »

This is the output in a terminal (Ubuntu Lucid 10.02 32 bit with aMule from standard ubuntu repository):

Invalid Kad tag; type=0xd2 name=

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/index.php?board=67.0
If possible, please try to generate a real backtrace of this crash:
    http://wiki.amule.org/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.2.6 using wxGTK2 v2.8.10
Running on: Linux 2.6.32-24-generic i686

[2] ?? in amule[0x8084a89]
[3] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0x31bba6]
[4] ?? in [0xfbd400]
[5] ?? in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x639424]
[6] ?? in /usr/lib/libgdk-x11-2.0.so.0[0x88032c]
[7] ?? in /lib/libglib-2.0.so.0[0x156cefb]
[8] g_main_context_dispatch in /lib/libglib-2.0.so.0[0x15285e5]
[9] ?? in /lib/libglib-2.0.so.0[0x152c2d8]
[10] g_main_loop_run in /lib/libglib-2.0.so.0[0x152c817]
[11] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x124f3c9]
[12] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x637c78]
[13] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x6cae3e]
[14] wxAppBase::OnRun() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x6caa31]
[15] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x2b27aa]
[16] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.8.so.0[0x2b2987]
[17] ?? in amule[0x815a5db]
[18] __libc_start_main in /lib/tls/i686/cmov/libc.so.6[0xfd4bd6]
[19] ?? in amule[0x8083a31]


--------------------------------------------------------------------------------

Is there anybode who also has this problem and knows how to fix it?
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
Re: aMule crashes after a while - I don't know why
« Reply #1 on: August 05, 2010, 09:50:56 PM »

Can you try the SVN version? We fixed several crash bugs since 2.2.6.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon