aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: amule 2.2.6 crash on Ubuntu 10.04 GLib-CRITICAL g_source_remove  (Read 1514 times)

Tay

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2

Hi all! My first post here. I have an annoying problem. Amule is always crashing in 3-5 minutes after starting. It sucks 90% of RAM, it stops working and it hungs without even closing its window. here is the error:

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.2.6 using wxGTK2 v2.8.10
Running on: Linux 2.6.32-30-generic-pae i686


(amule:2347): GLib-CRITICAL **: g_source_remove: assertion `tag > 0' failed


Any help, please? Thanks a lot.
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
Re: amule 2.2.6 crash on Ubuntu 10.04 GLib-CRITICAL g_source_remove
« Reply #1 on: June 04, 2011, 12:42:28 PM »

You have to use wxWidgets 2.8.12
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Tay

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: amule 2.2.6 crash on Ubuntu 10.04 GLib-CRITICAL g_source_remove
« Reply #2 on: June 04, 2011, 08:05:38 PM »

Thank you very much!! I updated as you indicated and now Amule works like a charm!!!!! ;D ;D

POWER TO THE COMMUNITY  :)
Logged