aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: error al actualizar amule  (Read 2789 times)

muleta

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 142
error al actualizar amule
« on: September 12, 2011, 12:50:33 PM »

Ya podemos actualizar amule 2.2.6 a la versión 2.3 desde Synaptic.

Lo he intentado, varias veces, pero me sale este error cuando intento iniciarlo:

Quote
amule: error while loading shared libraries: libbfd-2.20.so: cannot open shared object file: No such file or directory

La librería está instalada pero no la ve. En algunos casos se puede resolver creando un enlace simbólico con:

Quote
sudo ln -s /usr/lib/libbfd-2.20.1-system.20100303.so /usr/lib/libbfd-2.20.so

He desinstalado totalmente el programa y lo he vuelto a instalar, sin éxito. ¿Le ha ocurrido a alguien más?. ¿Cḿo lo habéis resuelto?.
Logged

btkaos

  • Global Moderator
  • Sr. Member
  • *****
  • Karma: 110
  • Offline Offline
  • Posts: 486
  • Kaos is infinite!
Re: error al actualizar amule
« Reply #1 on: September 12, 2011, 04:11:54 PM »

Ya podemos actualizar amule 2.2.6 a la versión 2.3 desde Synaptic.
No lo hagas, es mejor compilar. Además por lo que veo el amule que estás intentando instalar está completamente reventado. Intenta quitar las fuentes e instalar el viejo.

Quote
Quote
sudo ln -s /usr/lib/libbfd-2.20.1-system.20100303.so /usr/lib/libbfd-2.20.so
No hagas esto, te vas a cargar tu instalación.
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5823
Re: error al actualizar amule
« Reply #2 on: September 12, 2011, 07:10:17 PM »

Instalate el paquete binutils-dev

En principio, es fallo de Mint, por linkar dinamicamente a libbfd en un paquete incluido en la distribucion. Pero dime si te funciona instalando binutils-dev primero.
Logged

muleta

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 142
Re: error al actualizar amule
« Reply #3 on: September 12, 2011, 07:19:34 PM »

Ya había instalado binutils, antes de desinstalar el programa y no funcionó.
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5823
Re: error al actualizar amule
« Reply #4 on: September 12, 2011, 07:31:29 PM »

Binutils-dev
Logged

muleta

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 142
Re: error al actualizar amule
« Reply #5 on: September 12, 2011, 07:33:27 PM »

Sí, sí, era para abreviar. Además, compruebo en terminal que tengo la versión más reciente.
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5823
Re: error al actualizar amule
« Reply #6 on: September 13, 2011, 04:03:40 AM »

Que version exacta tienes de Mint?
Logged

muleta

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 142
Re: error al actualizar amule
« Reply #7 on: September 13, 2011, 09:31:39 AM »

Que version exacta tienes de Mint?

Me refería a que tengo instalada la última versión de binutils-dev. De Mint tengo la 11.
Logged

Kry

  • Ex-developer
  • Retired admin
  • Hero Member
  • *****
  • Karma: -665
  • Offline Offline
  • Posts: 5823
Re: error al actualizar amule
« Reply #8 on: September 13, 2011, 01:52:36 PM »

Si, 11, pero que es? 32 bits? 64bits? La estandard con gnome o la que viene con LXDE?

Cuando te preguntemos algo, intenta responder con el mayor detalle posible. No te preguntaba sobre la version de binutils-dev, pero si lo hiciera, necestiraria la version de binutils-dev que tienes, no que me digas "la ultima".
Logged

muleta

  • Full Member
  • ***
  • Karma: 1
  • Offline Offline
  • Posts: 142
Re: error al actualizar amule
« Reply #9 on: September 13, 2011, 02:28:50 PM »

Si, 11, pero que es? 32 bits? 64bits? La estandard con gnome o la que viene con LXDE?

Cuando te preguntemos algo, intenta responder con el mayor detalle posible. No te preguntaba sobre la version de binutils-dev, pero si lo hiciera, necestiraria la version de binutils-dev que tienes, no que me digas "la ultima".

Vaya... lamento haber obviado detalles tan importantes, perdona mi ignorancia. Y, si me preguntaras por la versión de binutils-dev, confieso que no sabría cómo averiguarlo. Me limité a transcribir lo que me indicó el terminal (que ya tenía instalada la versión más reciente). Quizás los informáticos sabéis cómo urgar en las entrañas de los ordenadores y conseguir todos los datos que os hacen falta, pero yo sólo soy médico.

Es la versión 11 "Katya" de 64 bits con gnome. Mi equipo no soportaba LXDE. Gracias por interesarte por mi problema.

Te informo de que, efectivamente, parece que el problema es LinuxMint porqué he hecho la actualización de amule en otro ordenador con Debian y, aunque me ha dado el problema de la librería invisible, al crearle el puente, se inicia perfectamente.
Logged