aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: error compiling the last version  (Read 2761 times)

abb80

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
error compiling the last version
« on: November 18, 2011, 04:17:46 AM »

hello,

i'm trying to compile the last version, i have the last version of gettext but when i execute ./configure i recive this message

http://pastebin.com/rd7TVKt6

i have this version of gettext: gettext (GNU gettext-runtime) 0.18.1

someone can help me?
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2674
Re: error compiling the last version
« Reply #1 on: November 18, 2011, 02:34:15 PM »

You need 'autopoint' which probably is in the 'gettext-tools' package.
Logged
concordia cum veritate

abb80

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: error compiling the last version
« Reply #2 on: November 18, 2011, 06:24:55 PM »

yes, the autopoint package, now i have an error when is linking amule:

http://pastebin.com/QxPbb5rb

i have the port of wxwidgets installed, could be this the  mistake?
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
Re: error compiling the last version
« Reply #3 on: November 18, 2011, 08:16:47 PM »

What do you mean with "port of wxwidgets"?
What is your distro?
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

abb80

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 11
Re: error compiling the last version
« Reply #4 on: November 19, 2011, 12:35:33 AM »

i have ubuntu 11.10, i compiled this package http://sourceforge.net/projects/wxwindows/files/2.8.12/wxGTK-2.8.12.tar.gz/download i tried to compile wxWidgets-2.8.12.tar.gz but i could not
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2674
Re: error compiling the last version
« Reply #5 on: November 19, 2011, 08:44:44 AM »

i have ubuntu 11.10, i compiled this package http://sourceforge.net/projects/wxwindows/files/2.8.12/wxGTK-2.8.12.tar.gz/download i tried to compile wxWidgets-2.8.12.tar.gz but i could not
Now you did compile it or just tried to compile it?
Logged
concordia cum veritate

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Axl_Mas

  • Jr. Member
  • **
  • Karma: 1
  • Offline Offline
  • Posts: 72
Re: error compiling the last version
« Reply #7 on: December 03, 2011, 10:35:30 AM »

[
Code: [Select]
   (cd /home/axl/amule/wx/lib/; rm -f libwx_gtk2u_richtext-2.8.so libwx_gtk2u_richtext-2.8.so.0; ln -s libwx_gtk2u_richtext-2.8.so.0.8.0 libwx_gtk2u_richtext-2.8.so.0; ln -s libwx_gtk2u_richtext-2.8.so.0 libwx_gtk2u_richtext-2.8.so)
(if test -d utils/wxrc ; then cd utils/wxrc && make all ; fi)
make[1]: Entering directory `/home/axl/amule/wx/utils/wxrc'
make[1]: *** No rule to make target `all'.  Stop.
make[1]: Leaving directory `/home/axl/amule/wx/utils/wxrc'
make: *** [wxrc] Error 2 

I follow the guide but when i do "make" i have this error :(
Ubuntu 11.10 64 bit.
With wx 2.9 i'am able to do make, to compile amule, but when i try to start the program i have an error.
Please help me i want to compile  the new amule 2.3.1!!!
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
Re: error compiling the last version
« Reply #8 on: December 03, 2011, 11:30:41 AM »

You are having problems compiling wx? How did you configure it, and what was its output?
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

Axl_Mas

  • Jr. Member
  • **
  • Karma: 1
  • Offline Offline
  • Posts: 72
Re: error compiling the last version
« Reply #9 on: December 06, 2011, 03:21:44 PM »

Now it works.
Configure without  --without-subdirs and make install.
If i follow the guide am error, but now amule works very well!
Logged