aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: wx DEBUG detection fails with wx 2.9  (Read 1528 times)

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
wx DEBUG detection fails with wx 2.9
« on: January 01, 2012, 01:33:53 PM »

Code: [Select]
  $ ../wxWidgets-2.9.3/configure --prefix=/home/martin/amule/wx29/inst --without-libtiff --without-subdirs --with-GTK --enable-debug --disable-optimize

../trunkAsio/configure --prefix=/home/martin/amule/bin --enable-amule-daemon --enable-geoip --disable-upnp --with-wxdir=/home/martin/amule/wx29/bdeb --with-denoise-level=3 --enable-debug

checking for wx-config... /home/martin/amule/wx29/bdeb/wx-config
checking for wxWidgets version >= 2.8.12 (--unicode=yes)... yes (version 2.9.3)
checking if wxWidgets was built in DEBUG mode... no
checking if wxWidgets was built in STATIC mode... no
checking which wxWidgets toolkit was selected... gtk2

DEBUG mode... no? Does this have some influence or is it just a glitch?
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2675
Re: wx DEBUG detection fails with wx 2.9
« Reply #1 on: January 01, 2012, 02:29:37 PM »

It is just a glitch. The final report will wrongly say that you're using a release build, but it doesn't influence compilation in any way.

I guess m4/wxwin.m4 should be updated...
Logged
concordia cum veritate