aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: [1] 2

Author Topic: install amule ok, but update how?  (Read 4373 times)

darkmesaia

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
install amule ok, but update how?
« on: March 30, 2012, 11:16:45 AM »

Hi,

We have made install amule on ubuntu server and everything works ok just fine

but see that it works the old version 2.2.6

I think that there is new properly;

Or this is for ubuntu latest

Otherwise how can we upgrade the software


Thanks in advance and i hope some update from you soon :)
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3830
  • Engines screaming
Re: install amule ok, but update how?
« Reply #1 on: March 30, 2012, 12:16:50 PM »

You can get Ubuntu packages here.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

darkmesaia

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
Re: install amule ok, but update how?
« Reply #2 on: March 30, 2012, 01:05:15 PM »

Yes we have seen this topic, but what to do exactly

can you give us some further information

for example what must we do with this

deb http://www.vollstreckernet.de/ubuntu/ oneiric amule-stable wx

thank for any help
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 164
  • Offline Offline
  • Posts: 2714
Re: install amule ok, but update how?
« Reply #3 on: March 30, 2012, 06:19:05 PM »

add that line to /etc/apt/sources.list
then run "apt-get update" and "apt-get upgrade" (without the quotes)
Logged
concordia cum veritate

darkmesaia

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
Re: install amule ok, but update how?
« Reply #4 on: March 31, 2012, 02:14:43 PM »

hi,

followed exactly the steps you said but still we see that we run in the version 2.2.6

what can go wrong

however thanks for your time
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 164
  • Offline Offline
  • Posts: 2714
Re: install amule ok, but update how?
« Reply #5 on: March 31, 2012, 08:55:03 PM »

For any more help we'd need to know exactly how the old version was installed, what was the output of the above apt-get commands, and maybe also the output of "dpkg -l 'amule*'".
Logged
concordia cum veritate

darkmesaia

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
Re: install amule ok, but update how?
« Reply #6 on: March 31, 2012, 10:48:21 PM »

Basically we have made install via the "synaptic packpage manager"

then just run and install the application and it worked properly ... basically working fine we have not problem with the function

just want to do the upgrade because they run on old version


Thanks in advance
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 164
  • Offline Offline
  • Posts: 2714
Re: install amule ok, but update how?
« Reply #7 on: April 01, 2012, 08:23:31 AM »

Then run the commands below and post their output here.
Code: [Select]
dpkg -l 'amule*'
apt-cache showpkg amule
apt-get update
apt-get upgrade
Logged
concordia cum veritate

darkmesaia

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
Re: install amule ok, but update how?
« Reply #8 on: April 01, 2012, 11:29:44 AM »

Hi,

unfortunately we have performed and what you said but still nothing no change

the results are here


Quote
root 01:15 PM ~ $ dpkg -l 'amule*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version        Description
+++-==============-==============-============================================
ii  amule          2.2.6+debian0- client for the eD2k and Kad networks, like e
ii  amule-common   2.2.6+debian0- common files for the rest of aMule packages
un  amule-daemon   <none>         (no description available)
un  amule-gnome-su <none>         (no description available)
ii  amule-utils    2.2.6+debian0- utilities for aMule (command-line version)
ii  amule-utils-gu 2.2.6+debian0- graphic utilities for aMule
root 01:16 PM ~ $ apt-cache showpkg amule
Package: amule
Versions:
2.2.6+debian0-7 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_universe_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_universe_binary-amd64_Packages
                  MD5: 5c464e6adf41c7373294617a696146d0


Reverse Depends:
  brdesktop-common,amule
  amule-utils,amule 2.1.2-1
  amule-gnome-support,amule
  amule-adunanza,amule
Dependencies:
2.2.6+debian0-7 - amule-common (5 2.2.6+debian0-7) libc6 (2 2.10) libcrypto++8 (0 (null)) libgcc1 (2 1:4.1.1) libgeoip1 (2 1.4.6.dfsg) libstdc++6 (2 4.4.0) libupnp3 (0 (null)) libwxbase2.8-0 (2 2.8.10.1) libwxgtk2.8-0 (2 2.8.10.1) zlib1g (2 1:1.1.4) amule-utils-gui (0 (null)) amule-utils (0 (null)) unzip (0 (null)) amule-common (3 2.2.0~svn20080525-1)
Provides:
2.2.6+debian0-7 -
Reverse Provides:
root 01:16 PM ~ $ apt-get update
Hit http://archive.ubuntu.com lucid Release.gpg
Hit http://archive.ubuntu.com lucid-updates Release.gpg                       
Hit http://archive.ubuntu.com lucid-security Release.gpg                       
Hit http://archive.ubuntu.com lucid Release   
Hit http://archive.ubuntu.com lucid-updates Release                 
Get:1 http://www.vollstreckernet.de oneiric Release.gpg [198B]       
Hit http://archive.ubuntu.com lucid-security Release                 
Get:2 http://www.vollstreckernet.de oneiric Release [13.8kB]
Hit http://archive.ubuntu.com lucid/main Packages       
Ign http://www.vollstreckernet.de oneiric Release
Hit http://www.vollstreckernet.de oneiric/amule-stable Packages
Hit http://archive.ubuntu.com lucid/restricted Packages
Hit http://archive.ubuntu.com lucid/universe Packages
Hit http://archive.ubuntu.com lucid/multiverse Packages
Hit http://archive.ubuntu.com lucid-updates/main Packages
Hit http://archive.ubuntu.com lucid-updates/restricted Packages
Hit http://www.vollstreckernet.de oneiric/wx Packages
Hit http://archive.ubuntu.com lucid-updates/universe Packages
Hit http://archive.ubuntu.com lucid-updates/multiverse Packages
Hit http://archive.ubuntu.com lucid-security/main Packages
Hit http://archive.ubuntu.com lucid-security/restricted Packages
Hit http://archive.ubuntu.com lucid-security/universe Packages
Hit http://archive.ubuntu.com lucid-security/multiverse Packages
Fetched 199B in 0s (822B/s)
Reading package lists... Done
W: GPG error: http://www.vollstreckernet.de oneiric Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY D63913EF50D0AE60
root 01:16 PM ~ $ apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  libwxgtk2.8-0 python-software-properties
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 164
  • Offline Offline
  • Posts: 2714
Re: install amule ok, but update how?
« Reply #9 on: April 01, 2012, 02:57:35 PM »

I see. You don't have the necessary keys to verify the packages, so they're ignored. You can get the keys with the following commands:
Code: [Select]
gpg --keyserver keyserver.ubuntu.com --recv D63913EF50D0AE60
gpg --export --armor D63913EF50D0AE60 | apt-key add -

After that, upgrading should finally succeed:
Code: [Select]
apt-get update
apt-get upgrade
Logged
concordia cum veritate

darkmesaia

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
Re: install amule ok, but update how?
« Reply #10 on: April 01, 2012, 03:46:59 PM »

I do not know really what can happen, we following faithfully that you say, but nevertheless still to run in version 2.2.6 :( :(

Actually I apologize for the inconvenience, but I do not know what may happen


those is the latest results

Quote
root 05:35 PM ~ $ gpg --keyserver keyserver.ubuntu.com --recv D63913EF50D0AE60
gpg: directory `/root/.gnupg' created
gpg: new configuration file `/root/.gnupg/gpg.conf' created
gpg: WARNING: options in `/root/.gnupg/gpg.conf' are not yet active during this run
gpg: keyring `/root/.gnupg/secring.gpg' created
gpg: keyring `/root/.gnupg/pubring.gpg' created
gpg: requesting key 50D0AE60 from hkp server keyserver.ubuntu.com
gpg: /root/.gnupg/trustdb.gpg: trustdb created
gpg: key 50D0AE60: public key "Werner Mahr (Der Vollstrecker) <werner@vollstreckernet.de>" imported
gpg: Total number processed: 1
gpg:               imported: 1


root 05:37 PM ~ $ gpg --export --armor D63913EF50D0AE60 | apt-key add -
OK


root 05:38 PM ~ $ apt-get update
Hit http://archive.ubuntu.com lucid Release.gpg
Hit http://archive.ubuntu.com lucid-updates Release.gpg
Hit http://archive.ubuntu.com lucid-security Release.gpg
Hit http://archive.ubuntu.com lucid Release   
Hit http://archive.ubuntu.com lucid-updates Release                 
Hit http://archive.ubuntu.com lucid-security Release                 
Get:1 http://www.vollstreckernet.de oneiric Release.gpg [198B]       
Hit http://archive.ubuntu.com lucid/main Packages       
Hit http://archive.ubuntu.com lucid/restricted Packages
Hit http://archive.ubuntu.com lucid/universe Packages
Hit http://archive.ubuntu.com lucid/multiverse Packages
Get:2 http://www.vollstreckernet.de oneiric Release [13.8kB]
Hit http://archive.ubuntu.com lucid-updates/main Packages
Hit http://archive.ubuntu.com lucid-updates/restricted Packages
Hit http://archive.ubuntu.com lucid-updates/universe Packages
Hit http://archive.ubuntu.com lucid-updates/multiverse Packages
Hit http://archive.ubuntu.com lucid-security/main Packages
Hit http://archive.ubuntu.com lucid-security/restricted Packages
Hit http://archive.ubuntu.com lucid-security/universe Packages
Hit http://archive.ubuntu.com lucid-security/multiverse Packages
Hit http://www.vollstreckernet.de oneiric/amule-stable Packages
Hit http://www.vollstreckernet.de oneiric/wx Packages
Fetched 199B in 0s (236B/s)
Reading package lists... Done
root 05:38 PM ~ $ apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  libwxgtk2.8-0 python-software-properties
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
root 05:39 PM ~ $


Thanks for your time guys
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 164
  • Offline Offline
  • Posts: 2714
Re: install amule ok, but update how?
« Reply #11 on: April 02, 2012, 06:42:14 PM »

Quote
Package: amule
Versions:
2.2.6+debian0-7 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_universe_binary-amd64_Packages) (/var/lib/dpkg/status)
I was blind... 64-bit packages aren't yet available, as far as I know. Vollstrecker could tell more on the state of 64-bit packages, if he's around.

Anyway, your system is now set up to receive updates whenever they're available. If the 64-bit packages go online sometime, it will now be as easy as to type "apt-get update" and "apt-get upgrade" to get the new version.
Logged
concordia cum veritate

darkmesaia

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
Re: install amule ok, but update how?
« Reply #12 on: April 02, 2012, 07:55:51 PM »

ie to keep the version that we have now until to there is support for 64bit!!!

ok we understand

We can somewhere to informed about this

ie that is something that will happen in the future will not happen! at least to we know


Thanks for help guys and sorry for the inconvenience
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 164
  • Offline Offline
  • Posts: 2714
Re: install amule ok, but update how?
« Reply #13 on: April 03, 2012, 08:37:00 PM »

Another way is to build aMule yourself, then you don't have to wait...
Logged
concordia cum veritate

darkmesaia

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 15
Re: install amule ok, but update how?
« Reply #14 on: April 03, 2012, 09:50:28 PM »

xmmmmm and how to do that, we should have some knowledge about this

if there is any tutorial who can to follow certainly we can look

but otherwise should necessarily expect something official from here

However we want to know if there is some problem that running in this version


Thanks for the help guys
Logged
Pages: [1] 2