aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: ubuntu 12.04 64bits, aMule 2.3.1-1 and crashes  (Read 1793 times)

Psykotik

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
    • http://www.ikiru.ch
ubuntu 12.04 64bits, aMule 2.3.1-1 and crashes
« on: May 09, 2012, 11:22:44 PM »

Since I updated to lastest and long term support Ubuntu (12.04), I'm frequently experimenting unexpected crashes. I don't know how much it could be related to my move to 64bits version, as I always used the rock solid 32 bits one.

I'm using official Ubuntu packages 2.3.1-1.

The code from .xsession-errors file:

Code: [Select]
(amule:3445): GLib-WARNING **: /build/buildd/glib2.0-2.32.1/./glib/giounix.c:411Error while getting flags for FD: Mauvais descripteur de fichier (9)


--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/index.php?board=67.0
If possible, please try to generate a real backtrace of this crash:
    http://wiki.amule.org/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.3.1 compiled with wxGTK2 v2.8.12
Running on: Linux 3.2.0-24-generic x86_64

[2] ?? in /usr/bin/amule[0x454cdf]
[3] wxFatalSignalHandler in /usr/lib/x86_64-linux-gnu/libwx_baseu-2.8.so.0[0x7fd3b1a51fcc]
[4] ?? in /lib/x86_64-linux-gnu/libpthread.so.0[0x7fd3b0d25cb0]
[5] ?? in /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-2.8.so.0[0x7fd3b20c3a96]
[6] ?? in /usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0[0x7fd3afe89c8f]
[7] g_main_context_dispatch in /lib/x86_64-linux-gnu/libglib-2.0.so.0[0x7fd3af748c9a]
[8] ?? in /lib/x86_64-linux-gnu/libglib-2.0.so.0[0x7fd3af749060]
[9] g_main_loop_run in /lib/x86_64-linux-gnu/libglib-2.0.so.0[0x7fd3af74945a]
[10] gtk_main in /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0[0x7fd3b024b2f7]
[11] wxEventLoop::Run() in /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-2.8.so.0[0x7fd3b20c27b8]
[12] wxAppBase::MainLoop() in /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-2.8.so.0[0x7fd3b213995b]
[13] wxEntry(int&, wchar_t**) in /usr/lib/x86_64-linux-gnu/libwx_baseu-2.8.so.0[0x7fd3b19ffd4b]
[14] ?? in /usr/bin/amule[0x447612]
[15] __libc_start_main in /lib/x86_64-linux-gnu/libc.so.6[0x7fd3b097a76d]
[16] ?? in /usr/bin/amule[0x44c485]


--------------------------------------------------------------------------------

Any idea?
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3763
  • Engines screaming
Re: ubuntu 12.04 64bits, aMule 2.3.1-1 and crashes
« Reply #1 on: May 10, 2012, 10:29:26 PM »

I'm afraid no. The crashing code is not even inside aMule.
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon