aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Re: ubuntu 12.04 64bits, aMule 2.3.1-1 and crashes  (Read 2040 times)

guest

  • Jr. Member
  • **
  • Karma: 1
  • Offline Offline
  • Posts: 54
Re: ubuntu 12.04 64bits, aMule 2.3.1-1 and crashes
« on: May 12, 2012, 12:20:49 PM »

System  is the same - trying to run amule 2.3.1-1 and nothing happens if I try to run using the icon. Opening a console and running from console I get the following error.
amule: error while loading shared libraries: libbfd-2.21.53-system.20110810.so: cannot open shared object file: No such file or directory

any starting points ? My binutils installed is binutils (2.22-6ubuntu1).
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
Re: ubuntu 12.04 64bits, aMule 2.3.1-1 and crashes
« Reply #1 on: May 12, 2012, 03:13:18 PM »

That's totally unrelated to the thread where you posted it.
Did you compile aMule yourself or install it from your distro?
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

guest

  • Jr. Member
  • **
  • Karma: 1
  • Offline Offline
  • Posts: 54
Re: ubuntu 12.04 64bits, aMule 2.3.1-1 and crashes
« Reply #2 on: May 12, 2012, 11:58:32 PM »

sorry Stu. Ran it from the Distro. Distro is Ubuntu 12.04 lts on AMD x64. All bits are standard upgrade from 11 for 12.04. I haven't mucked with it as yet.
Logged

Stu Redman

  • Administrator
  • Hero Member
  • *****
  • Karma: 214
  • Offline Offline
  • Posts: 3764
  • Engines screaming
Re: ubuntu 12.04 64bits, aMule 2.3.1-1 and crashes
« Reply #3 on: May 13, 2012, 12:13:48 AM »

Hm. Isn't libbfd-2.21.53-system.20110810.so a strange name for a lib supplied with a distro?
Anyway, you installed something from a package and it isn't working. Some required lib is failing or missing.
You can
- spend 117 back and forth posts analyzing that issue with someone who loves to analyze distro problems (like Vollstrecker)
- ask the distro guys (won't help, because it's working in general, just not for you)
- hope for someone posting here "easy, just ..."
- reinstall Ubuntu
- build aMule from source
I suggest the latter (unless you don't mind reinstalling your OS). 12.04 even ships the right wxWidgets version, so it's piece of cake. See http://wiki.amule.org/index.php/HowTo_Compile_In_Ubuntu
Logged
The image of mother goddess, lying dormant in the eyes of the dead, the sheaf of the corn is broken, end the harvest, throw the dead on the pyre -- Iron Maiden, Isle of Avalon

guest

  • Jr. Member
  • **
  • Karma: 1
  • Offline Offline
  • Posts: 54
Re: ubuntu 12.04 64bits, aMule 2.3.1-1 and crashes
« Reply #4 on: May 13, 2012, 11:18:32 AM »

Compiled from scratch and it does work. Yep it's a funny sort of error and I've got no idea where it crept in.
Logged