aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMule crashes constantly  (Read 5487 times)

Exaro

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
aMule crashes constantly
« on: September 29, 2015, 01:40:18 PM »

I'm having a problem with aMule. I can open it and connect to a network, but after a few minutes (usually about 10-15) it will force close. Having difficulty downloading files since I can't keep it open long enough to finish.

I'm using
Desktop: KDE 5
Distro: Netrunner 16 / Ubuntu Vivid


----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule SVN compiled with wxGTK2 v2.8.12 (Snapshot: rev. 10835)
Running on: Linux 3.19.0-28-generic i686

[2] wxFatalSignalHandler in /usr/lib/i386-linux-gnu/libwx_baseu-2.8.so.0[0xb6df0406]                                                                                                                                           
[3] ?? in [0xb7718bbc]                                                                                                                                                                                                         
[4] ?? in /lib/i386-linux-gnu/libglib-2.0.so.0[0xb6282b05]                                                                                                                                                                     
[5] ?? in /lib/i386-linux-gnu/libglib-2.0.so.0[0xb6282f68]                                                                                                                                                                     
[6] g_source_remove in /lib/i386-linux-gnu/libglib-2.0.so.0[0xb62847e3]                                                                                                                                                       
[7] gdk_input_remove in /usr/lib/i386-linux-gnu/libgdk-x11-2.0.so.0[0xb6409cb8]                                                                                                                                               
[8] GSocketGUIFunctionsTableConcrete::Install_Callback(GSocket*, GSocketEvent) in /usr/lib/i386-linux-gnu/libwx_gtk2u_core-2.8.so.0[0xb6fc6227]                                                                               
[9] GSocket::Enable(GSocketEvent) in /usr/lib/i386-linux-gnu/libwx_baseu_net-2.8.so.0[0xb6e86108]                                                                                                                             
[10] GSocket::Write(char const*, int) in /usr/lib/i386-linux-gnu/libwx_baseu_net-2.8.so.0[0xb6e87590]                                                                                                                         
[11] wxSocketBase::_Write(void const*, unsigned int) in /usr/lib/i386-linux-gnu/libwx_baseu_net-2.8.so.0[0xb6e826f8]                                                                                                           
[12] wxSocketBase::Write(void const*, unsigned int) in /usr/lib/i386-linux-gnu/libwx_baseu_net-2.8.so.0[0xb6e82748]                                                                                                           
[13] ?? in amule[0x81ea2ce]                                                                                                                                                                                                   
[14] ?? in amule[0x80df472]                                                                                                                                                                                                   
[15] ?? in amule[0x80bd4fe]                                                                                                                                                                                                   
[16] ?? in amule[0x812874f]                                                                                                                                                                                                   
[17] wxThreadInternal::PthreadStart(wxThread*) in /usr/lib/i386-linux-gnu/libwx_baseu-2.8.so.0[0xb6debbde]                                                                                                                     
[18] wxPthreadStart in /usr/lib/i386-linux-gnu/libwx_baseu-2.8.so.0[0xb6debc18]                                                                                                                                                 
[19] ?? in /lib/i386-linux-gnu/libpthread.so.0[0xb6b6c1aa]
[20] clone in /lib/i386-linux-gnu/libc.so.6[0xb6a94fde]

--------------------------------------------------------------------------------
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2675
Re: aMule crashes constantly
« Reply #1 on: October 01, 2015, 10:19:46 PM »

Ubuntu version or self-compiled?
Logged
concordia cum veritate

Exaro

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: aMule crashes constantly
« Reply #2 on: October 02, 2015, 03:54:47 PM »

Ubuntu version or self-compiled?

Ubuntu version.
I'm using Netrunner 16, but it uses Ubuntu sources.

I just checked and its in the Ubuntu/universe repo. Version 2.3.1+git1a369e47-3
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2675
Re: aMule crashes constantly
« Reply #3 on: October 03, 2015, 11:04:15 AM »

Well, unfortunately all I can tell is that it's a known bug, but it's cause is yet unknown. It doesn't affect everyone, for example I myself cannot reliably reproduce it. That makes tracking it down really hard.
Logged
concordia cum veritate

LAZA

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 27
Re: aMule crashes constantly
« Reply #4 on: January 18, 2016, 11:42:45 AM »

Seems to be the same error with complete different setting:

OS: Manjaro 15.12 64 Bit
Kernel: 4.4.0
DE: Xfce

Code: [Select]
----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule SVN compiled with wxGTK2 v2.8.12 (Snapshot: rev. 10871)
Running on: Linux 4.4.0-1-MANJARO x86_64

[2] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0x7f418a550b22]
[3] ?? in /usr/lib/libpthread.so.0[0x7f418c17cd60]
[4] ?? in /usr/lib/libglib-2.0.so.0[0x7f41883b6e4b]
[5] ?? in /usr/lib/libglib-2.0.so.0[0x7f41883b707e]
[6] g_main_context_prepare in /usr/lib/libglib-2.0.so.0[0x7f41883b94eb]
[7] ?? in /usr/lib/libglib-2.0.so.0[0x7f41883b9eeb]
[8] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0x7f41883ba342]
[9] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x7f4188edb787]
[10] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7f418abd78da]
[11] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7f418ac5bdba]
[12] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x7f418a4f628a]
[13] ?? in amule[0x4425a2]
[14] __libc_start_main in /usr/lib/libc.so.6[0x7f4189614610]
[15] ?? in amule[0x450329]

Happens for me since the upgrade to Kernel 4.4.0 - do not mentioned this with Kernel 4.4.0-RC7 and RC8  :o

Complete post in the Manjaro Forum: https://forum.manjaro.org/index.php?topic=30249.0

How can i create a valid Backtrace?
Thanks in advance
LAZA


« Last Edit: January 18, 2016, 12:44:26 PM by LAZA »
Logged

LAZA

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 27
Re: aMule crashes constantly
« Reply #5 on: January 19, 2016, 03:55:51 PM »

Could this be a problem with the Kernel???
I got an update yesterday and no more crashes since reboot...

Update list:
https://manjaro.github.io/Update-2016-01-18_%28stable%29/

Code: [Select]
$ uname -a
Linux T3500 4.4.0-2-MANJARO #1 SMP PREEMPT Thu Jan 14 22:37:56 UTC 2016 x86_64 GNU/Linux
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2675
Re: aMule crashes constantly
« Reply #6 on: January 19, 2016, 08:21:48 PM »

Well, it could be related to that, although I haven't seen any related package being updated.
Logged
concordia cum veritate

LAZA

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 27
Re: aMule crashes constantly
« Reply #7 on: January 27, 2016, 11:12:53 AM »

Well, it could be related to that, although I haven't seen any related package being updated.

You're right - nevertheless is aMule working constant since upgrade to this kernel...
Maybe a coincidence but i don't buy this cause
- with 4.3 kernel no problems
- with 4.4 RC7 and RC8 no problems
- with 4.4.0-2 no problems

The only one i got permanent crashes was 4.4.0-1

Thanks for noticing.
Logged

LAZA

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 27
Re: aMule crashes constantly
« Reply #8 on: February 10, 2016, 07:09:06 PM »

And again:

Changing the Kernel is a bad habit - aMule punishes with crashes.   :o

Code: [Select]
----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule SVN compiled with wxGTK2 v2.8.12 (Snapshot: rev. 10871)
Running on: Linux 4.5.0-1-MANJARO x86_64

[2] wxFatalSignalHandler in /usr/lib/libwx_baseu-2.8.so.0[0x7fc3d93e7b22]
[3] ?? in /usr/lib/libpthread.so.0[0x7fc3db013d60]
[4] ?? in /usr/lib/libglib-2.0.so.0[0x7fc3d724de4b]
[5] ?? in /usr/lib/libglib-2.0.so.0[0x7fc3d724e07e]
[6] g_main_context_prepare in /usr/lib/libglib-2.0.so.0[0x7fc3d72504eb]
[7] ?? in /usr/lib/libglib-2.0.so.0[0x7fc3d7250eeb]
[8] g_main_loop_run in /usr/lib/libglib-2.0.so.0[0x7fc3d7251342]
[9] gtk_main in /usr/lib/libgtk-x11-2.0.so.0[0x7fc3d7d72787]
[10] wxEventLoop::Run() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7fc3d9a6e8da]
[11] wxAppBase::MainLoop() in /usr/lib/libwx_gtk2u_core-2.8.so.0[0x7fc3d9af2dba]
[12] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0x7fc3d938d28a]
[13] ?? in amule[0x4425a2]
[14] __libc_start_main in /usr/lib/libc.so.6[0x7fc3d84ab610]
[15] ?? in amule[0x450329]

--------------------------------------------------------------------------------
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2675
Re: aMule crashes constantly
« Reply #9 on: February 11, 2016, 08:09:32 PM »

I guess you're building a whole list of kernels aMule does/doesn't support :)
Logged
concordia cum veritate

langioletto

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: aMule crashes constantly
« Reply #10 on: February 11, 2016, 09:38:12 PM »

Hi, I have compiled aMule on raspberry:

Current version is: aMuleD SVN compiled with wxGTK2 v2.8.12 and Boost 1.60 (Snapshot: rev. 10874)

raspbian-jessie 2016-02-09

When I start this immediately crashes "Kernel 4.1.17+"

Code: [Select]
root@raspberrypi:~# /root/amuled
 2016-02-11 21:27:06: Initialising aMuleD SVN compiled with wxGTK2 v2.8.12 and Boost 1.60 (Snapshot: rev. 10874)
 2016-02-11 21:27:06: Checking if there is an instance already running...
 2016-02-11 21:27:06: No other instances are running.
!2016-02-11 21:27:06: ERROR: WARNING Warning! You are running aMule as root.
!2016-02-11 21:27:06: Doing so is not recommended for security reasons,
!2016-02-11 21:27:06: and you are advised to run aMule as an normal
!2016-02-11 21:27:06: user instead.

--------------------------------------------------
Warning! You are running aMule as root.
Doing so is not recommended for security reasons,
and you are advised to run aMule as an normal
user instead.
--------------------------------------------------

 2016-02-11 21:27:06: ListenSocket: Ok.
 2016-02-11 21:27:06: Loading temp files from /root/.aMule/Temp.
 2016-02-11 21:27:06: All PartFiles Loaded.

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/index.php?board=67.0
If possible, please try to generate a real backtrace of this crash:
    http://wiki.amule.org/wiki/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMuleD SVN compiled with wxGTK2 v2.8.12 and Boost 1.60 (Snapshot: rev. 10874)
Running on: Linux 4.1.17+ armv6l

[2] ?? in [0x262c38]
[3] ?? in [0x3068e0]

--------------------------------------------------------------------------------
 2016-02-11 21:27:06: amuled: OnInit - starting timer
Aborted

The same demon on raspberry with raspbian-wheezy 05/05/2015 no problem "Kernel 3.18.6+"

Code: [Select]

root@raspberrypi:~# /root/amuled
 2016-02-11 21:35:56: Initialising aMuleD SVN compiled with wxGTK2 v2.8.12 and Boost 1.60 (Snapshot: rev. 10874)
 2016-02-11 21:35:56: Checking if there is an instance already running...
 2016-02-11 21:35:56: No other instances are running.
!2016-02-11 21:35:56: ERROR: WARNING Warning! You are running aMule as root.
!2016-02-11 21:35:56: Doing so is not recommended for security reasons,
!2016-02-11 21:35:56: and you are advised to run aMule as an normal
!2016-02-11 21:35:56: user instead.

--------------------------------------------------
Warning! You are running aMule as root.
Doing so is not recommended for security reasons,
and you are advised to run aMule as an normal
user instead.
--------------------------------------------------

 2016-02-11 21:35:56: ListenSocket: Ok.
 2016-02-11 21:35:56: Loading temp files from /root/.aMule/Temp.
 2016-02-11 21:35:56: All PartFiles Loaded.
 2016-02-11 21:35:56: amuled: OnInit - starting timer
 2016-02-11 21:35:56: Asio thread 3 started
 2016-02-11 21:35:56: Asio thread 2 started
 2016-02-11 21:35:56: Asio thread 4 started
 2016-02-11 21:35:56: Asio thread 1 started

Do you have any suggestions for me?

Very thanks
« Last Edit: February 11, 2016, 10:28:07 PM by langioletto »
Logged

HKM

  • Jr. Member
  • **
  • Karma: 4
  • Offline Offline
  • Posts: 76
  • You don't know enough to know that you don't know.
Re: aMule crashes constantly
« Reply #11 on: February 12, 2016, 01:34:05 AM »

Did you read the log? It's not crashing as it just closes as desgined since your running under root with full autonomy access, which is not advised as its security risk of permission base structure. When you port installed the aMule package it created user 'amuled' as deafult. So you don't issue command 'amuled' manually as it should be started as service. Now I don't know which platform you use but follow these general steps below and modify it based on your need.

---
1) rm -rf /root/.aMule
This will remove the whole aMule related files created as deafult under root.

2) /sbin/chkconfig --add amuled
3) /sbin/chkconfig amuled on
This will insure amuled is added as service and turned on for boot start.

4) service amuled start
This will properly deploy aMuleD (daemon) under default user; amuled.

5) cd /var/lib/amuled/.aMule/
This will change dir to working aMule dir.

6) wget http://upd.emule-security.org/ipfilter.zip
7) wget http://upd.emule-security.org/nodes.dat
8) wget http://upd.emule-security.org/server.met
These will download current upto date nodes.dat (KAD nodes), server.met (ED2K servers) and ipfilter.dat (blocklist).

9) unzip ipfilter.zip
10) cd ipfilter
11) cp ./ipfilter/guarding.p2p ./ipfilter.dat
This will unzip the compressed folder and rename it and move it to ./aMule

12) chown -R amuled:amuled ipfilter.dat
This will give ownership of ipfilter back to deafult user; amuled.

13) echo -n PASSWORD | md5sum
This will generate md5 hash of given password.

14) vi amule.conf
15) PRESS "I"
This will open default amule.conf file and enable insert mode to modify its content.

16) Nick=[UserName]
17) IPFilterSystem=1
18) SmartIdState=1
19) AcceptExternalConnections=1
20) ECPassword=[md5 hash]
21) Enabled=1
22) Password=[md5 hash]
23) Template=default
24) IsClientCryptLayerRequired=1
25) PRESS [Esc]
26) :wq
These lines are each entries within amule.conf you need to modify and save.

27) amuleweb --write-config --host=localhost --password=PASSWORD --admin-pass=PASSWORD
28) vi remote.conf
29) AdminPassword=[md5 hash]
Verify password matchs from amule.conf Password is exact in remote.conf AdminPassword.

30) init 6
This will reboot your unit.
---

After the system boots up amuled should be running along with amuleweb. You can verify it by doing TOP command. I just wrote this for fool proof step by step so anyone can do it for future reference. If you STILL have any problems after that... [SMH] then post back regarding it ill help you.
Logged

langioletto

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: aMule crashes constantly
« Reply #12 on: February 12, 2016, 09:26:53 AM »

Thank you for your intervention

My right now are just test compilation

My problem is that the demon of compiled kernel "Kernel 4.1.17+" does not work.

The same demon of kernel "Kernel 3.18.6+" works fine

Log "Kernel 4.1.17+"

root@raspberrypi:~# amuled

Code: [Select]
--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/index.php?board=67.0
If possible, please try to generate a real backtrace of this crash:
    http://wiki.amule.org/wiki/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMuleD SVN compiled with wxGTK2 v2.8.12 (Snapshot: rev. 10874)
Running on: Linux 4.1.17+ armv6l

[2] ?? in [0x24e918]
[3] ?? in [0x2f23d0]

--------------------------------------------------------------------------------
Logged

HKM

  • Jr. Member
  • **
  • Karma: 4
  • Offline Offline
  • Posts: 76
  • You don't know enough to know that you don't know.
Re: aMule crashes constantly
« Reply #13 on: February 12, 2016, 03:54:24 PM »

I see you updated your post. Now I can't say anything regarding aMule operating under 4.1.17 as I'm using 2.6.32 and 3.16.7 here. But as you can see Topi have stated it may not be supported under that 4.x tree fully. Why don't you compile aMule 2.3.1 (SR) and downgrade the Kernel supported by your LINUX distro under longterm support, which should be 3.x branch. Newer Kernel's are released under mainline/stable but may not be compatible as it seem to be the issue.

Logged