aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: UDP-SocketSocket died, recreating.  (Read 769 times)

gcollin

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 2
UDP-SocketSocket died, recreating.
« on: October 30, 2015, 03:33:18 PM »

OS: Linux Mint 17.2 (64-bit)

aMule Version: 2.3.1

Kernel:
graeme> uname -r
3.13.0-66-generic

Platform: HP Laptop (don't recall actual model number)

CPU: Core i5-3210M @2.50GHz

RAM: 6Gb

Location: London, UK

Hi guys ... OK, I've been happily running aMule for a number of years without any issues until this last weekend. I installed ntpd in order to deal with the transition from BST to GMT, which happened last Saturday night, and to generally keep the system time in check, and save having to periodically run ntpdate manually. This seemed to go fine, and not cause any issues across the board until, after a few hours I started getting the following error messages in abundance:

MuleUDPSocket: Server UDP-SocketSocket died, recreating.
Created Server UDP-Socket at port 4665
MuleUDPSocket: Client UDP-SocketSocket died, recreating.
Created Client UDP-Socket at port 4672

The system has been shutdown numerous times, I've tried disabling ntpd, and even changing the TCP/UDP ports aMule is using, all to no avail.

aMule still does work, although not as well as it used to before the problems started - things seem to happen a lot slower now.

Anyone got any ideas/suggestions as to what the problems may be, where to look for them, or even how to cure them?

If you want any further information, please ask - I'll happily provide if I'm able.

Many thanks.

-Graeme.
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 163
  • Offline Offline
  • Posts: 2688
Re: UDP-SocketSocket died, recreating.
« Reply #1 on: November 02, 2015, 09:48:04 AM »

I don't think the issue has any relation with the recent installment of ntpd. Though I admit I don't have the faintest idea what causes these errors.
Logged
concordia cum veritate

gcollin

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: UDP-SocketSocket died, recreating.
« Reply #2 on: November 07, 2015, 09:35:38 AM »

Ok, so now I have an update, and sort of an answer (although not a solution) ...

Tried uninstalling and reinstalling aMule, all to no avail. I even tried restarting the router.

Now, this weekend, I have the occasion to log onto another network, and Bingo! The problem goes away!

Ergo, it appears that the problem lies with something that's happened at the ISP's end, rather than at mine ... Grrr ...

Cheers, guys.

-G.
Logged