aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: *** Error in `amule': free(): invalid pointer: 0x000000000483bb60 ***  (Read 2632 times)

LAZA

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 27

Manjaro Xfce 64 Bit

aMule SVN 10944

Attached is the complete crash report.

Code: [Select]
*** Error in `amule': free(): invalid pointer: 0x000000000483bb60 ***
======= Backtrace: =========
/usr/lib/libc.so.6(+0x70c4b)[0x7f465e8d6c4b]
/usr/lib/libc.so.6(+0x76fe6)[0x7f465e8dcfe6]
/usr/lib/libc.so.6(+0x777de)[0x7f465e8dd7de]
amule[0x4fa048]
amule[0x6941ba]
amule[0x6941f9]
amule[0x6952fc]
amule[0x6985dd]
amule[0x4f94d4]
amule[0x4f9e02]
amule[0x4e9eb2]
amule[0x48591a]
amule[0x4b9b58]
amule[0x4849f9]
/usr/lib/libwx_baseu-2.8.so.0(_ZN12wxEvtHandler21ProcessEventIfMatchesERK21wxEventTableEntryBasePS_R7wxEvent+0x5b)[0x7f465f7c68bb]
/usr/lib/libwx_baseu-2.8.so.0(_ZN16wxEventHashTable11HandleEventER7wxEventP12wxEvtHandler+0x73)[0x7f465f7c6973]
/usr/lib/libwx_baseu-2.8.so.0(_ZN12wxEvtHandler12ProcessEventER7wxEvent+0xdb)[0x7f465f7c6d1b]
/usr/lib/libwx_baseu-2.8.so.0(_ZN12wxEvtHandler20ProcessPendingEventsEv+0x78)[0x7f465f7c6808]
/usr/lib/libwx_baseu-2.8.so.0(_ZN12wxAppConsole20ProcessPendingEventsEv+0x49)[0x7f465f73c0c9]
/usr/lib/libwx_gtk2u_core-2.8.so.0(_ZN9wxAppBase11ProcessIdleEv+0x2e)[0x7f465fed503e]
/usr/lib/libwx_gtk2u_core-2.8.so.0(+0x1ccb15)[0x7f465fe39b15]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x15a)[0x7f465d62dc8a]
/usr/lib/libglib-2.0.so.0(+0x4a040)[0x7f465d62e040]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0xc2)[0x7f465d62e362]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb7)[0x7f465e14e347]
/usr/lib/libwx_gtk2u_core-2.8.so.0(_ZN11wxEventLoop3RunEv+0x3a)[0x7f465fe508da]
/usr/lib/libwx_gtk2u_core-2.8.so.0(_ZN9wxAppBase8MainLoopEv+0x5a)[0x7f465fed4dba]
/usr/lib/libwx_baseu-2.8.so.0(_Z7wxEntryRiPPw+0x9a)[0x7f465f76f28a]
amule[0x43ec02]
/usr/lib/libc.so.6(__libc_start_main+0xf1)[0x7f465e886291]
amule[0x44c8fa]
======= Memory map: ========
00400000-0087e000 r-xp 00000000 00:12 1075074                            /usr/bin/amule
00a7e000-00a91000 r--p 0047e000 00:12 1075074                            /usr/bin/amule
00a91000-00aeb000 rw-p 00491000 00:12 1075074                            /usr/bin/amule
00aeb000-00b04000 rw-p 00000000 00:00 0
02665000-07cc6000 rw-p 00000000 00:00 0                                  [heap]
[..]
Logged

LAZA

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 27
Re: *** Error in `amule': free(): invalid pointer: 0x000000000483bb60 ***
« Reply #1 on: August 27, 2016, 09:47:42 AM »

At start i get this message since a version update some days(?) ago:

Code: [Select]
Warning: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1009,wx containers,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1010,wx containers,compatible with 2.6).
 2016-08-27 09:46:06: Initialising aMule SVN compiled with wxGTK2 v2.8.12 (Snapshot: rev. 10944)
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2726
Re: *** Error in `amule': free(): invalid pointer: 0x000000000483bb60 ***
« Reply #2 on: September 05, 2016, 02:19:12 PM »

At start i get this message since a version update some days(?) ago:

Code: [Select]
Warning: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1009,wx containers,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1010,wx containers,compatible with 2.6).
 2016-08-27 09:46:06: Initialising aMule SVN compiled with wxGTK2 v2.8.12 (Snapshot: rev. 10944)

Well, that may cause problems like this.
Logged
concordia cum veritate

LAZA

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 27
Re: *** Error in `amule': free(): invalid pointer: 0x000000000483bb60 ***
« Reply #3 on: September 05, 2016, 08:47:36 PM »

Sorry, but i do not see a difference in the message:

The library
used 2.8 (no debug,Unicode,compiler with C++ ABI 1009,wx containers,compatible with 2.6),
and your program
used 2.8 (no debug,Unicode,compiler with C++ ABI 1010,wx containers,compatible with 2.6).
 2016-08-27 09:46:06: Initialising aMule SVN compiled with wxGTK2 v2.8.12 (Snapshot: rev. 10944)

Looks for me as (near) the same versions and flags(?) and things... - just a small bump in the C++ ABI

If not: Please give me a hint what can i do to avoid this problem?

Thanks in advance
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2726
Re: *** Error in `amule': free(): invalid pointer: 0x000000000483bb60 ***
« Reply #4 on: September 06, 2016, 07:55:27 PM »

just a small bump in the C++ ABI

Exactly that.

I suggest recompiling aMule and/or wxWidgets to use the same ABI.
Logged
concordia cum veritate

LAZA

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 27
Re: *** Error in `amule': free(): invalid pointer: 0x000000000483bb60 ***
« Reply #5 on: October 09, 2016, 12:54:05 PM »

Okay, here the good news:

Manjaro / Arch provided a new(er) version of aMule 10958 (17th September) and this brings up the same error - but works flawless!

So i hope for the next Manjaro release for this error will be gone...
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2726
Re: *** Error in `amule': free(): invalid pointer: 0x000000000483bb60 ***
« Reply #6 on: October 10, 2016, 07:17:05 PM »

Manjaro / Arch provided a new(er) version of aMule 10958 (17th September)

That's almost 2.3.2... Why not that?
Logged
concordia cum veritate

LAZA

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 27
Re: *** Error in `amule': free(): invalid pointer: 0x000000000483bb60 ***
« Reply #7 on: October 10, 2016, 08:56:02 PM »

Manjaro / Arch provided a new(er) version of aMule 10958 (17th September)

That's almost 2.3.2... Why not that?

Cause 10958 is in the paket manager...

Which version has 2.3.2?
Maybe the maintainer needs a little push to compile that with actual packages   ::)
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2726
Re: *** Error in `amule': free(): invalid pointer: 0x000000000483bb60 ***
« Reply #8 on: October 12, 2016, 11:30:35 AM »

Which version has 2.3.2?

10960 is identical to 2.3.2 except that it identifies itself as a development version. The real 2.3.2 release tarball can be found on SourceForge.
Logged
concordia cum veritate