aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMule crash with clean Linux Mint 18  (Read 1627 times)

mac1929

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 19
aMule crash with clean Linux Mint 18
« on: September 06, 2016, 07:01:21 AM »

Hi guys,

I have just installed a clean Linux Mint 18 in a laptop. When running aMule it crashes with this report:

ASSERT INFO:
../src/unix/sockunix.cpp(143): assert "m_fd != INVALID_SOCKET" failed in OnReadWaiting(): invalid socket ready for reading?

BACKTRACE:
[1] wxOnAssert(char const*, int, char const*, char const*, char const*)
[2] g_main_context_dispatch
[3] g_main_loop_run
[4] gtk_main
[5] wxGUIEventLoop::DoRun()
[6] wxEventLoopBase::Run()
[7] wxAppConsoleBase::MainLoop()
[8] wxEntry(int&, wchar_t**)
[9] __libc_start_main

God the binary form the "Market". Version is 2.4.0~git20151120.0023527bc2-1ubuntu1
« Last Edit: September 06, 2016, 07:05:18 AM by mac1929 »
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 164
  • Offline Offline
  • Posts: 2714
Re: aMule crash with clean Linux Mint 18
« Reply #1 on: September 06, 2016, 07:57:29 PM »

wxWidgets version?
Logged
concordia cum veritate

mac1929

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 19
Re: aMule crash with clean Linux Mint 18
« Reply #2 on: September 08, 2016, 04:44:08 PM »

wxWidgets version?

This is the info shown. I suppose it is 3.0.2. Got amule from the official Mint repo.

Current version is: aMule SVN compiled with wxGTK2 v3.0.2 and Boost 1.58
Running on: Linux 4.4.0-21-generic x86_64

[2] ?? in /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0[0x7fb5fd8568ec]
[3] ?? in /lib/x86_64-linux-gnu/libpthread.so.0[0x7fb5fc9ba3d0]
[4] ?? in [0x7fb5cc00cc20]

In case this is of any help:

$ ldd /usr/bin/amule | more
   linux-vdso.so.1 =>  (0x00007ffc037f4000)
   libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007efd172eb000)
   libboost_system.so.1.58.0 => /usr/lib/x86_64-linux-gnu/libboost_system.so.1.58.0 (0x00007efd170e7000)
   libcrypto++.so.9 => /usr/lib/libcrypto++.so.9 (0x00007efd16acd000)
   libupnp.so.6 => /usr/lib/x86_64-linux-gnu/libupnp.so.6 (0x00007efd16894000)
   libixml.so.2 => /usr/lib/x86_64-linux-gnu/libixml.so.2 (0x00007efd16687000)
   libwx_gtk2u_adv-3.0.so.0 => /usr/lib/x86_64-linux-gnu/libwx_gtk2u_adv-3.0.so.0 (0x00007efd162a0000)
   libwx_gtk2u_core-3.0.so.0 => /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0 (0x00007efd15a27000)
   libwx_baseu_net-3.0.so.0 => /usr/lib/x86_64-linux-gnu/libwx_baseu_net-3.0.so.0 (0x00007efd157db000)
   libwx_baseu-3.0.so.0 => /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0 (0x00007efd15348000)
   libGeoIP.so.1 => /usr/lib/x86_64-linux-gnu/libGeoIP.so.1 (0x00007efd15117000)
   libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007efd14d95000)
   libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007efd14a8b000)
   libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007efd14875000)
   libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007efd14658000)
   libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007efd1428e000)
   libthreadutil.so.6 => /usr/lib/x86_64-linux-gnu/libthreadutil.so.6 (0x00007efd14087000)
   libgtk-x11-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0 (0x00007efd13a3b000)
   libgdk-x11-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0 (0x00007efd13786000)
   libgdk_pixbuf-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgdk_pixbuf-2.0.so.0 (0x00007efd13564000)
   libpango-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpango-1.0.so.0 (0x00007efd13317000)
   libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007efd130c4000)
   libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007efd12db3000)
   libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007efd12a78000)
   libnotify.so.4 => /usr/lib/x86_64-linux-gnu/libnotify.so.4 (0x00007efd12870000)
   libpangocairo-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpangocairo-1.0.so.0 (0x00007efd12663000)
   libcairo.so.2 => /usr/lib/x86_64-linux-gnu/libcairo.so.2 (0x00007efd1234e000)
   libXxf86vm.so.1 => /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 (0x00007efd12148000)
   libSM.so.6 => /usr/lib/x86_64-linux-gnu/libSM.so.6 (0x00007efd11f40000)
   libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007efd11d1a000)
   libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007efd11ac1000)
   libtiff.so.5 => /usr/lib/x86_64-linux-gnu/libtiff.so.5 (0x00007efd1184e000)
   libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007efd11649000)
   /lib64/ld-linux-x86-64.so.2 (0x0000562e99fd8000)
   libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007efd11445000)
   libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007efd1123e000)
   libatk-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libatk-1.0.so.0 (0x00007efd11019000)
   libgio-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0 (0x00007efd10c91000)
   libpangoft2-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0 (0x00007efd10a7a000)
   libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007efd10837000)
   libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007efd1062c000)
   libXinerama.so.1 => /usr/lib/x86_64-linux-gnu/libXinerama.so.1 (0x00007efd10429000)
   libXi.so.6 => /usr/lib/x86_64-linux-gnu/libXi.so.6 (0x00007efd10219000)
   libXrandr.so.2 => /usr/lib/x86_64-linux-gnu/libXrandr.so.2 (0x00007efd1000e000)
   libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007efd0fe03000)
   libXcomposite.so.1 => /usr/lib/x86_64-linux-gnu/libXcomposite.so.1 (0x00007efd0fc00000)
   libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007efd0f9fd000)
   libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007efd0f7ea000)
   libthai.so.0 => /usr/lib/x86_64-linux-gnu/libthai.so.0 (0x00007efd0f5e1000)
   libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007efd0f3d8000)
   libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007efd0f168000)
   libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007efd0ef46000)
   libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007efd0ec9b000)
   libpixman-1.so.0 => /usr/lib/x86_64-linux-gnu/libpixman-1.so.0 (0x00007efd0e9f3000)
   libxcb-shm.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-shm.so.0 (0x00007efd0e7ef000)
   libxcb-render.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-render.so.0 (0x00007efd0e5e4000)
   librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007efd0e3dc000)
   libICE.so.6 => /usr/lib/x86_64-linux-gnu/libICE.so.6 (0x00007efd0e1c1000)
   libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007efd0dfbc000)
   liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007efd0dd9a000)
   libjbig.so.0 => /usr/lib/x86_64-linux-gnu/libjbig.so.0 (0x00007efd0db8c000)
   libselinux.so.1 => /lib/x86_64-linux-gnu/libselinux.so.1 (0x00007efd0d969000)
   libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007efd0d74e000)
   libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007efd0d4ef000)
   libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007efd0d2c6000)
   libdatrie.so.1 => /usr/lib/x86_64-linux-gnu/libdatrie.so.1 (0x00007efd0d0bd000)
   libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007efd0ceb9000)
   libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007efd0ccb3000)
   libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007efd0ca8d000)
« Last Edit: September 08, 2016, 04:54:33 PM by mac1929 »
Logged

mac1929

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 19
Re: aMule crash with clean Linux Mint 18
« Reply #3 on: September 08, 2016, 09:09:37 PM »

It is very likely that the version available in Mint 18 is this one :)

https://github.com/amule-project/amule/issues/2
Logged

mac1929

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 19
Re: aMule crash with clean Linux Mint 18
« Reply #4 on: September 13, 2016, 04:51:00 PM »

Logged