aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: aMule 2.3.2: starts and disappears on me  (Read 475 times)

Brilliant

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
aMule 2.3.2: starts and disappears on me
« on: May 31, 2017, 06:41:13 PM »

Hi all,

on my remote server I've recently installed Fedora 25 server, and since I need a GUI also installed Plasma KDE workspace. And X2goServer to let me access it graphically. All is OK till now.
The problem arises with aMule taken from here. When I launch it a warning appears telling me that I shouldn't run it as root. Pressing OK the program interface appears, together with a new warning offering to download a list of server. I can press Yes or No to that, in any case the aMule window simply disappears, puff! Konsole shows a 'Segmentation error' at the end:

Code: [Select]
2017-05-31 17:58:52: Initialising aMule 2.3.2 compiled with wxGTK2 v3.0.2 and Boost 1.60
 2017-05-31 17:58:52: Checking if there is an instance already running...
 2017-05-31 17:58:52: No other instances are running.
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

--------------------------------------------------
Warning! You are running aMule as root.
Doing so is not recommended for security reasons,
and you are advised to run aMule as an normal
user instead.
--------------------------------------------------

 2017-05-31 17:59:16: ListenSocket: Ok.
 2017-05-31 17:59:17: Caricamento dei file Part da: /root/.aMule/Temp
 2017-05-31 17:59:17: Tutti i file Part sono caricati.
 2017-05-31 17:59:17: Thread 4 asincrono avviato
 2017-05-31 17:59:17: Thread 3 asincrono avviato
 2017-05-31 17:59:17: Thread 2 asincrono avviato
 2017-05-31 17:59:17: Thread 1 asincrono avviato
Errore di segmentazione

Any hint?

Thanks in advance.
Logged