aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Amule crashes at start  (Read 931 times)

javiermarcon

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 3
Amule crashes at start
« on: April 03, 2019, 03:13:31 AM »

Hello, When I start Amule with the 4662 port unavailable (because another user is using amule also), it crashes with the output listed.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.2 LTS"
PC: 64 bits (I7 with 64 gb of ram)

 2019-04-02 21:59:13: Initialising aMule 2.3.2 compiled with wxGTK2 v3.0.3 and Boost 1.65
 2019-04-02 21:59:13: Checking if there is an instance already running...
 2019-04-02 21:59:13: No other instances are running.
!2019-04-02 21:59:13: ERROR: Could not listen to TCP port.

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/index.php?board=67.0
If possible, please try to generate a real backtrace of this crash:
    http://wiki.amule.org/wiki/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.3.2 compiled with wxGTK2 v3.0.3 and Boost 1.65
Running on: Linux 4.15.0-46-generic x86_64

[2] ?? in /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0[0x7fa1da6d105c]
[3] ?? in /lib/x86_64-linux-gnu/libpthread.so.0[0x7fa1d9797890]
[4] ?? in amule[0x55c00cd83337]
[5] ?? in amule[0x55c00cd78af3]
[6] ?? in amule[0x55c00cd7af7d]
[7] ?? in amule[0x55c00cd7f419]
[8] ?? in amule[0x55c00cd836cc]
[9] wxThread::CallEntry() in /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0[0x7fa1da6c5d52]
[10] ?? in /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0[0x7fa1da6cd63c]
[11] ?? in /lib/x86_64-linux-gnu/libpthread.so.0[0x7fa1d978c6db]
[12] clone in /lib/x86_64-linux-gnu/libc.so.6[0x7fa1d94b588f]

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/index.php?board=67.0
If possible, please try to generate a real backtrace of this crash:
    http://wiki.amule.org/wiki/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.3.2 compiled with wxGTK2 v3.0.3 and Boost 1.65
Running on: Linux 4.15.0-46-generic x86_64

[2] ?? in /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0[0x7fa1da6d105c]
[3] ?? in /lib/x86_64-linux-gnu/libpthread.so.0[0x7fa1d9797890]
[4] ?? in amule[0x55c00cd83337]
[5] ?? in amule[0x55c00cd78af3]
[6] ?? in amule[0x55c00cd7af7d]
[7] ?? in amule[0x55c00cd7f419]
[8] ?? in amule[0x55c00cd836cc]
[9] wxThread::CallEntry() in /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0[0x7fa1da6c5d52]
[10] ?? in /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0[0x7fa1da6cd63c]
[11] ?? in /lib/x86_64-linux-gnu/libpthread.so.0[0x7fa1d978c6db]
[12] clone in /lib/x86_64-linux-gnu/libc.so.6[0x7fa1d94b588f]

--------------------------------------------------------------------------------
Aborted (core dumped)
Logged

tortuga57

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: Amule crashes at start
« Reply #1 on: April 03, 2019, 08:04:49 PM »

Tray to add a delay of 60 seconds before the start command of the daemon:

look her http://forum.amule.org/index.php?topic=21731.msg129505#msg129505

I have a similar problem
Logged