aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: "Enable IP Filtering" gives LowID  (Read 3308 times)

Warped_Dragon

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
"Enable IP Filtering" gives LowID
« on: October 12, 2004, 09:34:16 AM »

Hi, new amule user here, I use emule quite a bit on windows, but got tired of rebooting everytime I wanted something. So I installed amule, and it's great, good job on it. :)

I've got it all set up and configured the way I want, but I've hit a snag. Under preferences - security, setting the option "Enable IP Filtering" to on results in LowId's whenever I connect to a server. If I turn it off, I get HighID's. Obviously, I want HighID's with it on ;)

I'm on DSL, with a router. The ports are set correctly on the router, so it's not a router problem. I'm using Gentoo linux, neither ipchains nor iptables is installed, so it's not a firewall problem. I updated my ipfilter.dat file with the follewing url: http://ciberia.ya.com/Mc4TuTi/ipfilter.dat, which I found here on the forums. I'm not sure if it started after I did that, or if it did it before. I never tried turning that option on before I updated the file. If it turns out the file is the cause, can anyone suggest a different url to get an updated ipfilter.dat?

Anyone have any ideas? I have files that are impatient to be shared :)
Logged

Xaignar

  • Admin and Code Junky
  • Hero Member
  • *****
  • Karma: 19
  • Offline Offline
  • Posts: 1103
Re: "Enable IP Filtering" gives LowID
« Reply #1 on: October 12, 2004, 11:41:05 AM »

That link is broken, could you fix that and tell me the IP of the server you are trying to connect to?
Logged

Xaignar

  • Admin and Code Junky
  • Hero Member
  • *****
  • Karma: 19
  • Offline Offline
  • Posts: 1103
Re: "Enable IP Filtering" gives LowID
« Reply #2 on: October 12, 2004, 11:41:55 AM »

Nevermind, it isn't broken, I just didn't notice the comma at the end. ;)
However, I still need to know which server you are trying to connect to.
Logged

Warped_Dragon

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: "Enable IP Filtering" gives LowID
« Reply #3 on: October 12, 2004, 04:31:12 PM »

Sorry, should have said which servers I was using :) So far it's happened on every one I've tried, picking at random. *Starts amule to get some server ip's*

Ok, at random....

Code: [Select]
0/12/04 08:25:24: Connecting to Project Grande (213.158.119.104 - 213.158.119.104:4661)
10/12/04 08:25:25: Connected to Project Grande (213.158.119.104:4661)
10/12/04 08:25:25: Connection established on: Project Grande
10/12/04 08:25:25: WARNING: You have recieved Low-ID!

10/12/04 08:36:23: Connecting to [URL]www.zoozle.net[/URL] (69.50.243.2 - 69.50.243.2:4646)
10/12/04 08:36:23: Connected to [URL]www.zoozle.net[/URL] (69.50.243.2:4646)
10/12/04 08:36:24: Connection established on: [URL]www.zoozle.net[/URL]
10/12/04 08:36:24: WARNING: You have recieved Low-ID!

10/12/04 08:26:44: Connecting to Byte Devils (207.150.166.150 - 207.150.166.150:3306)
10/12/04 08:26:44: Connected to Byte Devils (207.150.166.150:3306)
10/12/04 08:26:46: Connection established on: Byte Devils
10/12/04 08:26:46: WARNING: You have recieved Low-ID!

10/12/04 08:27:37: Connecting to [URL]http://www.usenext.cc/[/URL] (207.150.166.150 - 207.150.166.150:3306)
10/12/04 08:27:37: Connected to [URL]http://www.usenext.cc/[/URL] (207.150.166.150:3306)
10/12/04 08:27:38: Connection established on: [URL]http://www.usenext.cc/[/URL]
10/12/04 08:27:38: WARNING: You have recieved Low-ID!

10/12/04 08:29:51: Connecting to ProbenPrinz.de (62.241.53.4 - 62.241.53.4:4242)
10/12/04 08:29:51: Connected to ProbenPrinz.de (62.241.53.4:4242)
10/12/04 08:29:52: Connection established on: ProbenPrinz.de
10/12/04 08:29:52: WARNING: You have recieved Low-ID!

10/12/04 08:30:20: Connecting to !StormSex.net - Free Porn! (69.50.187.210 - 69.50.187.210:4661)
10/12/04 08:30:20: Connected to !StormSex.net - Free Porn! (69.50.187.210:4661)
10/12/04 08:30:20: Connection established on: !StormSex.net - Free Porn!
10/12/04 08:30:20: WARNING: You have recieved Low-ID!

10/12/04 08:37:00: Connecting to LioNetwork.Net (212.199.125.36 - 212.199.125.36:8080)
10/12/04 08:37:00: Connected to LioNetwork.Net (212.199.125.36:8080)
10/12/04 08:37:02: Connection established on: LioNetwork.Net
10/12/04 08:37:02: WARNING: You have recieved Low-ID!

As you can see, it seems to be any server I try :/ Oh, and on another note, the !StormSex.net server seems to be the default when I set amule to autoconnect on startup. Any way to change that? It's not the server I'd choose, personally... but I digress. With Enable IP Filter set to OFF, the warnings about LowID are not present, and the color of the connected icon indicates a HighID. Hope this is what you needed :)
Logged

Xaignar

  • Admin and Code Junky
  • Hero Member
  • *****
  • Karma: 19
  • Offline Offline
  • Posts: 1103
Re: "Enable IP Filtering" gives LowID
« Reply #4 on: October 12, 2004, 05:15:12 PM »

Ok, this is strange. If you only use the ipfilter.dat file you've linked to, then those IPs shouldn't be filtered. I've tested that.

Could you attach your current ipfilter.dat file? The one found in ~/.aMule/
You'll probably have to bzip2 it first though.
Logged

Warped_Dragon

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: "Enable IP Filtering" gives LowID
« Reply #5 on: October 12, 2004, 06:53:26 PM »

Ok, I was doing as you asked, bzip'ing my ipfilter.dat... when I noticed an oddity. -My- ipfilter.dat has a grand total of one line in it. Very odd. Apparently, when I gave amule the link in my first post to update it's list, that's exactly what it did. Update it. Not save it, just update the list in memory, not saving when I closed it. So, I manually downloaded the file, and replaced one one-liner with it. Ran amule, and I'm now connecting with HighID's with the IP Filter turned on. I still don't know what was wrong or why it wasn't doing so before, but it seems to be working now :) Thanks for your swift response in trying to help though, it was much appreciated!
Logged

Xaignar

  • Admin and Code Junky
  • Hero Member
  • *****
  • Karma: 19
  • Offline Offline
  • Posts: 1103
Re: "Enable IP Filtering" gives LowID
« Reply #6 on: October 12, 2004, 07:32:40 PM »

What was the one line? Also, AFAIK, it should have saved it to file, when you updated it. I'll mention this to the guy who wrote that bit of the IPFilter code.
Logged

Warped_Dragon

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: "Enable IP Filtering" gives LowID
« Reply #7 on: October 13, 2004, 03:07:21 AM »

Erm.... I didn't even think to save it, so I couldn't tell you. I'd assume it's the same line that every install of aMule starts with :/ I could try reinstalling if you really wanted it :P
Logged