aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Pages: [1] 2

Author Topic: aMule crash  (Read 11148 times)

marcof

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 14
aMule crash
« on: December 23, 2004, 11:18:08 PM »

QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
kbuildsycoca running...
Checking /dev/cdrom for cdrom...
Testing /dev/cdrom for cooked ioctl() interface
CDROM sensed: ATAPI compatible HL-DT-ST GCE-8480B0B

kioslave: ####### CRASH ###### protocol = thumbnail pid = 22105 signal = 11
Hasher: Creating new thread.
Hasher: Starting to create MD4 hash for file: 032.part
Hasher: Finished hashing file: 032.part
Hasher: No files on queue, stopping thread.
Hasher: A thread has died.
9AE9F33790BFC769FC647FFF4AF6A7A4: Resuming uploads of file.
AICH Thread: Syncronization thread started.
AICH Thread: Masterhashes of known files have been loaded.
AICH Thread: Starting to hash files. 1 files found.
AICH Thread: Hashing file: King.of.Queens,The.[01x11].Noel.Coward.DVDRiP-RiVER.a vi, total files left: 0
AICH Thread: Hashing completed.
AICH Thread: Thread terminated.
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: aMule crash
« Reply #1 on: December 23, 2004, 11:27:35 PM »

hum ?

marcof

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 14
Re: aMule crash
« Reply #2 on: December 23, 2004, 11:32:00 PM »

i don't understand... that's what appear in my console..
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: aMule crash
« Reply #3 on: December 23, 2004, 11:33:07 PM »

i don't understand too.. because i don'T see OOPS - seems like amule crashed or smth like that ;)
and the cdrom stuff ..  8o

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2677
Re: aMule crash
« Reply #4 on: December 23, 2004, 11:36:40 PM »

Quote
kioslave: ####### CRASH ###### protocol = thumbnail pid = 22105 signal = 11
It seems like that kioslave has crashed meanwhile you ran aMule.
I suppose aMule runs fine, doesn't it?
Logged
concordia cum veritate

marcof

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 14
Re: aMule crash
« Reply #5 on: December 23, 2004, 11:45:59 PM »

aMule run fine 2 or 3 hours... afterwards aMule crash...
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: aMule crash
« Reply #6 on: December 23, 2004, 11:49:19 PM »

then we need a backtrace ( take a look here -> http://www.amule.org/wiki/index.php/Backtraces )

marcof

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 14
Re: aMule crash
« Reply #7 on: December 24, 2004, 04:05:58 PM »

I wait a little more and the problem is:

--------------------------------------------------------------------------------
OOPS! Houston, we have a situation: seems like aMule crashed!
Please, post these lines on the backtrace forum on http://www.amule.org/
aMule version is: 2.0.0rc8 using wxGTK1 v2.5.3
----------------------------=| BACKTRACE FOLLOWS: |=----------------------------

[0] CamuleApp::OnFatalException() in amule[0x8274e73]
[1] wxFatalSignalHandler in /usr/lib/libwx_base-2.5.so.3[0x40646c76]
[2] ?? in /lib/libc.so.6 [0x40b69078]
[3] CUploadQueue::GetWaitingPosition(CUpDownClient*) in amule[0x8267614]
[4] CUpDownClient::SendRankingInfo() in amule[0x825decc]
[5] CUploadQueue::AddClientToQueue(CUpDownClient*) in amule[0x82662b2]
[6] CClientReqSocket::ProcessPacket(char const*, unsigned, unsigned char) in amule[0x80d372e]
[7] CClientReqSocket::PacketReceived(Packet*) in amule[0x80dfc88]
[8] CEMSocket::OnReceive(int) in amule[0x80e30a4]
[9] CClientReqSocketHandler::ClientReqSocketHandler(wxSocketEvent&) in amule[0x80e057e]
[10] wxAppConsole::HandleEvent(wxEvtHandler*, void (wxEvtHandler::*)(wxEvent&), wxEvent&) const in /usr/lib/libwx_base-2.5.so.3[0x405a3a6b]
Logged

marcof

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 14
Re: aMule crash
« Reply #8 on: December 26, 2004, 12:08:27 AM »

Nobody know what happen? i'm running slackware 10, wxGTK 2.5.3
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: aMule crash
« Reply #9 on: December 26, 2004, 12:31:42 AM »

Quote
Originally posted by deltaHF
then we need a backtrace ( take a look here -> http://www.amule.org/wiki/index.php/Backtraces )

it can be a wxgtk 2.5.3 problem .. try to remove it and recompile wxgtk+wxbase 2.4.2, then recompile amule

marcof

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 14
Re: aMule crash
« Reply #10 on: December 27, 2004, 04:49:24 PM »

i can't compile aMule rc8 with wxGTK and wxBase 2.4.2

wxcas.cpp:71: error: parse error before `)' token
wxcas.cpp:76: error: parse error before `)' token
wxcas.cpp:84: error: `SetPrintMode' undeclared (first use this function)
wxcas.cpp:94: error: `Show' undeclared (first use this function)
wxcas.cpp:95: error: `SetTopWindow' undeclared (first use this function)
make[6]: *** [wxcas-wxcas.o] Error 1
make[6]: Leaving directory `/home/marco/aMule-2.0.0rc8/src/utils/wxCas/src'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/marco/aMule-2.0.0rc8/src/utils/wxCas'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/marco/aMule-2.0.0rc8/src/utils'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/marco/aMule-2.0.0rc8/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/marco/aMule-2.0.0rc8/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/marco/aMule-2.0.0rc8'
make: *** [all] Error 2
[marco@Linux:~/aMule-2.0.0rc8]
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: aMule crash
« Reply #11 on: December 27, 2004, 05:00:29 PM »

ls -l /usr/bin/wx*

ls -l /usr/local/bin/wx*

marcof

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 14
Re: aMule crash
« Reply #12 on: December 27, 2004, 05:05:05 PM »

[marco@Linux:~] ls -l /usr/bin/wx*
lrwxr-xr-x  1 root root   17 2004-12-27 16:46 /usr/bin/wx-config -> wxbase-2.4-config
-rwxr-xr-x  1 root root 4864 2004-12-27 16:46 /usr/bin/wxbase-2.4-config
-rwxr-xr-x  1 root bin  7644 2004-10-28 20:54 /usr/bin/wxcopy
-rwxr-xr-x  1 root root 5052 2004-12-27 16:14 /usr/bin/wxgtk-2.4-config
-rwxr-xr-x  1 root bin  6080 2004-10-28 20:54 /usr/bin/wxpaste
[marco@Linux:~]ls -l /usr/local/bin/wx*
ls: /usr/local/bin/wx*: No such file or directory
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
Re: aMule crash
« Reply #13 on: December 27, 2004, 05:11:04 PM »

as root:
 
ln -sf /usr/bin/wxgtk-2.4-config /usr/bin/wx-config
ln -sf /usr/bin/wxbase-2.4-config /usr/bin/wxbase-config
ldconfig

and recompile amule now

do you ppl never read FAQ? ;)
http://www.amule.org/wiki/index.php/Compilation_Installation

marcof

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 14
Re: aMule crash
« Reply #14 on: December 28, 2004, 01:48:19 AM »

OOPS! Houston, we have a situation: seems like aMule crashed!
Please, post these lines on the backtrace forum on http://www.amule.org/
aMule version is: 2.0.0rc8 using wxGTK1 v2.4.2
----------------------------=| BACKTRACE FOLLOWS: |=----------------------------

[0] CamuleApp::OnFatalException() in amule[0x8248f9a]
[1] wxFatalSignalHandler in /usr/lib/libwx_gtk-2.4.so[0xb7e621b9]
[2] ?? in /lib/libpthread.so.0 [0xb7f8ce65]
[3] ?? in [0xffffe420]
[4] CUploadQueue::GetWaitingPosition(CUpDownClient*) in amule[0x823b726]
[5] CUpDownClient::SendRankingInfo() in amule[0x8232847]
[6] CUploadQueue::AddClientToQueue(CUpDownClient*) in amule[0x823a408]
[7] CClientReqSocket::ProcessPacket(char const*, unsigned, unsigned char) in amule[0x80ce108]
[8] CClientReqSocket::PacketReceived(Packet*) in amule[0x80da62c]
[9] CEMSocket::OnReceive(int) in amule[0x80ddac2]
[10] CClientReqSocketHandler::ClientReqSocketHandler(wxSocketEvent&) in amule[0x80daef0]
[11] wxEvtHandler::SearchEventTable(wxEventTable&, wxEvent&) in /usr/lib/libwx_gtk-2.4.so[0xb7d7dc76]
[12] wxEvtHandler::ProcessEvent(wxEvent&) in /usr/lib/libwx_gtk-2.4.so[0xb7d7da7c]
[13] wxEvtHandler::ProcessPendingEvents() in /usr/lib/libwx_gtk-2.4.so[0xb7d7d9a
8]
[14] wxAppBase::ProcessPendingEvents() in /usr/lib/libwx_gtk-2.4.so[0xb7d40676]
[15] ?? in /usr/lib/libwx_gtk-2.4.so [0xb7ce2853]
[16] ?? in /usr/local/lib/libglib-1.2.so.0 [0xb779c1cd]
[17] ?? in /usr/local/lib/libglib-1.2.so.0 [0xb779b0d9]
[18] ?? in /usr/local/lib/libglib-1.2.so.0 [0xb779b5c4]
[19] g_main_run in /usr/local/lib/libglib-1.2.so.0[0xb779b83c]
[20] gtk_main in /usr/lib/libgtk-1.2.so.0[0xb788636f]
[21] wxApp::MainLoop() in /usr/lib/libwx_gtk-2.4.so[0xb7ce3386]
[22] wxAppBase::OnRun() in /usr/lib/libwx_gtk-2.4.so[0xb7d40518]
[23] wxEntry(int, char**) in /usr/lib/libwx_gtk-2.4.so[0xb7ce3b06]
[24] main in amule[0x824ccd9]
[25] __libc_start_main in /lib/libc.so.6[0xb74cb549]
[26] wxTopLevelWindowBase::GetMaxSize() const in start.S:122
Logged
Pages: [1] 2