aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: helppppp!!!!!!!! LOW iD!!!!!!!  (Read 4885 times)

deniz

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
helppppp!!!!!!!! LOW iD!!!!!!!
« on: January 02, 2005, 09:38:31 PM »

hello..
i am using fedora core 3 and my connection adsl.i am using a router.I opened ports tcp 4662, and udp 4665 and udp 4672 for the router.And i used "iptables"  command to allow this ports under linux.Output of the iptables -v -L is below....

Code: [Select]
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination
36143   30M RH-Firewall-1-INPUT  all  --  any    any     anywhere             anywhere
    0     0 ACCEPT     tcp  --  any    any     anywhere             anywhere            tcp dpt:4662
    0     0 ACCEPT     udp  --  any    any     anywhere             anywhere            udp dpt:4665
    0     0 ACCEPT     udp  --  any    any     anywhere             anywhere            udp dpt:4672

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination
    0     0 RH-Firewall-1-INPUT  all  --  any    any     anywhere             anywhere

Chain OUTPUT (policy ACCEPT 37309 packets, 5595K bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain RH-Firewall-1-INPUT (2 references)
 pkts bytes target     prot opt in     out     source               destination
 1264 1264K ACCEPT     all  --  lo     any     anywhere             anywhere
  158  9618 ACCEPT     icmp --  any    any     anywhere             anywhere            icmp any
    0     0 ACCEPT     ipv6-crypt--  any    any     anywhere             anywhere
    0     0 ACCEPT     ipv6-auth--  any    any     anywhere             anywhere
   11  1090 ACCEPT     udp  --  any    any     anywhere             224.0.0.251         udp dpt:5353
    0     0 ACCEPT     udp  --  any    any     anywhere             anywhere            udp dpt:ipp
33750   29M ACCEPT     all  --  any    any     anywhere             anywhere            state RELATED,ESTABLISHED
    0     0 ACCEPT     tcp  --  any    any     anywhere             anywhere            state NEW tcp dpt:ftp
    0     0 ACCEPT     tcp  --  any    any     anywhere             anywhere            state NEW tcp dpt:smtp
  960  208K REJECT     all  --  any    any     anywhere             anywhere            reject-with icmp-host-prohibited

and still i take a  low id .....What must i do....thanks to everybody...
« Last Edit: January 02, 2005, 09:39:09 PM by deniz »
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2676
Re: helppppp!!!!!!!! LOW iD!!!!!!!
« Reply #1 on: January 02, 2005, 10:25:55 PM »

You should use 'iptables -I INPUT 1 (blabla)'  instead of 'iptables -A INPUT (blabla)', so your rules get inserted BEFORE the firewall chain (RH-Firewall-1-INPUT)
Logged
concordia cum veritate

deniz

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: helppppp!!!!!!!! LOW iD!!!!!!!
« Reply #2 on: January 02, 2005, 10:44:38 PM »

still low ID...i did what you said..but still the same..0 am sending new output of iptables -v -L
Code: [Select]
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination
    0     0 ACCEPT     udp  --  any    any     anywhere             anywhere            udp dpt:4672
  111  8836 ACCEPT     udp  --  any    any     anywhere             anywhere            udp dpt:4665
    0     0 ACCEPT     tcp  --  any    any     anywhere             anywhere            tcp dpt:4662
42519   32M RH-Firewall-1-INPUT  all  --  any    any     anywhere             anywhere
    0     0 ACCEPT     tcp  --  any    any     anywhere             anywhere            tcp dpt:4662
    0     0 ACCEPT     udp  --  any    any     anywhere             anywhere            udp dpt:4665
    0     0 ACCEPT     udp  --  any    any     anywhere             anywhere            udp dpt:4672

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination
    0     0 RH-Firewall-1-INPUT  all  --  any    any     anywhere             anywhere

Chain OUTPUT (policy ACCEPT 45250 packets, 6180K bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain RH-Firewall-1-INPUT (2 references)
 pkts bytes target     prot opt in     out     source               destination
 1400 1274K ACCEPT     all  --  lo     any     anywhere             anywhere
  210 13012 ACCEPT     icmp --  any    any     anywhere             anywhere            icmp any
    0     0 ACCEPT     ipv6-crypt--  any    any     anywhere             anywhere
    0     0 ACCEPT     ipv6-auth--  any    any     anywhere             anywhere
   11  1090 ACCEPT     udp  --  any    any     anywhere             224.0.0.251         udp dpt:5353
    0     0 ACCEPT     udp  --  any    any     anywhere             anywhere            udp dpt:ipp
39842   30M ACCEPT     all  --  any    any     anywhere             anywhere            state RELATED,ESTABLISHED
    0     0 ACCEPT     tcp  --  any    any     anywhere             anywhere            state NEW tcp dpt:ftp
    0     0 ACCEPT     tcp  --  any    any     anywhere             anywhere            state NEW tcp dpt:smtp
 1056  219K REJECT     all  --  any    any     anywhere             anywhere            reject-with icmp-host-prohibited
Logged

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2676
Re: helppppp!!!!!!!! LOW iD!!!!!!!
« Reply #3 on: January 02, 2005, 10:50:25 PM »

Are you using aMule on the same machine where your firewall is?
Logged
concordia cum veritate

deniz

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: helppppp!!!!!!!! LOW iD!!!!!!!
« Reply #4 on: January 02, 2005, 11:22:19 PM »

i dont understand your question..actually i don't know...but i am using fedora core 3 and no another  firewall ..and my router has a virtual settings option and i add there;

tcp 4662
udp4665
udp4672

then i write my modem's ip(10.0.0.2) to the host  area..will i write another thing to that part?(my ip or 127.0....blabla).i dont know..i am using a asus labtop..i dont know yhe problem:(  and thanks your fast replies.....
Logged

snac

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 34
Re: helppppp!!!!!!!! LOW iD!!!!!!!
« Reply #5 on: January 03, 2005, 09:42:30 PM »

wait wait wait.
Deniz you use firewall fedora ? If yes, that would have to go at /dev/null :D
---First Step
Flush rules. you login with root ( in console please) ( sudo root ) and type this commands
iptables -F
iptables -X
iptables -Z

--Second Step
always as root type
service iptables stop

Ok you now have clear rules in memory and stopped a moment that semi-firewall :D of fedora.


You now start amule and try.
ID nice = You write rules for firewall. Read this post http://www.amule.org/wiki/index.php/Firewall
ID BAD = Problems of connection or you not share or ipbanned.

Good look.
P.S.
iptables -t nat -L -nv
« Last Edit: January 03, 2005, 09:45:00 PM by snac »
Logged
Desktop:: AMD Barton 2600 + ArchLinux Heavy Modded + KDE 3.4.1 + aMule 2.0.3
Portable:: Ibook G4 - 1,25Ghz - OSX 10.3.9
Linux User Nr.372724

deniz

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: helppppp!!!!!!!! LOW iD!!!!!!!
« Reply #6 on: January 04, 2005, 12:07:46 AM »

still low id..:( what must i do? and what is happening..i did all..must i change the ports??
Logged

snac

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 34
Re: helppppp!!!!!!!! LOW iD!!!!!!!
« Reply #7 on: January 04, 2005, 08:38:38 AM »

Deniz go in section config of the your router ( You can access in webbrowser) look manual router for it
exist a internal firewall in your router ?

Yes = Open port for Amule.
No = Control Settings amule. Or you have problems of connection or you not share or ipbanned.


Good Luck.
Logged
Desktop:: AMD Barton 2600 + ArchLinux Heavy Modded + KDE 3.4.1 + aMule 2.0.3
Portable:: Ibook G4 - 1,25Ghz - OSX 10.3.9
Linux User Nr.372724

deniz

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: helppppp!!!!!!!! LOW iD!!!!!!!
« Reply #8 on: January 05, 2005, 01:21:11 PM »

Noo i have bo firewall in my router..And i did all but still i get low ID ...:(  what can 1 do another...:(
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: helppppp!!!!!!!! LOW iD!!!!!!!
« Reply #9 on: January 05, 2005, 01:38:02 PM »

how do you connect to teh internet?
if you do connect with your router to the internet, it is a firewall even if its not called in the webinterface like that.

check in the webinterface, setup section for something like NAT, virtuall server or something simular.
you need to forward ports to your linux box. a good idear might be to check the manual of the router. they usually have to examples, for example for a webserver behind the router or soemthing alike.

stefanero
PS. I have a SMC router and amule would nto get highID aswell, a firmware update for the router  helped it.
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

deniz

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
Re: helppppp!!!!!!!! LOW iD!!!!!!!
« Reply #10 on: January 05, 2005, 01:46:37 PM »

i am connecting to the internet with ADSL and i have a 4 port switch router.And in webbrowser  it has virtual srver,NAT...atc..And i opened ports for amule bu using virtual server.But i didn't do anything with NAT..and my router has also  "WAN settings,Lan settings,DMZ,DNS,ADSL  Configuration,Route Table, Misc Confg.,RIP Confg.,Bridge Filtering"..And while opening ports what must 1 write to "Host IP Address" section..Must i write my computer's IP,or Router's 0p..?(for zoom modem it is 10.0.0.2)
I wish it helps you.And thanks your replies again...
« Last Edit: January 05, 2005, 01:48:30 PM by deniz »
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: helppppp!!!!!!!! LOW iD!!!!!!!
« Reply #11 on: January 05, 2005, 01:56:43 PM »

so you configured your adsl connection with teh WAN settings of this router right?
( just to make sure )

well maybe not only check out virtuel server, maybe check NAT section aswell, NAT is actually the right word for what you want.
and tehn FORWARD the 2 ports, 4462tcp and 4472udp to the IP address of your linux box running amule.

stefanero
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

AwesomeMachine

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 6
  • I was raised and presently live in Milwaukee, WI USA. I have a bachelors degree in chemistry, and a two year degree in computer programming.
firewall
« Reply #12 on: January 23, 2005, 04:37:16 AM »

I use SuSE 9.2 and a router.  I forwarded ports 4662 tcp 4672 udp to their respective identical external ports, 4662 4672 within the router.  I then shut my firewall off because nothing I did worked.  I'm still mystified as to how that firewall in SuSE works.  I know you use Fedora, and that firewall sounds hard.  But now I get high ID.

Powered by Asus P4P800|  Pentium 4 3.2 GHz. oc'ed to 3700  MHz. | 1GB Mushkin black PC3200 in dual controller at 6-2-2-2 | SATA 120 GB RAID | Nvidia FX5900 | SuSE 9.2
Logged
******AWESOME******