aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Webserver  (Read 5913 times)

Anthomas

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Webserver
« on: January 16, 2005, 10:36:21 PM »

Scusate ancora la mia totale ignoranza, sto impazzendo per far funzionare il webserver.
Ho impostato la porta 4771, l'ho aperta sul firewall del router, ma non riesco neanche a vedere il webserv dalla mia stessa macchina.
Provo a dare http://127.0.0.1:4771 e non mi visualizza niente, lo stesso con gli indirizzi 192.168.0.x:4771 (della mia lan) e con l'ip pubblico 151.x.x.x:4771
Sulle impostazioni ho messo avvia webserv all'avvio, abilitato compressione gzip, ho provato di tutto, ma non visualizzo il webserv (con emule mi funziona subito invece).
Cosa posso fare?
Vi sarei grato se mi aiutaste.
Logged

ReIkO

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
    • http://www.reik0.info
WebServer
« Reply #1 on: January 21, 2005, 10:04:27 AM »

Stesso problema! Credo ci sia un problema di base alla programmazione del client del mulo! O almeno su Linux non funziona!
Ho fatto e rifatto 200 prove ma niente!

 :P
Logged
ReIkO r0x

Frankk

  • Full Member
  • ***
  • Karma: 0
  • Offline Offline
  • Posts: 142
    • http://frankk.no-ip.com
Re: Webserver
« Reply #2 on: January 21, 2005, 12:17:10 PM »

Per attivare il webserver bisogna lanciare oltre ad amule anche amuleweb il quale si connette ad amule tramite la "Porta TCP esterna" che di default è 4712.

una volta che il tutto funzionerà potete avviare amuleweb in background con gli switch "amuleweb -q -f &"

Ciao.
Frankk
Logged

Anthomas

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: Webserver
« Reply #3 on: January 21, 2005, 02:39:10 PM »

Purtroppo quando avvio amuleweb mi da sempre la seguente risposta:
----------------------------------------------
xxxxxxxx@linux:~> amuleweb
Enter password for mule connection (return if no pass defined):

Creating client...
Now, doing connection....
Using host 'localhost' port:4712
Trying to connect (timeout = 10 sec)...
Connection Failed. Unable to connect to the specified host
---------------------------------------------------
Ho verificato la password, disabilitato il firewall, amule avviato, provate tutte le opzioni possibili, mi da sempre lo stesso messaggio.
Devo rassegnarmi?
Logged

Anthomas

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 12
Re: Webserver
« Reply #4 on: January 22, 2005, 12:14:39 PM »

Dopo aver copiato dai sorgenti la directory webserver e il file emule.tmpl, dando il comando #amuleweb -f sono riuscito a visualizzare la schermata di accesso dal browser. Effettuando login, entra nella pagina, ma mi cade improvvisamente la connessione con il seguente messaggio da amuleweb:
---------------------------------------------------------------
Creating client...
Now, doing connection....
Using host 'localhost' port:4772
Trying to connect (timeout = 10 sec)...
Succeeded! Connection established to aMule 2.0.0rc8

---------------------------------
|       aMule Web Server        |
---------------------------------


Use 'Help' for command list

Web Server: Started
aMuleweb$
WSThread: Thread started
WSThread: created service
WSThread: created socket listening on :4771
Segmentation fault
------------------------------------------------------

quindi anche se ora funziona inizialmente, non mi è possibile utilizzare il servizio.
Logged

Togusa

  • Newbie
  • Karma: 1
  • Offline Offline
  • Posts: 3
Re: Webserver
« Reply #5 on: February 02, 2005, 04:12:59 PM »

attenzione che stai sbagliando porta; è la 4711 , non 4771
Logged
Plug and pray eXperience...

BaHaMuT_ZeR0

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 32
Re: Webserver
« Reply #6 on: December 23, 2005, 02:25:24 PM »

a me dà questo errore invece

peppe@debian:~$ amuleweb
This is amuleweb CVS Thu Dec 22 07:02:03 CET 2005

Creating client...
CECSocket error: The timeout for this operation expired
CECSocket error: The timeout for this operation expired
Connection Failed. Unable to connect to the specified host

il mio file REMOTE.CONF è

Locale=
[EC]
Host=192.168.1.11
Port=4711
Password=a7872f0adb3f728cc7da152d004cc0e9
[Webserver]
Port=-1
Template=php-default
UseGzip=0
AllowGuest=0
AdminPassword=
GuestPassword=

Pls help me  :(
Logged