aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Crashes on start (always sigh -.-)  (Read 2199 times)

ominobufo

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 18
Crashes on start (always sigh -.-)
« on: March 02, 2005, 09:05:54 PM »

--------------------------------------------------------------------------------
OOPS! Houston, we have a situation: seems like aMule crashed!
Please, post these lines on the backtrace forum on http://www.amule.org/
aMule version is: 2.0.0rc8 using wxGTK1 v2.4.2
----------------------------=| BACKTRACE FOLLOWS: |=----------------------------

[0] CamuleApp::OnFatalException() in amule[0x82c8924]
[1] wxFatalSignalHandler in /usr/lib/libwx_gtk-2.4.so[0x404143dd]
[2] ?? in /lib/libpthread.so.0 [0x4002cc85]
[3] ?? in /lib/libc.so.6 [0x409f2db8]
[4] CSharedFilesWnd::CSharedFilesWnd(wxWindow*) in amule[0x8293478]
[5] CamuleDlg::CamuleDlg(wxWindow*, wxString const&, wxPoint, wxSize) in amule[0x82d013b]
[6] CamuleGuiApp::InitGui(bool, wxString&) in amule[0x82cc447]
[7] CamuleApp::OnInit() in amule[0x82c62e1]
[8] CamuleGuiApp::OnInit() in amule[0x82cc0a6]
[9] wxEntry(int, char**) in /usr/lib/libwx_gtk-2.4.so[0x4028fe08]
[10] main in amule[0x82cbf84]
[11] __libc_start_main in /lib/libc.so.6[0x409df469]
[12] wxTopLevelWindowBase::GetMaxSize() const in amule[0x812f861]

--------------------------------------------------------------------------------
Aborted


Work well for months till yesterday..... (maybe a reboot can solve ^^, will tell u)
« Last Edit: March 03, 2005, 06:48:32 PM by ominobufo »
Logged

phoenix

  • Evil respawning bird from aMule Dev Team
  • Developer
  • Hero Member
  • *****
  • Karma: 44
  • Offline Offline
  • Posts: 2505
  • The last shadow you'll ever see
Re: Crashes on start (always sigh -.-)
« Reply #1 on: March 03, 2005, 02:17:41 AM »

ominobufo,

This is the right place for crashes. Proper backtraces are another thing, read this:
http://www.amule.org/wiki/index.php/Backtraces

About your problem, were you on the search window and then altered a spin button down to zero? If that was it, this bug is already fixed in cvs. You can either wait for the next aMule release or get a tarball here and compile it yourself:
http://www.hirnriss.net/?area=cvs

If you choose to do so, please read this:
http://www.amule.org/wiki/index.php/Compilation_Installation

Cheers!
Logged

ominobufo

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 18
Re: Crashes on start (always sigh -.-)
« Reply #2 on: March 10, 2005, 08:02:08 PM »

tnx
Logged