aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: It runs but doesnt work when i'm not root  (Read 2927 times)

capi

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 3
It runs but doesnt work when i'm not root
« on: March 10, 2005, 11:49:18 PM »

Hello,

That's it, i can run the program when i'm a regular user, but it seems than i can`t open or read from the ports need, because i get no results when i search for any files. When i become root everything works fine

any help?
thanks
Logged

quazar

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: It runs but doesnt work when i'm not root
« Reply #1 on: March 11, 2005, 05:31:13 AM »

Are you using the default ports, or are you running below port 1027, linux by default prevents access to ports below 1027 if you are not root, but you should just get a low id if this is so.

What version are you using rc8 cvs?

Did you compile this yourself or did you use a rpm?

Firewall / router?
Logged

quazar

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: It runs but doesnt work when i'm not root
« Reply #2 on: March 11, 2005, 06:17:21 AM »

Can you access the internet from a web browser from the "non root" account?
Logged

capi

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 3
Re: It runs but doesnt work when i'm not root
« Reply #3 on: March 12, 2005, 03:06:28 AM »

I'm using the default ports, and i have the last debian tensting version, which is 2.0.0rc7
Logged

quazar

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: It runs but doesnt work when i'm not root
« Reply #4 on: March 12, 2005, 03:57:31 AM »

I would try to compile or get a hold of at least rc8 and try that and see what happens;  I don't remember what the issue was that I had with rc7, but this made it unusable (at least for the distribution I was using at the time.).

 http://www.amule.org/files/download.php?file=59 --(link to rc8 for debian)

Oddly and I don't know if this is related, but if you compile FireFox in linux as root (sometimes) it won't let you run it as any other user; it pumps out errors in a non ending loop.

Also there were some internet access issues with various packaged versions of WX, if the above dosn't work, you may want to try to compile wxAll yourself.

http://prdownloads.sourceforge.net/wxwindows/wxAll-2.4.2.tar.gz

Hope this helps :)
Logged

capi

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 3
Re: It runs but doesnt work when i'm not root
« Reply #5 on: March 12, 2005, 01:11:37 PM »

thanx
Logged

quazar

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 13
Re: It runs but doesnt work when i'm not root
« Reply #6 on: March 12, 2005, 11:28:26 PM »

Your welcome :)
Logged