aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: CVS 20050309 Crashed  (Read 2290 times)

basler

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
CVS 20050309 Crashed
« on: March 11, 2005, 08:35:41 PM »

Hi


----------------------------=| BACKTRACE FOLLOWS: |=----------------------------

aMule version is: CVS using wxGTK2 v2.5.4 (Snapshot: Wed Mar  9 07:01:24 CET 2005)

[0] ?? in amuled [0x80e6bc6]
[1] ?? in amuled [0x815ea7b]
[2] wxFatalSignalHandler in /usr/lib/libwx_base-2.5.so.4[0x40187ba8]
[3] ?? in /lib/libpthread.so.0 [0x40028825]
[4] ?? in /lib/libc.so.6 [0x4049e678]
[5] ?? in amuled [0x80b9e87]
[6] ?? in amuled [0x80b4a90]
[7] ?? in amuled [0x80bad81]
[8] ?? in amuled [0x80bc380]
[9] wxThreadInternal::PthreadStart(wxThread*) in /usr/lib/libwx_base-2.5.so.4[0x4017e57b]
[10] wxPthreadStart in /usr/lib/libwx_base-2.5.so.4[0x4017e44f]
[11] ?? in /lib/libpthread.so.0 [0x40022e51]
[12] __clone in /lib/libc.so.6[0x4054c6ea]

--------------------------------------------------------------------------------


(10 min later:) OK, now it looks, that it works, but ist don't connect to the servers?! The Console shows that:

CServerSocket: destroying socket 0x8533838
CServerSocket: connection refused or timed out
CServerSocket: destroying socket 0x85b4ca8
CServerSocket: destroying socket 0x8535198
CServerSocket: connection refused or timed out
CServerSocket: destroying socket 0x8533838
ECSocket::ReadBufferFromSocket error The socket is non-blocking and the operation would block
ECSocket::ReadBufferFromSocket error The socket is non-blocking and the operation would block
ECSocket::ReadBufferFromSocket error The socket is non-blocking and the operation would block


Is this normal? I think not...

And the webinterface freezes, after trying to connect manualy.

Last night, the amuled worked normally.

Help!




Bye



P.S: aMule is great! (If it works...)  :baby:
« Last Edit: March 11, 2005, 08:45:45 PM by basler »
Logged

zippelmann

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: CVS 20050309 Crashed
« Reply #1 on: March 13, 2005, 07:12:59 PM »

Today I got the same error with the cvs vom yesterday and today. I tried to connect to the webserver but after I passed the login I only see a withe screen. I tried to restart the daemon ..

and this is the bug mesg:

Shutdown requested, terminating.
free(): invalid pointer 0x84e3508!
free(): invalid pointer 0x84e36d8!

--------------------------------------------------------------------------------
Oops, aMule crashed!
Hey, stop crying! You wanted the edge, and now you fell down?!
Please, post the following lines, on the aMule Crashes forum on:
    http://forum.amule.org/board.php?boardid=67&sid=/
You should also try to generate a real backtrace of this error, please read:
    http://www.amule.org/wiki/index.php/Backtraces
----------------------------=| BACKTRACE FOLLOWS: |=----------------------------

aMule version is: CVS using wxGTK2 v2.5.4 (Snapshot: Sun Mar 13 07:01:23 CET 2005)

  • ?? in amuled [0x80e6b72]
  • [1] ?? in amuled
[0x815f009]
[2] wxFatalSignalHandler in /usr/lib/libwx_base-2.5.so.4[0x40148ba8]
[3] ?? in [0xffffe420]

--------------------------------------------------------------------------------
Abgebrochen
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: CVS 20050309 Crashed
« Reply #2 on: March 13, 2005, 07:33:32 PM »

1st
http://www.amule.org/wiki/index.php/FAQ_amuled -- this one is nice for at least 2 bugs...

2nd
could you please compile your amuled with --enable-debug and run it in gdb?
so wec can get usefull backtraces and fix those freaking bugs

thnx
stefanero
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

zippelmann

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: CVS 20050309 Crashed
« Reply #3 on: March 13, 2005, 10:25:18 PM »

sry, but now it works  mysteriously. I will post the gdb msgs if I get this error once more
Logged