aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Read this before posting!  (Read 7584 times)

phoenix

  • Evil respawning bird from aMule Dev Team
  • Developer
  • Hero Member
  • *****
  • Karma: 44
  • Offline Offline
  • Posts: 2505
  • The last shadow you'll ever see
Read this before posting!
« on: March 26, 2005, 10:41:25 PM »

Before posting in this forum, please serch for your problem here so that you don't waste your time and we don't waste ours. Try to find a backtrace similar to yours and follow the instructions. Here are some "classic" rc8 backtraces. These are all solved issues and current CVS code no longer has them. Or maybe they were generated due to a misbehaving wx package, unfortunately most distributions come with bad wxGTK packages.

So, first, make sure you are using the wx packages from our home page:
http://www.amule.org/files/files.php?cat=12

If the problem still persists, get yourself a CVS snapshot tarball here and compile it yourself. Instructions on how to do so can be found here. If your distribution is rpm based, you can also do:

$ rpmbuild -ta aMule-CVS-20050326.tar.bz2

And a rpm will be magically built.

Please, don't post if your backtrace looks like any of these:

Cheers!
Logged

rebroad

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 9
    • http://stardate.no-ip.com
Is it ok to use wxwidgets v2.5.x?
« Reply #1 on: May 14, 2005, 10:04:39 PM »

Quote
Originally posted by phoenix
So, first, make sure you are using the wx packages from our home page:
http://www.amule.org/files/files.php?cat=12

Cheers!

I notice on the webpage above that there are versions 2.4.x and 2.6.x. Is amule supported if compiled using wxwidgets 2.5.x?

Cheers,
Ed
Logged

deltaHF

  • Evil Admin
  • Former Developer
  • Hero Member
  • *****
  • Karma: 6
  • Offline Offline
  • Posts: 3923
  • .. Legends may sleep, but they never die ..
    • http://www.amule.org
RE: Is it ok to use wxwidgets v2.5.x?
« Reply #2 on: May 14, 2005, 10:07:47 PM »

Quote
Originally posted by rebroad
I notice on the webpage above that there are versions 2.4.x and 2.6.x. Is amule supported if compiled using wxwidgets 2.5.x?

somehow yes.. but as wxGTK-2.5.x has a lot of bugs, it's better to get 2.6.0 ;)

cheers

GonoszTopi

  • The current man in charge of most things.
  • Administrator
  • Hero Member
  • *****
  • Karma: 165
  • Offline Offline
  • Posts: 2677
Re: Read this before posting!
« Reply #3 on: June 29, 2006, 06:23:53 PM »

One more thing about posting backtraces:

There is a checkbox under text input field labelled `Deactivate smilies in this message.'
PLEASE check this checkbox! It's much easier to read raw character data than smilies :)
Logged
concordia cum veritate

strcpy

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 3
Re: Read this before posting!
« Reply #5 on: September 15, 2007, 10:34:33 AM »

So, first, make sure you are using the wx packages from our home page:
http://www.amule.org/files/files.php?cat=12

the link is dead
Logged