aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: amule e wxGTK  (Read 3332 times)

chaosgate

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
amule e wxGTK
« on: March 30, 2005, 09:08:02 PM »

Salve a tutti, avevo un amule perfettamente funzionante, poi mi รจ venuta la malsana idea di fare (in fedora core 4) un yum check-update e mi ha visto che c'era una versione nuova di wxgtk... aggiorno e ora il mulo ( da console) mi dice:


----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
[0] CamuleApp::OnFatalException() in amule[0x82252ea]
[1] wxFatalSignalHandler in /usr/lib/libwx_gtk-2.4.so.0[0x54805d]
[2] ?? in /lib/tls/libpthread.so.0 [0xa508d8]
[3] wxChoice::GetString(int) const in /usr/lib/libwx_gtk-2.4.so.0[0x3e584e]
[4] wxListBase::Append(void*) in /usr/lib/libwx_gtk-2.4.so.0[0x4c889b]
[5] wxChoice::GtkAppendHelper(_GtkWidget*, wxString const&) in /usr/lib/libwx_gtk-2.4.so.0[0x3e5b65]
[6] wxChoice::Create(wxWindow*, int, wxPoint const&, wxSize const&, int, wxString const*, long, wxValidator const&, wxString const&) in /usr/lib/libwx_gtk-2.4.so.0[0x3e5d16]
[7] searchDlg(wxWindow*, bool, bool) in amule[0x816a6ac]
[8] CSearchDlg::CSearchDlg(wxWindow*) in amule[0x81d01f5]
[9] CamuleDlg::CamuleDlg(wxWindow*, wxString const&, wxPoint, wxSize) in amule[0x823598b]
[10] CamuleGuiApp::InitGui(bool, wxString&) in amule[0x822e06b]
[11] CamuleApp::OnInit() in amule[0x8227da6]
[12] CamuleGuiApp::OnInit() in amule[0x822dd91]
[13] wxEntry(int, char**) in /usr/lib/libwx_gtk-2.4.so.0[0x3ddfd0]
[14] main in amule[0x822dc7b]
[15] __libc_start_main in /lib/tls/libc.so.6[0xe32e33]
[16] wxScrolledWindow::AdjustScrollbars() in amule[0x80cbbf1]


qualche idea?

ciao a tutti!
Logged

phoenix

  • Evil respawning bird from aMule Dev Team
  • Developer
  • Hero Member
  • *****
  • Karma: 44
  • Offline Offline
  • Posts: 2505
  • The last shadow you'll ever see
Re: amule e wxGTK
« Reply #1 on: March 31, 2005, 03:51:17 AM »

Ciao chaosgate,

Sorry, I don't speak italian. You have a broken wx package. Remove all your wx packages (wxGTK, wxGTK-devel and possibly wxBase) and reinstall with the ones from our home page:
http://www.amule.org/files/files.php?cat=12

Cheers!
Logged