aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: amule crashes when scrolling server list  (Read 1622 times)

AZerror

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
amule crashes when scrolling server list
« on: May 31, 2005, 11:24:02 PM »

i'm using mandrake 10.1, and installed amule with urpmi. when first I loaded amule everything worked fine, until I scrolled down the server list, then it crashed. didn't create a core file or a big enough error to post here like others i've seen... the problem got worse and I couldn't even connect to the servers without crashing again anymore. after some research here I removed amule, installed your wx packages just to make sure and re-installed amule (still urpmi... was lazy and i hate compilation...  :] ). also updated the server.met file.
now it loads and can even connect to the servers but if I scroll to about half the length of the list it crashes just like before... also, my speed is incredibly low (0.7 k at most..) but i guess it has nothing to do with it.

$ rpm -qa | grep wx
wxGTK2.5-2.5.1-5mdk
libwxPythonGTK2.5_2-2.5.2.7-2mdk
wxGTK-2.4.2-1
libwxgtk2.5_1-2.5.1-5mdk
wxPythonGTK-2.5.2.7-2mdk
wxBase-2.4.2-1

i see i have another wxGTK... should I remove it?
sorry i don't have a detailed error message, just this -

AICH Thread: Syncronization thread started.
AICH Thread: Masterhashes of known files have been loaded.
AICH Thread: No new files found.
AICH Thread: Thread terminated.
Segmentation fault

just before the next prompt.
thanks in advance!
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: amule crashes when scrolling server list
« Reply #1 on: June 01, 2005, 08:02:56 AM »

yup long solved problem, thats why there is 2.0.1, upgrad and all be fine ;)

stefanero
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."