aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: apt-get upgrade hällt amule und amuleweb zurück  (Read 6942 times)

tomek74

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 10
apt-get upgrade hällt amule und amuleweb zurück
« on: June 21, 2005, 10:59:20 AM »

apt-get upgrade funktioniert nicht mehr. Hier der Output:

The following packages have been kept back:
  amule amuleweb
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.


Ein apt-get install amule liefert den folgenden Output:

apt-get install amule
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  amule: Depends: libgcc1 (>= 1:4.0.0-7) but 1:3.4.3-13 is to be installed
E: Broken packages


In meiner source.list steht:
deb http://www.vollstreckernet.de/debian/ testing amule
deb http://www.vollstreckernet.de/debian/ testing wx


dpkg -s amule sagt:

dpkg -s amule
Package: amule
Status: install ok installed
Priority: optional
Section: x11
Installed-Size: 6192
Maintainer: Vollstrecker
Architecture: i386
Version: 2.0.3+CVS20050616-1
Depends: libc6 (>= 2.3.2.ds1-21), libgcc1 (>= 1:3.4.1-3), libglib2.0-0 (>= 2.6.0), libgtk2.0-0 (>= 2.6.0), libstdc++5 (>= 1:3.3.4-1), libwxgtk2.5.3 (>= 2.5.3.2), libx11-6 | xlibs (>> 4.1.0), zlib1g (>= 1:1.2.1)
Recommends: amule-utils, amule-cas, amule-wxcas
Suggests: amule-xas
Description: aNOTHER eMule P2P Client
 aMule stand for another eMule file-sharing program, it is also
 another fork of the xMule project. It connects to eDonkey2000
 network, supports Linux, *BSD and MacOS X platforms, and has
 a new vision of the GUI


Wer weiß, wie man das Problem beheben kann?

Gruss Thomas
« Last Edit: June 21, 2005, 11:01:19 AM by tomek74 »
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4249
RE: apt-get upgrade hällt amule und amuleweb zurück
« Reply #1 on: June 21, 2005, 11:06:35 AM »

Quote
Originally posted by tomek74
The following packages have unmet dependencies:
  amule: Depends: libgcc1 (>= 1:4.0.0-7) but 1:3.4.3-13 is to be installed
E: Broken packages

schonmal versucht libgcc upzudaten?
btw wenn du das machst könnte es aber sein das er noch eine ganze menge andere sachen updatet

stefanero
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

tomek74

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 10
Re: apt-get upgrade hällt amule und amuleweb zurück
« Reply #2 on: June 21, 2005, 11:22:26 AM »

Quote
schonmal versucht libgcc upzudaten?

Wie kann ich einfach libgcc updaten?

Ich habe Degian Sarge 3.1

sourcelist.list

deb http://ftp.de.debian.org/debian/ sarge main contrib non-free
deb http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free
deb-src http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free
deb http://security.debian.org stable/updates main contrib non-free
deb http://www.vollstreckernet.de/debian/ testing amule
deb http://www.vollstreckernet.de/debian/ testing wx
Logged

Vollstrecker

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1471
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: apt-get upgrade hällt amule und amuleweb zurück
« Reply #3 on: June 21, 2005, 11:28:03 AM »

Entweder mit Backports, oder selbst Backporten, oder garnicht. Ich habe hier nur testing am laufen, und kann deswegen nicht für Sarge bauen. Jetzt ist die Zeitspanne in der Sarge und testing nahe beieinander liegen wohl um.
Wenn jemand einen Sarge-Rechner zur Verfügung stellen könnte, würde ich darauf auch pkg's für Sarge bauen, aber bis jetzt hat sich niemand gefunden.
Logged
Homefucking is killing prostitution

tomek74

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 10
Gute Anleitung zum Bauen von Packeten für Debian Sarge
« Reply #4 on: June 21, 2005, 04:15:44 PM »

Wo kann ich denn eine gute Anleitung zum Bauen der Packete finden?
Vielleicht sogar in deutsch?

Gruss Thomas
Logged

Vollstrecker

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1471
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: apt-get upgrade hällt amule und amuleweb zurück
« Reply #5 on: June 21, 2005, 11:05:34 PM »

Bei google. dpkg-source oder apt-get builddep sollten die richtigen Treffer bringen. Auf Debian-User war auch mal ne Anleitung dazu, die du mit einem der Stichworte im Archiv finden können solltest. Falls dir das nicht hilft, hab ich irgendwo auch noch ne Anleitung rumfliegen. Muss ich halt erst suchen.
Logged
Homefucking is killing prostitution

tomek74

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 10
Selber bauen, oder auf testing umsteigen, aber wie?
« Reply #6 on: June 22, 2005, 10:15:54 AM »

Vielen Dank für die Infos.
Eine andere Möglichkeit wäre doch Sarge auf testing zu bringen.
Ich weiss leider nicht wie das geht, aber ich könnte mir vorstellen, dass es genügt, wenn man die source.list Datei ändert.
Alle Vorkommnisse von sarge oder stable durch testing ersetzen!

Anstatt:
deb http://ftp.de.debian.org/debian/ sarge main contrib non-free
deb http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free
deb-src http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free
deb http://security.debian.org stable/updates main contrib non-free

Lieber:
deb http://ftp.de.debian.org/debian/ testing main contrib non-free
deb http://non-us.debian.org/debian-non-US testing/non-US main contrib non-free
deb-src http://non-us.debian.org/debian-non-US testing/non-US main contrib non-free
deb http://security.debian.org testing/updates main contrib non-free

Wen ich dann apt-get update && apt-get upgrade ausführe, dann könnte ich die aktuelle testing version von Debian haben? ODER?
Logged

Vollstrecker

  • Global Moderator
  • Hero Member
  • *****
  • Karma: 65
  • Offline Offline
  • Posts: 1471
  • Unofficial Debian Packager
    • http://vollstreckernet.de
Re: apt-get upgrade hällt amule und amuleweb zurück
« Reply #7 on: June 22, 2005, 12:08:45 PM »

Genau. Aber zum Wechseln der Distribution ist apt-get distupgrade vorgesehen.
Logged
Homefucking is killing prostitution