aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: LowID through Firewall & Router  (Read 6300 times)

sunka

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
LowID through Firewall & Router
« on: July 15, 2005, 09:37:21 PM »

Hi everybody,

I'm having trouble getting aMule to give me a HighID.  I have a cable internet connection through a Netgear router and software firewall under Fedora Core 4.

I went to the wiki and followed the instructions show on http://www.amule.org/wiki/index.php/Firewall_Fedora and I aslo configured my router to forward ports 4662, 4665, and 4672 to my computer's IP.  when I go to the test page it says everything is fine and should work, but when i actually connect to a server I get:

2005-07-15 12:28:22: Connected to eD2k mania (213.251.134.191:4661)
2005-07-15 12:28:23: Warning: eD2k mania (213.251.134.191:4661) - NG : Your 4662 port is not reachable. Please review your network config.
2005-07-15 12:28:23: Connection established on: eD2k mania
2005-07-15 12:28:23: WARNING: You have recieved Low-ID!
2005-07-15 12:28:23:    Most likely this is because you're behind a firewall or router.
2005-07-15 12:28:23:    For more information, please refer to http://wiki.amule.org

my router's forwarding setup looks something like this (there is no TCP/UDP option):

     #     Service Name      Start Port      End Port     Server IP Address
   1   eMule                       4662           4662         mylocalIP
   2   eMule                       4665           4665         mylocalIP
   3   eMule                       4672           4672         mylocalIP

This is my first time having a computer behind a router so that's probably where the issue lies, although is it possible i need to do more setup on my computer's software firewall than described on the howto page?

Thanks for all your help.
-Josh
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: LowID through Firewall & Router
« Reply #1 on: July 15, 2005, 09:39:34 PM »

well 1st thing you should try is to DISABLE the FC4 firewall, and restart amule....if you are highID then, it was that, if not its teh router

do you get your IP address from teh router via dhcp or did you setup static ip in FC?
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

sunka

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: LowID through Firewall & Router
« Reply #2 on: July 16, 2005, 07:00:09 PM »

Diabled the FC4 firewall and that didn't help.  My computer's IP address is  assigned by the router via DHCP I believe, but the router is set up to always assign it the same IP address, and my public IP is dynamically assigned to the router by the ISP.

My login screen displays my computer's IP as localhost.localdomain rather than an actual IP address (which happens if I connect the computer directly to the cable modem).
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: LowID through Firewall & Router
« Reply #3 on: July 16, 2005, 08:23:29 PM »

on most routers you cannot do portforwarding to dhcp address...try with a statuc address
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

sunka

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: LowID through Firewall & Router
« Reply #4 on: July 16, 2005, 10:23:04 PM »

i just set my computer to have a static IP using the network device manager, and that still didn't work.  I can't disable the network until later, but I am going to try connecting to an amule server directly to the cable modem w/o the router.  It didn't help with Limewire, but then, that crashed my computer everytime I tried starting it.  :rolleyes:  Anyway, thank your help, following your suggestions has helped me with a different program I was having network issues with. :)
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: LowID through Firewall & Router
« Reply #5 on: July 16, 2005, 11:18:24 PM »

well taking problems step by step is always a good way ;)
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

sunka

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 4
Re: LowID through Firewall & Router
« Reply #6 on: July 21, 2005, 09:39:21 PM »

Hi there,

Just an update on my situation...gave up on aMule working for a few days, then my need to have everything on my computer work perfectly overcame my frustration and I booted up aMule.  I received a HighID.  To test it, I disconnected and the next few servers said my port 4662 was unreachable, then one connected me with a LowID (the one that gave me a HighID b4)...I rebooted my computer, and got assigned a HighID...

Don't really know what's going on, but I'm connected with a HighID now, so I'm just not going to shut down the program or my computer. :-)

Thanks for your help.
_josh
Logged

wardevil

  • Sr. Member
  • ****
  • Karma: -1
  • Offline Offline
  • Posts: 402
Re: LowID through Firewall & Router
« Reply #7 on: July 25, 2005, 01:58:15 AM »

Perhaps your computer hang something (aMule??) on port 4662 and then when connecting to a server the port is blocked...  ?(

After closing amule(a few seconds later) issue the following command as root:
ps aux | grep amule

and see if there is any instance of amule
if not do:
lsof -i
and check if there is port 4662 in the output.
if port 4662 is there then there is something hanging that port...

Cheers.....
Logged
Linux user nº289016 at Linux counter

sexcopter

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
Re: LowID through Firewall & Router
« Reply #8 on: July 26, 2005, 04:09:37 PM »

Hi, I have a similar but slightly different problem, thought I'd continue here rather than start another thread :)

I have the usual lowid problem and my setup is as follows. I'm using aMule on Ubuntu on this pc, which is connected directly to an XP machine which is the gateway pc. The XP machine has Sygate (a software firewall) installed and is otherwise connected directly to a cable modem. I've set a rule on Sygate to allow all traffic in and out of 4662 on TCP but still no joy. Have disabled the firewall and also no joy. I wonder if I need some kind of portforwarding on the XP machine, but if so I have no idea how to do this (I can't see any such facility in Sygate). Can anyone advise me?
The port test page for 4662 gives the following:

Quote
Error: TCP port 4662 is unavailable. Make sure your firewall or router is allowing/forwarding this TCP service port and your ED2K client is running (i.e. aMule, eMule).

Detailed Error Message
TCP Error 111 Connection refused

Explanation
The port is available for connections but a connection was refused meaning there is nothing listening on that port. This most likely means you can use ED2K but your client is not currently running. Try running this test again with an ED2K client running to make sure you can really establish a connection. No info available; this TCP error probably indicates a problem with the networking on your system (i.e. the TCP/IP stack).

Maybe that gives some clue (and yes, aMule *is* running).
Thanks in advance for any help!

James.
Logged

stefanero

  • Some Support
  • Developer
  • Hero Member
  • *****
  • Karma: 8
  • Offline Offline
  • Posts: 4236
Re: LowID through Firewall & Router
« Reply #9 on: July 26, 2005, 04:32:25 PM »

well yes you need portforwarding otherwise it will not work, I suggest you read the manual of Sygate, if this app can actually do this.
I am not sure, but it will definelty not work without portforwarding

kerio, has a software firewall, which is capable of doing this, if you want to have a look.

other then that, I suggest you switch the pcs, make the ubuntu maschine the gw, and the XP behind it, this works probably much better and more easy anyway

stefanero
Logged
In its default setup, Windows XP on the Internet amounts to a car
parked in a bad part of town, with the doors unlocked, the key in
the ignition and a Post-It note on the dashboard saying, "Please
don't steal this."

KoZaki

  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 59
  • OS : i586 / athlon languages : french, english, chinese
    • http://c.laloy.free.fr/howtos/linux/
Re: LowID through Firewall & Router
« Reply #10 on: August 11, 2005, 12:12:06 AM »

I've got aMule on a Mandriva desktop connected to another Linux router/FW (which is incidently connected on an 'Freebox v2" (ADSL modem with dhcp but no router)

so i'm kind of in the same config than sexcopter, if not like sunka.

network's running fine but i get aMule's LowID as well as negative result on testport page :(
There is what i did on the Linux router/FW with iptables :
- Masquerade : iptables -A POSTROUTING -t nat -o eth1 -j MASQUERADE
- forwarded TCP & UDP ports which aMule's configured with
Then restarted iptables on the router/FW & network on the desktop PC.

As I'm still getting LowID on every 3-4 servers I tried, so I know there's still something to do, which is probably related to forwarding. But I ain't no clue about what to do now.

aMule WiKi says something i quite still don't understand
Quote
Vous disposez d'un firewall de type NAT sur votre réseau local (style Ipcop), de la même manière il faut que vous ouvriez les ports TCP 4662 et UDP 4672, mais en plus il faut que vous renseigniez l'adresse IP de votre poste aMule.
which may mean (my translation lol) : "you have to notify the IP Adress of the PC aMule's running on".

Please may someone help me on that ?
Logged
Internet <=> we like to share :D
la FAQ applications Linux

wardevil

  • Sr. Member
  • ****
  • Karma: -1
  • Offline Offline
  • Posts: 402
Re: LowID through Firewall & Router
« Reply #11 on: August 15, 2005, 03:24:31 AM »

Im not quite familiar with iptables as i use shorewall my self....but put some logging on the iptables rules to see whats happening....
Have u tried another port?i advise u to test with some high ports to see if your ISP is not playing with your money ;) like blocking default ports of p2p applications....


Cheers....
Logged
Linux user nº289016 at Linux counter

KoZaki

  • Jr. Member
  • **
  • Karma: 0
  • Offline Offline
  • Posts: 59
  • OS : i586 / athlon languages : french, english, chinese
    • http://c.laloy.free.fr/howtos/linux/
Re: LowID through Firewall & Router
« Reply #12 on: August 15, 2005, 09:05:38 PM »

Thank you wardevill,

I just happened to finalize my router configuration, thanks to this excellent page (in French) & amule iptables Firewall Wiki  :rolleyes:
Logged
Internet <=> we like to share :D
la FAQ applications Linux