aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Modifying shared files paths in /home/me/.aMule/shareddir.dat > aMule not start  (Read 344 times)

wdc

  • Approved Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 5

Hi, my large shared collection path changed, so i was searching .aMule directory files if i can try replacing old paths (backing up original directory before doing so). But after doing that (sed -i "s|/run/media/me/XTB/|/new/path/" shareddir.dat) and even restoring backup, aMule fails to start:

Quote
amule
09:52:30: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1014,wx containers,compatible with 2.8).
 2020-10-27 09:52:31: Initialising aMule SVN compiled with wxGTK2 v3.0.5 and Boost 1.72 (Snapshot: rev. 11047)
 2020-10-27 09:52:31: Checking if there is an instance already running...
 2020-10-27 09:52:31: No other instances are running.
 2020-10-27 09:53:13: ListenSocket: Ok.
 2020-10-27 09:53:14: Loading temp files from /home/lnot/.aMule/Temp.
 2020-10-27 09:53:14: All PartFiles Loaded.
 2020-10-27 09:59:12: Asio thread 1 started
 2020-10-27 09:59:12: Asio thread 2 started
 2020-10-27 09:59:12: Asio thread 3 started
 2020-10-27 09:59:12: Asio thread 4 started
Trace/breakpoint trap (core dumped)

aMule SVN compiled with wxGTK2 v3.0.5 and Boost 1.72 (Snapshot: rev. 11047) (OS: Linux)
Manjaro (Arch based) Linux

My questions are: how to fix this? How to replace paths without rehashing terabytes of data?

When i remove all files from mentioned .aMule directory, it start working.
Then i was trying to copy some other files to the empty folder and these worked:
.aMule/amule.conf
.aMule/known.met
.aMule/shareddir.dat
.aMule/known2_64.met
i had to again select directories to share and it looks like it not needed to rehash, just took maybe a minute to add the 1.5TB folder.
looking back i think i could save time and re-selected the shared directories via UI, though maybe it would delete known file hashes (http://wiki.amule.org/wiki/Known.met_file) when i deselect shared folder, i do not know, i have not tried...

I am wondering what went wrong when changing paths in mentioned file via command line and how to do it properly via command line and via GUI.

Thank You
Logged

Vollstrecker

  • Administrator
  • Hero Member
  • *****
  • Karma: 66
  • Offline Offline
  • Posts: 1532
  • Unofficial Debian Packager
    • http://vollstreckernet.de

Changing something in shareddir.dat should affect the hashing, nor the gui. You could even just add the dirs at the end of it and then move the files. You need to hash the files at least that amule sees that it's the same file, as these are located in known.met, which is binary. You could look into that with a hexeditor, but I don't think that helps much.

First thing I would adress is the ABI mismatch, just to be sure this doesn't cause your problems.
Logged
Homefucking is killing prostitution