aMule Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

We're back! (IN POG FORM)

Author Topic: Problem z instalacja  (Read 3811 times)

domininLatex

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 3
Problem z instalacja
« on: August 17, 2005, 02:38:38 PM »

Witam do tej pory korzystalem z gnutelli jednak chcialem sprawdzic amul'a niestety mam spory problem z instalacja (korzystam z Debiana). Zeby zainstalowac amula potrzebuje wxwidgets, przy instalacji otrzymuje taki komunikat:

*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

co powinienem zrobic zeby wlasciwie zainstalowac GTK? probowalem sciagnac nowsza wersje i poprostu zainstalowac, ale wyskakuje mi cos takiego:

configure: error: Package requirements (glib-2.0 >= 2.7.1    atk >= 1.0.1    pango >= 1.9.0    cairo >= 0.9.2) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the BASE_DEPENDENCIES_CFLAGS and BASE_DEPENDENCIES_LIBS environment variables
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.

Sciagnelem wszystkie wymienione biblioteki i je poinstalowalem, ale ciagle dostaje ten sam komunikat pomimo, ze zainstalowalem glib'a w wersji 2.8
Logged

KeRn

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 32
Re: Problem z instalacja
« Reply #1 on: August 17, 2005, 03:53:24 PM »

na to wyglada ze twoje liby nie sa tam gdzie wxwidgets ma podane w Makefile; uzyj przy ./configure opcji --help i podaj recznie sciezke do libow. Jesli masz debiana/ubuntu to tutaj masz mala pomoc.
Logged

domininLatex

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 3
Re: Problem z instalacja
« Reply #2 on: August 17, 2005, 04:25:12 PM »

1. Jak mam sprawdzic gdzie te biblioteki sie mieszcza?
2. Mam podac sciezke do kazdej z nich?
Logged

domininLatex

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 3
Re: Problem z instalacja
« Reply #3 on: August 17, 2005, 05:12:49 PM »

hmm nie doczytalem wczesniej ze mozna dodac link do apt'a i po klopocie, juz dziala :D
Logged

KeRn

  • Newbie
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 32
Re: Problem z instalacja
« Reply #4 on: August 18, 2005, 10:35:04 AM »

Quote
Originally posted by domininLatex
hmm nie doczytalem wczesniej ze mozna dodac link do apt'a i po klopocie, juz dziala :D
wiec po problemie?! :)

Quote
1. Jak mam sprawdzic gdzie te biblioteki sie mieszcza?
przewaznie sa w /usr/lib/

Quote
2. Mam podac sciezke do kazdej z nich?
o ile sa opcje w ./configure --help to bys tam musial to sprawdzic; jesli nie to pozostaje jeszcze ldconfig
Logged